[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

How to configure these on Cisco Router 881?

Posted on 2013-12-11
8
Medium Priority
?
1,666 Views
Last Modified: 2013-12-17
I want to setup this router as an Internet router for the following objectives:

   1. There are 2 interfaces - VLAN1 for internal network, and FE4 as WAN interface for Internet line. I have subscribed a Internet line with the ISP on dynamic IP plan. What I have to configure on the WAN interface is just set it to DHCP, and all ip addressing will be allocated. These include, IP assigned to the WAN interface, subnet mask, default gateway, dns server ips, etc.

      How should set these settings on the FastEthernet4 interface? How about the default gateway? Shall I point it to the FE4 or else?

   2. I also need to setup this router as a DHCP server for my network - 192.168.100.0/24. There are few IPs have been assigned to few servers, and no-changeable. These IPs are,
.100.5, .100.25, .100.144, .100.188; how can I exclude these IPs on my router, suppose my DHCP pool is ranging - .100.51 - .100.200?


thanks in advance.
0
Comment
Question by:MichaelBalack
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 1

Author Comment

by:MichaelBalack
ID: 39711448
I nearly forget, how to set the NAT on this router?
0
 
LVL 22

Assisted Solution

by:Matt V
Matt V earned 400 total points
ID: 39714804
DHCP Pool:

ip dhcp pool DHCPPOOL
  network 192.168.100.0 255.255.255.0
  default-router 192.168.100.1 (this is your LAN IP of router)
  dns-server x.x.x.x x.x.x.x (specify DNS server here)
 
Allow DCHP to set the default route, specifying the interface does not always work.
0
 
LVL 22

Accepted Solution

by:
Jody Lemoine earned 1600 total points
ID: 39715028
mattmvotas has covered the basics of your DHCP pool for your VLAN1 clients, but you still need to restrict the pool. Cisco routers assume that they can assign the entire subnet, so to set your pool you need to tell the router what range to exclude. Use the following for a pool of 192.168.51-200.

ip dhcp excluded-address 192.168.100.1 192.168.100.50
ip dhcp excluded-address 192.168.100.201 192.168.100.254

To exclude the individual hosts with static IPv4 addresses, a simplified version of the same command it used. You don't actually need to exclude the first two of these because they're already covered by the ranges used to restrict your DHCP pool.

ip dhcp excluded-address 192.168.100.5
ip dhcp excluded-address 192.168.100.25
ip dhcp excluded-address 192.168.100.144
ip dhcp excluded-address 192.168.100.188

For the WAN interface on FastEthernet4, go with this. The "ip dhcp client request" line is actually a default, but I'm including it to illustrate what's going on.

interface FastEthernet4
 ip address dhcp
 ip dhcp client request router dns-nameserver
 ip dhcp client default-router distance 1
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:MichaelBalack
ID: 39715649
Hi mattvmotas and jodylemoine,

How about the nat? for vlan1 and fa4?
0
 
LVL 22

Expert Comment

by:Jody Lemoine
ID: 39715653
That's fairly straight-forward.

object-group network og-rfc1918
 10.0.0.0 /8
 172.16.0.0 /12
 192.168.0.0 /16
!
ip access-list extended acl-nat
 permit ip object-group og-rfc1918 any
!
ip nat inside source list acl-nat interface FastEthernet4 overload
!
interface Vlan1
 ip nat inside
!
interface FastEthernet4
 ip nat outside
0
 
LVL 1

Author Comment

by:MichaelBalack
ID: 39715658
Hi jodylemoine,

Thanks for the speedy reply.

Then for the default gateway, is this command: ip route 0.0.0.0 0.0.0.0 interface fastethernet4
works?
0
 
LVL 22

Expert Comment

by:Jody Lemoine
ID: 39715664
If you want to define your default gateway manually, "ip route 0.0.0.0 0.0.0.0 dhcp" will do the trick, but if you're getting the default gateway from DHCP, it shouldn't be needed. I would set up your DHCP connection and do a "show ip route" to see if it has installed the route for you before adding it manually. If you already have a 0.0.0.0/0 route, you don't need to add one.
0
 
LVL 1

Author Closing Comment

by:MichaelBalack
ID: 39725640
Excellence, it works like a charm
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question