[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 459
  • Last Modified:

RDP into Server 2012 Standard Issue

I have a new 2012 standard server, set up as a DC, not a part of my domain nor will it be. I have enabled Remote Desktop access, firewall is off, and I believe I have correctly configured RDP services on the machine (it will primarily be a "terminal server"). I can RDP to other machines on my domain from it. RDP services appear to be started and running appropriately, or at least the ones I am familiar with.

But no matter what I do or configure, I can NOT rdp into the 2012 server from my Win7 machine or any other machine on my domain.

The server came from a software company who actually performed the install and configuration, and from what I can tell/find, they did nothing to prevent RDP access into the server.

I'm at a loss at this point as to why I can't rdp into this thing.
0
tjwo94
Asked:
tjwo94
  • 4
2 Solutions
 
achaldaveCommented:
There can be anything from changed default RDP port, custom firewall, some other application listening on same port or encryption requirement.

Since the server came from software company, is it running any proprietary application on it? It is possible they don't want you to login using RDP, you might want to check if enabling RDP breaks any license agreement.

you can use netstat -anb or netstat -ano command to identify application listening to port 3389 (default RDP)

Check TDP-TCP properties under Remote desktop configuration for SSL and network configuration, check security for any deny permission.

To check if RDP is listening on non default port or not open regedit
check PortNumber under HKLM\System\CurrentControlSet\Control\Terminal Server\Wds\rdpwd\tds\tcp

Also make sure fDenyTSConnections is set to 0 under
HKLM\System\CurrentControlSet\Control\Terminal Server\
0
 
tjwo94Author Commented:
I have checked the registry locations, both are fine.
No applications are currently listening on port 3389.
No encryptions exists, nor custom firewall policy.

Not sure where to look for the TDP-TCP properties you mentioned.
0
 
tjwo94Author Commented:
So I called the software company to verify if they changed something I can't find to prevent me accessing this port. They did.

They changed the default port from 3389. However, when I check this in the registry, it says the port is 3389. What gives?
0
 
tjwo94Author Commented:
Ah, this is why.

The appropriate registry key to check for default RDP port is this:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber

Thank you for the help!
0
 
tjwo94Author Commented:
Splitting points for both efforts to diagnose issue. Had to do some more of my own leg work to find the correct issue, but you definitely pointed me in the right direction, and helped to eliminate some other causes.
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now