certificates for Exchange 2010

We have created two SAN certificates

Internal (service: IMAP, POP, UM, SMTP)
exdag.abc.com, ex01.abc.com, ex02.abc.com, mail.abc.com , autodiscover.abc.com

External (service: POP, IIS, SMTP)
mail.abc.com, autodiscover.abc.com

If we use the internal certificates within IIS service it always pops up for certificate warning message until we bind the IIS service on it. However, the external access to web mail will not work within the IIS service binding on the external certificate.

Currently, we have changed all the CAS to refer mail.abc.com in external URL. I was told that it can create an internal certificate for internal use a public certificate for external use. However, it doesn't work as expected. Any idea ? Can I make the internal certificate work without IIS binding ?

For this change, will the DAG work as expected ? In case the EX01 is down, will the EX02 take up the work actually as I have already changed all the CAS internal & external reference to mail.abc.com.  

Great Thanks.
AXISHKAsked:
Who is Participating?
 
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
The simple way is to use the external host name internally and have one SSL certificate for everything. This is easily setup within Exchange and AD.

http://semb.ee/hostnames

Simon.
0
 
MaheshConnect With a Mentor ArchitectCommented:
You cannot bind multiple SSL certificates to IIS service (Default web site) on CAS server.

If your have internal and external URLs are same (Split DNS), then you can use single external certificate for IIS and you don't require internal SSL certificate.

If you want to use seperate certificates with internal and external url, then  you need to create one more owa virtual directory

http://blogs.technet.com/b/exchange/archive/2011/01/17/configuring-multiple-owa-ecp-virtual-directories-on-exchange-2010-client-access-server.aspx

Mahesh
0
 
AXISHKAuthor Commented:
We are using exdag.abc.com but if we change it to mail.abc.com, will it work as expected ?

Tks
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
Simon Butler (Sembee)ConsultantCommented:
As long as DNS and Exchange are setup correctly and the certificate is trusted it will work fine. You can use any name that you like.

Simon.
0
 
AXISHKAuthor Commented:
EXDAG is created when creating the DAG for both Exchange servers. EXDAG DNS record can update directly by Exchange if the other pair is down. Outlook is pointing to the server name EXDAG.

In case I change it to mail.abc.com, does it mean that I need to update the DNS manually ... the automatic failover feature in Outlook is lost.

Base on the URL, I can't fix out what I need to setup on my Exchange. Is there any further detail or example ?  Tks


http://blogs.technet.com/b/exchange/archive/2011/01/17/configuring-multiple-owa-ecp-virtual-directories-on-exchange-2010-client-access-server.aspx
0
 
MaheshArchitectCommented:
How your outlook is pointing to EXDAG (DAG \ Cluster virtual account if i am not wrong) ?

As long as outlook is able to connect to CAS array \ CAS server,You should be able to connect

Check below articles for more details
http://technicaljeditrials.info/2011/02/28/exchange-2010-multiple-owaecp-directories-part-1/
http://johnyassa.wordpress.com/tag/multiple-owa-ecp-virtual-directories/

Mahesh
0
 
AXISHKAuthor Commented:
I have changed to use the external certificate mail.ktl.com.hk internally. Have make this reference under Outlook Web App, Exchange Control Panel, Exchange ActiveSync, Offline Address Book Distribution.

When I start the outlook, it still pop for a server EX01 ? We have DAG group "EXDAG" with two physical servers named "EX01" & "EX02". In fact, the public certificate "mail.abc.com" is used to check "EX01". Any idea ?

Tks
eCert.png
eCert-1.png
0
 
Simon Butler (Sembee)ConsultantCommented:
The DAG name should not be used for anything else, such as Outlook connectivity.
The RPC CAS Array name should not be used for anything other than MAPI TCP traffic.

You should have a unique host name for both of those, neither of which needs to be in the SSL certificate. You should have another host name for SSL based services.

You cannot change all references in EMC. You have to make modifications via the Shell - see the article I posted above.

Simon.
0
 
AXISHKConnect With a Mentor Author Commented:
Are u talking about the link "http://semb.ee/hostnames" ??

"You should have a unique host name for both of those, neither of which needs to be in the SSL certificate. You should have another host name for SSL based services."

What do you mean ? Sorry for that ...
0
 
MaheshArchitectCommented:
Your DAG FQDN must be different than CAS array
DAG FQDN should not be used for outlook connectivity and both are not required in certificates.

Instead of struggling with having seperate names for internal and external, why don't you set internal and external URLs same and just use one public certificate for all, its easier and requires less configuration.
Only thing you need to setup split DNS so that external names can be resolved in private network with private IP

Simon already has provided you with required info with nice article in his earlier comment.

Mahesh
0
 
AXISHKAuthor Commented:
Yes, I have already used the public certificate for internal & external. And pop for that message... guessing I still miss something but I can't identify at this stage.
0
 
MaheshArchitectCommented:
What problem exactly you are facing, if you could brief as appropriate please with any screen shots

Mahesh
0
 
Simon Butler (Sembee)ConsultantCommented:
Did you go through the article that I posted and checked everything? There a few that are easily missed, such as the setting on get-clientaccessserver

Simon.
0
 
AXISHKAuthor Commented:
Hi,
For identify "CAS-Server" is it talking about the actual host name, ie EX01 & EX02 in my case ?

Tks


Autodiscover URL:
Set-ClientAccessServer -Identity "CAS-Server" -AutodiscoverServiceInternalUri https://mail.example.net/autodiscover/autodiscover.xml

Web Services URL :
Set-WebServicesVirtualDirectory -Identity "CAS-Server\EWS (Default Web Site)" -InternalUrl https://mail.example.net/ews/exchange.asmx -ExternalUrl https://mail.example.net/ews/exchange.asmx
0
 
Simon Butler (Sembee)ConsultantCommented:
The reference is the actual name of the server.
If you do

get-clientaccessserver | select identity

then you will see what it is looking for.

Simon.
0
 
AXISHKAuthor Commented:
Tks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.