Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 322
  • Last Modified:

ASP.NET VisualStudio 2008 error

I have a web application written in C# in Visual Studio 2008. It was an working application that I compiled and run on my local PC(windows 7).

but now I get the error:
unable to connect to the asp.net development server

When I run the application, the compilation succeeds but then it returns the error. I attached the screenshot.
error
Could you please suggest me how to fix the error? Thanks a lot.
0
toooki
Asked:
toooki
  • 5
  • 4
1 Solution
 
TheAvengerCommented:
Right click on the project and select properties. Then go to Web and change the configuration options, i.e. change from local server to a remote and then back. Just change them as you need them, save and retry.
0
 
toookiAuthor Commented:
Thanks a lot. When I right click on the project and select properties. Then go to Web, I get the attached screen below.

error
Could you please let me know which one I change here under the "Servers" menu?
This is my PC file folder:
C:\PDPM\int_2.11\PDPMWebSln\ProductHealth\ProductHealthDashboard.aspx (which is my start page).
0
 
TheAvengerCommented:
Try selecting Current page at the top and Specific port at the middle
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
toookiAuthor Commented:
Thanks but sorry I still get error.
error
0
 
TheAvengerCommented:
A person reports that the web server was stuck. Have you tried restarting the machine? Or just killing the process "WebDev.WebServer40.EXE" (or similar, this one is for VS 2010)?

Another option: Replace WebDev.WebServer.exe with another exe C:\Program Files (x86)\Common Files\microsoft shared\DevServer\9.0\WebDev.WebServer.exe. Restart your machine .
0
 
toookiAuthor Commented:
Thank you. I killed the processes like WebDev.WebServer40.EXE and tried. I got the same error.

Then I restarted the PC and then run. This time I get a different error (It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. ) and I attached the screenshot. Could you please suggest what could cause the error?
error
0
 
TheAvengerCommented:
Can you try to use the standard IIS instead of the development one? It is done at the same place in the properties of the project but you need to have IIS installed locally. If this one runs, then your development server is damaged and you might need to reinstall VS
0
 
toookiAuthor Commented:
Thank you. But I think I am in big problem. Now I right-click on the project and do not see the "Property" menu any more.
error
0
 
TheAvengerCommented:
You have to click on the project itself, not on a folder in it.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now