Solved

Website loads very slow , please advice on the cause

Posted on 2013-12-13
12
306 Views
Last Modified: 2014-01-05
Hi all ,

We got a website to test , but it was loading very slow.

I checked using pingdom.com and it says page load time as   60.00s

Then i used firebug and yslow in firefox but unable to identify why its loading very slow .

Its residing on windows server , can you please suggest your ideas why its taking so much time and if possible how to fix it.

The URL is <<<signup(dot)activitybox(dot)ca>>>

Thanks in advance

Thanks,
Magento
0
Comment
Question by:magento
  • 5
  • 3
  • 2
  • +1
12 Comments
 
LVL 82

Assisted Solution

by:leakim971
leakim971 earned 167 total points
ID: 39716966
I think it's a server side issue.
create an account here to start using this tools : http://newrelic.com/
0
 
LVL 31

Accepted Solution

by:
Marco Gasi earned 167 total points
ID: 39717001
If you use Firefox, you can install Firebug and YSlow. Yslow is an extension which gives suggestions in order to improve speed of site. I attach a screenshot whoch represents the first view of YSlow testing your site (as a side note, you can type a plain url: it easier for use to visit your site and it doesn't present any security issue)

YSlow report
0
 
LVL 18

Expert Comment

by:Steven Harris
ID: 39717006
49173 ms First Byte Time

Have you checked DNS setup?
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 5

Author Comment

by:magento
ID: 39717020
Leakim971,

Just signed up , need to install those apps later.

MarqusG,

yes, i did the yslow but not sure where the problem lies.

Thinkspacesolutions,

Can you please advice on how to check up the DNS ?

Thanks
0
 
LVL 31

Expert Comment

by:Marco Gasi
ID: 39717129
Don't know about other possible solutions, but seeing YSlow report it seems you have a lot of work to do: I think you should begin to fix some issues nad see if this improves the speed of the site, then go on to another issue and so on.
0
 
LVL 82

Expert Comment

by:leakim971
ID: 39717138
Your browser do the request and receive an answer 40s after
Once it receive the main document, others resources are loaded VERY quickly

So you've a process taking a huge time to build your page (index.php) and be able to send it.
0
 
LVL 18

Assisted Solution

by:Steven Harris
Steven Harris earned 166 total points
ID: 39717182
As far as DNS is concerned, you don't appear to have any SOA records.

Besides that, I would have to agree with marqusG, there seem to be a lot of small errors that are all adding up.

I would start with HTML and CSS validation:

4 HTML Errors
2163 CSS Validation errors.
0
 
LVL 5

Author Comment

by:magento
ID: 39717430
ThinkSpaceSolutions,

Yes i see i dont have the SOA records by running that command in putty .

So how to get that fixed , whom i need to contact .

Also how to check the HTML and CSS validation , so i can ask my collegues to work on fixing it.

Thanks,
Magento
0
 
LVL 5

Author Comment

by:magento
ID: 39717451
Leakim971,

>>>So you've a process taking a huge time to build your page (index.php) and be able to send it.

Can you please provide more explanation on the above.

As far my understanding once this is fixed  then the site will be good.

So how to find that process? In unix i think we can find using TOP command . Not sure how to check in windows server.

Thanks,
Magento
0
 
LVL 82

Expert Comment

by:leakim971
ID: 39717490
I've no idea, that's why I ask you to use new relic, it will help you to do more than resolve the current issue.
0
 
LVL 5

Author Comment

by:magento
ID: 39718269
Thanks everyone.

I have a question, If its a server issue ,when i load an image into the root path and access it like

www.domain.com/image.jpg

Then i get immediate response and also the backend its loading fast .

Please advice.

Thanks,
Magento
0
 
LVL 5

Author Comment

by:magento
ID: 39747624
Hi ,

We did lot of analysis using the above comments and finally the problem is with the fonts of the theme .

I will promptly close this thread  by latest Jan 2nd.

Happy Newyear wishes !!!

Thanks,
Magento
0

Featured Post

MIM Survival Guide for Service Desk Managers

Major incidents can send mastered service desk processes into disorder. Systems and tools produce the data needed to resolve these incidents, but your challenge is getting that information to the right people fast. Check out the Survival Guide and begin bringing order to chaos.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Since pre-biblical times, humans have sought ways to keep secrets, and share the secrets selectively.  This article explores the ways PHP can be used to hide and encrypt information.
Introduction This article is intended for those who are new to PHP error handling (https://www.experts-exchange.com/articles/11769/And-by-the-way-I-am-New-to-PHP.html).  It addresses one of the most common problems that plague beginning PHP develop…
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.
The viewer will learn how to create a basic form using some HTML5 and PHP for later processing. Set up your basic HTML file. Open your form tag and set the method and action attributes.: (CODE) Set up your first few inputs one for the name and …

679 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question