Inserted entry from MCE editor is not rendering HTML on query...

I'm using MCE editor and the entry in the db for each post is something like...

&ltp&gtLorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque placerat risus lacus, eu mollis lorem venenatis ut. Donec imperdiet turpis elit. Suspendisse lobortis commodo elit, et laoreet elit.&lt/p&gt

when I <cfoutput> the result to the front-end I get <p>Lorem ipsum.... </p>

Open in new window


I would like for it to actually render the value as HTML
brihol44Asked:
Who is Participating?
 
dgrafxConnect With a Mentor Commented:
in your tinymce init - do you have an entry for entity_encoding?
set it's value to raw if yes or add it if you don't so that it's:
entity_encoding:"raw"

that might help.
0
 
dgrafxCommented:
i'm guessing you mean that you want to show the html entities that are in the db instead of the browser converting them to tags or symbols - correct?

use:
<pre><code>
&ltp&gtLorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque placerat risus lacus, eu mollis lorem venenatis ut. Donec imperdiet turpis elit. Suspendisse lobortis commodo elit, et laoreet elit.&lt/p&gt
</code></pre>
0
 
brihol44Author Commented:
Well, I want them to actually render as HTML so I dont' see <p>  tag or any reference to it. I'm not sure why it's not actually adding it as HTML but instead showing it on the page. I suppose I have to figure out how it's getting in the db first? The MCE editor automatically adds the <p> tags in the entry but it's converting to &ltp&g when it posts the entry to the db.

Thanks for the help!
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
dgrafxCommented:
You do mean inside the editor - correct?
Are you viewing html source?
Just checking.

Are you saying that when you insert <p> into the db - then when you look in the db it has been converted to &lt;p&gt ?

if yes then what init settings do you have in mce editor for entity_encoding?
And also are there settings for MySql concerning this?
0
 
brihol44Author Commented:
Hi,

Well it's showing the "<p>" tag actually on the website (dev) on the front page that people see.

Inside the editor it shows correctly in that I only see text. When I click on the "HTML" view button it's...

<p>Loren ipsum.... </p>

My Table info is...

Table Type MyISAM
Default Char Set : utf8
Default Collation: utf8_general_ci


entity encoding :
entity_encoding : 'named',
0
 
brihol44Author Commented:
oh and...

Are you saying that when you insert <p> into the db - then when you look in the db it has been converted to &lt;p&gt ?
No MCE actually inserts the <p> tag automatically which is fine. My only issue is that it's showing <p>Loren ipsum... </p> that is displaying on the front-end.

The entry in the db is...  &ltp&gtLorem ipsum dolor sit amet, consectetur adipiscing elit. Curabitur dapibus, turpis vitae congue hendrerit, purus libero semper turpis, quis egestas tellus augue a odio.&lt/p&gt
0
 
dgrafxCommented:
For experimentation's sake manually edit the db and replace the &lt;p&gt with <p> and the same for closing.
Then look at the webpage.

does the problem go away or is it the same issue?
0
 
brihol44Author Commented:
Doing that does work so I guess I have to figure out why MCE is converting the <p> tag to &lt;p&gt. I don't know much about the editor so I'm not too sure yet.
0
 
brihol44Author Commented:
I ended up using coldfusion to replace the arrow values. I tried all of the things you had mentioned. I'm not sure what's going on with it.
0
 
dgrafxCommented:
well - thanks for the points!

and i hope you get it squared away!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.