how to remove "read only" from folders

I am needing to change the attributes on folders in windows 8 from "Read only" to full permissions and windows 8 will not allow me to do this.  
I can change it but it goes right back to read only again.  
how do I make this change permanent?
Who is Participating?
Steven HarrisConnect With a Mentor PresidentCommented:
Would you happen to be running Kaspersky AV?

If not, you may want to try running the App Troubleshooter.

downloaded and installed "take ownership" app
This may be the ultimate issue...  I am not familiar with that program, and would have done this manually myself.

Most likely during the process the app did not retain permissions for the ALL APPLICATION PACKAGES principle.

ALL APPLICATION PACKAGES needs the following permissions to execute properly:

Read & execute, List folder contents and Read in the following locations:
     C:\Program Files (x86)
     C:\Program Files

List folder and read data, Create Folders and Append Data


To check for this principle: right-click on a folder or file in the file system > Properties > Security Tab > Advanced.
Michael-BestConnect With a Mentor Commented:
beemmerAuthor Commented:
I am logged in as administrator.  The computer only has one account (Ron).  I have just installed a fresh copy of windows 8, so I am confident there are no viruses.
Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

nashim khanConnect With a Mentor Exchange AdministratorCommented:
To do the subject changes, you need to have local administrator rights.

First verify the user is an administrator to not. If you are an administrator user, then you can do it easilly. If facing the issue, then there is an issue with user rights. To fix the issue you need to digg in registry.

First you check the user and then verify the same. Once it get fix no need to digg in registry.

Revert if you are still unable to fix the same.

Steven HarrisConnect With a Mentor PresidentCommented:
Building off of Michael-Best's link, it should be noted that in Win8 you should first take ownership of the entire drive and all sub-folders/files.  This will allow you to take and set permissions as needed without SYSTEM reverting the privileges.
beemmerAuthor Commented:
Ok, I did as you said - I took ownership (downloaded and installed "take ownership" app) When I did that, my issue on that part was solved.  But now it appears that I have created another problem.  When I go from the desktop to the start screen and click on any of the apps, such as the weather, Calander, or Maps, they will not work.  For instance, if I click on "weather", it will flip over like it is going to run, and then go right back to the start menue page.  
Does anyone know how I can fix this issue?
beemmerAuthor Commented:
I guess i will have to admit that when it comes to this part of windows I just have never caught on to all this permissions thing.   I am sending you some snapshots of the folder propterties to see if you can help me further with this.

 I have always been able to install the operating system, install any app I wanted to and had no issues.  
  The apps that I installed are working fine.  The apps that are not working are some of the apps that came pre-installed with windows.
Steven HarrisConnect With a Mentor PresidentCommented:
So far you are on the right track.

For each of those locations, ALL APPLICATION PACKAGES needs to be added.

Hit Edit > Add

In the text box, type 'all app' (without quotes) and then the Check names button.

Hit OK > Apply > OK
beemmerAuthor Commented:
Thanks for helping me with this issue.  I found out that I was dealing with a disk configured originally as GPT.  Once I figured that out and changed settings correctly everything worked fine.  
 One thing that was interesting to me was that if I went into BIOS and changed the setting from GUID to LAGACY and attempted to install Windows would say that it could not intall because there was an MBR table on the hard drive and if I set the BIOS to GUID it would say it could not install because the there was a GPT table on the hard disk
 Apparently I need to take some schooling on all of that.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.