Can I install an older version of Adobe Flash?

I was having problems with the latest Flash and uninstalled it a couple of weeks ago. I decided I want it for a few things. I found that the older vesions are available as archives so I tried to install an older version (10.3 for XP/Firefox). It won't let me install it.. I get the following message:

...
Can I stop this and successfully install?

Thanks
LVL 12
Missus Miss_SellaneusAsked:
Who is Participating?
 
John HurstConnect With a Mentor Business Consultant (Owner)Commented:
Here is another Adobe Support article for uninstalling a prior version. Perhaps it will help.

http://helpx.adobe.com/flash-player/kb/install-previous-version-flash-player.html

If you can use the current version, it is easier to stay current than try to use older versions.

... Thinkpads_User
0
 
John HurstBusiness Consultant (Owner)Commented:
The only good place I saw for old versions of Flash was this Adobe site:

http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

But these versions are for developers. In any recent number of years, users have not been able to download Flash. That is probably what is happening to you.  So then you need to use the most recent version, which seems to work ok.

... Thinkpads_User
0
 
Missus Miss_SellaneusAuthor Commented:
Ya, that's where I found the old version.

I just needed to run the uninstaller which I already had. Apparently uninstalling the last newer version through "Uninstall" didn't completely. I've got the old version installed.
0
 
John HurstBusiness Consultant (Owner)Commented:
Thanks for the update and I was happy to help.

... Thinkpads_User
0
All Courses

From novice to tech pro — start learning today.