• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 956
  • Last Modified:

VPN problems on Sonicwall TZ210

I am using net extender to create a VPN from my laptop at home. My laptop at home has a dynamically assigned IP address from my router at home. My home router is a netgear.

My VPN was working fine for a long time. I would connect to my work network using net extender. Then i would launch a remote desktop and type in the server name that i wanted to remote into. RDP just times out. However, if I type in the IP address of the server I am able to log in.

Also i have mapped drives that do not work if using the server name however when I use IP address it works fine.

My home gateway is on and my work gateway is

My home computer is a laptop that is on a domain. It used to be a workstation at work. So when i login it is not authenticated by a DC. I just login using my name@mydomain.com and password and I never have a problem.

I did notice however that when I dolog into VPN successfully I no longer have local internet access. So in order to google search I have to disconnect from Net Extender, launch google, then log back in. Is that normal also since i am in tunnel mode?
1 Solution
Blue Street TechLast KnightsCommented:

NetExtender in tunnel all mode forces all traffic to be routed over the SSL-VPN adapter. To allow your end users access to internet over the UTM-SSLVPN, you will need to allow “WAN RemoteAccess Networks” (a network address object whose value acts like a default route), and the Tunnel All option must be selected on the Client Routes page.  The method below is appropriate when the administrator wants all of their NetExtender users to have their internet access provided through the SSL-VPN otherwise disable Tunnel All mode.  Be sure that you are not overwhelming the internet bandwidth at the location where the firewall is installed, as this traffic will be added to the other loads from inside the network.
Step 1: On the SonicWALL, go to SSL-VPN > Client Routes screen, enable the Tunnel All option in the drop down menu.

Step 2: On the Users > Local Groups screen, configure SSLVPN Services group and under tab “VPN Access,” add the object WAN RemoteAccess Networks.

Step 3: No custom rules are needed on the Firewall > Access Rules screen for this to work.  You can see auto-added rules in the section SSLVPN to WAN.
Make sense?
Ramakrishna PrabhuNetwork EngineerCommented:
Agree with diverseit
MEATBALLHEROAuthor Commented:
That sounds like it will solve the internet connection issue. However, my big problem is that I can not connect via host name  using RDP. i used to connect my secure vpn and then RDP using my server name MYSERVER01 and now I can only connect to this server if I type in the IP address.

When I type NSLOOKUP in CMD Prompt I get the DNS server IP address from my office because I'm in tunnel mode,  but not the DNS server name. It says unknown.

Did I screw something up on my remote client side or is this a active directory DNS issue on my office network side?
The problem is it appears you have a tunnel misconfiguration issue. You need to setup a split tunnel and forward DNS so you can have Internet through your home connection but utilize the forwarded DNS to resolve the hostnames of your work servers so your file shares work.
Blue Street TechLast KnightsCommented:
It is not a misconfiguration to have Tunnel All mode enabled nor is it the appropriate fix to use a Split Tunnel if that is not desired! My solution (http:#a39719094) is a validated one and is accurate if you want to stick with Tunnel All mode, which will force all the traffic through to the your Office securely.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now