Solved

dd-wrt setup with ics from tethered phone

Posted on 2013-12-15
29
400 Views
Last Modified: 2014-01-01
I'm trying to setup my e1000 recently flashed with dd-wrt. ICS is setup with a NIC address of 192.168.137.1. The WAN IP is a dynamic address of 192.168.137.X. The router is DHCP of 192.168.1.X. The PC reports no internet connection on the NIC that is connected to the router internet port as well as the LAN port the printer is connecred to. No wireless internet either. What type of setup do i need.
0
Comment
Question by:ssurbrook
  • 16
  • 13
29 Comments
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
On the Status tab of your DD-WRT, what is the full line after
Firmware Version ?

Did you try doing a 30-30-30 reset, then a power cycle, then hookup the ICS to the WAN port and seeing if the ICS was giving a working internet connection to the WAN port?

Did you try turning off the windows firewall?
0
 

Author Comment

by:ssurbrook
Comment Utility
Firmware: DD-WRT v24-sp2 (03/25/13) mini

Yes, I did the 30/30/30 reset and the power cycle, hooking up the ICS to the WAN port.

I'm using Kaspersky and did turn off the firewall.
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
Sorry... I should have said Status tab, Router sub-tab. i.e. There should be a build number, too.

Are you still using the trailed build, or did you switch to some other mini?

What's the FCC-ID printed on the barcode sticker?
0
 

Author Comment

by:ssurbrook
Comment Utility
Here's the Status>Router png. Haven't switched mini's. The writing is pretty small but appears to be FCC 087-E1000. I'm curious about your inquiry to the FCC number. I've never had anyone ask me that before.

It is running in Client Bridge mode with the CAT 5 linking the PC NIC and one of the router LAN ports. Status_Router
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
It's apparently Q87-E1000
You might be surprised by the information you can find about a device from its FCC-ID.

http://transition.fcc.gov/oet/ea/fccid/
Note the dash counts as part of the product code.


> It is running in Client Bridge mode with the CAT 5 linking the PC NIC
That sounds like the problem.

In Wireless -> Basic Settings set Wireless Mode to AP.

In Setup -> Basic Setup the WAN Connection Type should be Automatic Configuration - DHCP.
Enable the DHCP server under Network Address Server Settings (DHCP).

In Setup -> Advanced Routing make the Operating Mode Gateway.
(that setting should also work as Router for this situation.)

Connect the PC's NIC to the WAN/Internet port (the only way ICS could be giving the WAN port a DHCP address in the 192.168.137.x range, so I'm not sure how you're hooked to a LAN port too).
0
 

Author Comment

by:ssurbrook
Comment Utility
I made the mistake of having 2 Ethernet connections since I have 2 NICs. I've disable one and removed the 2nd CAT-5. Now only using 1 LAN port. I can get wireless connectivity to the router but still no internet access on that device.
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
If you're not connected to the DD-WRT's WAN/Internet port, disable its DHCP server... then the ICS DHCP server should assign 192.168.137.xxx IPs to clients that connect through the E1000.
0
 

Author Comment

by:ssurbrook
Comment Utility
I provided an overview of the Network and Sharing Center.Network and Sharing Center
I noticed something in the connection details that may be a problem. My phone modem can't be configured for DHCP Configuration nor DNS Configuration. See Mobile Connection Details attachment.Mobile Connection Status
When ICS is applied, the LAN IP is statically set to 192.168.137.1 which is fine. However, once ICS is applied, the DCHP Configuration changes from yes to no. When I try to change it through a netsh command, the IP address is reset and no longer communicates with the phone modem. See LAN Connection details attachment.LAN Connection Status
I only have one router that is connected via LAN port to a PC NIC that is ICS'd to the phone modem.

In DD-WRT, I'm presently set as AP as you can see in the final attachment. This seems to be the only way to broadcast my SSID for clients.Present E1000 system info
Given this, my ultimate problem is how to get the E1000 to talk to either the LAN connection or modem connection, as well as have DHCP and DNS applied.
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
What method are you using to connect to the mobile provider?

The DHCP Enabled setting of the NIC doesn't matter. Its IPv4 address should be statically set (by ICS) to 192.168.137.1, and the ICS DHCP server's function is internal to windows, not controlled by that adapter.

Change the LAN IP of the E1000 to 192.168.137.250 because the first address the ICS DHCP server is likely going to try to assign is 192.168.137.2, which would create a duplicate IP situation because the LAN interface of the E1000 already has that IP statically assigned.

Don't forget to disable the DHCP server in the E1000.  :)
0
 

Author Comment

by:ssurbrook
Comment Utility
it is through AT&T. The phone is a BlackBerry Torch 9810 using 3G I believe via dialup to a wireless tower. BlackBerry indicates is H+ but I think that is equivalent to 3G.

Good point on the router IP. I didn't factor that in. I'll disable the DHCP and report back.
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
> it is through AT&T
Right, but how are you telling it to connect?

Are you using some software they gave you, or did you Add... a connection on the Connections tab in Internet Options and tell it to dial *98 (or *99... those are the only 2 numbers to dial on GSM networks that I know of).
0
 

Author Comment

by:ssurbrook
Comment Utility
Sorry I didn't understand earlier. Yes, I'm using AT&T Communication Manager, version 7. Version 9 is not compatible. I wondered if this may be a problem but it's all I have unless you have another suggestion.

I applied your suggestion. Presently, the router is 192.168.137.250 with DHCP server disabled. I still have no internet but can wirelessly configure the router. I tried pinging 192.168.137.1 with no success.
0
 

Author Comment

by:ssurbrook
Comment Utility
I switched over to the BlackBerry Desktop Software to give that a try. Same result. Same ICS IP.
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
Make a manual dialup connection for it.

Click the 'start' orb, type in inetcpl.cpl and hit Enter.
Go to the Connections tab.
Click Add...
Choose Dial-up
Select the data modem (your phone) from the list
For the number to dial, enter *98
Check all 3 boxes... you may need to OK a UAC prompt for one
For this demonstration I named the connection Data Modem
Leave the username / password blank, and click ConnectInternet options - Connections - Manual Add (click for larger)
The connection might fail... if so, click Set up the connection anywayConnections - Manual Add - Set up anyway (click for larger)
If it connects successfully, just note what it says at the bottom and click Close.Connections - Manual Add - Connection Successful (click for larger)
Back in the Internet Properties dialog (Internet options), I select the Never dial a connection option (because that's not the primary way I connect to the internet; your mileage may vary), highlight the connection you just added and click SettingsInternet Properties - Connections - Settings
In the next dialog, click PropertiesConnections - Settings - Properties
Go to the Options tab and UNcheck the Prompt for name and password, and Prompt for phone number boxes.Internet Properties - Connections - Settings - Properties - OptionsGo back to the General tab and click ConfigureInternet Properties - Connections - Settings - Properties - Generalin the modem configuration dialog, check the 3 boxes indicated (all except enable modem speaker), and set the data rate to the highest allowed (should be at least 921,600) Internet Properties - Connections - Settings - Properties - ConfigureFinally, on the Sharing tab, set it to share that connection and select the NIC (typically named Local Network Connection) as the adapter to share it with... when you do so you should get a popup noting that sharing was already enabled on some other modem, but it will now be enabled on the new device.ICS swap notice
Finally, click the 'start' orb, type in ncpa.cpl and hit Enter.
Right-click on the 'Data Modem' connection you made and select Create Shortcut
You'll get a dialog asking if you want to create the shortcut on the Desktop instead.
Answer Yes.

Now the reason I went through all this is sometimes the connection managers provided by the carriers actually disable all other network adapters while they connect you.  They do that because they want to rent you a different device to share the connection with multiple people... the thing is, their roadblocks prevent you from using network printers, et al, while you're tethered using their connection managers.

So use that desktop shortcut to connect (or click the network icon in the Notification Area, then click the 'Data Modem' created and a 'Connect' button will appear), and see if the tethering to  ICS to DD-WRT all works without ATT's software in the loop.

Oh, and if you can't get it to connect at all using *98, review the screen grabs... on the General tab of the modem's Properties dialog, change that to *99 and try again.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:ssurbrook
Comment Utility
Excellent details, thank you. I haven't been able to attempt it yet but it all makes sense. The BlackBerry software trial connected but performed the same way. I should have time tomorrow to attempt your solution.

Thanks so much for your time on this subject. It's been a loooong time since I've had to deal with dialup, let alone a wireless internet connection.
0
 

Author Comment

by:ssurbrook
Comment Utility
Ok Myagi (:-) just about there. About the only thing I had to change was the *99 to *99# based on what I saw through a comparison between the corporate software the the created dial up connection.

Here's the next piece of the puzzle. How do I keep the ICS without disconnecting? As long as I'm connected from the initial setup, I have internet shared through the router and is performing exactly as I want it. Once I disconnect, the LAN NIC reverts back to no internet access.

Here's some screen shots of the configuration.Data Modem Pre ICSModem ConfigurationModem Properties - OptionsModem Properites - SecurityModem Properites NetworkingModem Properties SharingModem SetupModem ConnectedModem ICS'd
You've been a tremendous help!
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
> How do I keep the ICS without disconnecting?
> As long as I'm connected from the initial setup, I have internet shared
> through the router and is performing exactly as I want it. Once I
> disconnect, the LAN NIC reverts back to no internet access.

I'm not sure what you're saying there. e.g. What does, "Once I disconnect," mean?
If you want it to connect when other users try to access the internet, check the 3rd box on the Sharing tab, too.

Then, note which of the 3 dialing radio buttons is checked in the Internet Options -> Connections window.

If you want it to stay connected all the time (unlimited minutes; unlimited bytes), choose Dial whenever a network connection is not present

If you want it to (re)connect (after the 20-minute timeout has occurred; you could shorten that time if you don't have unlimited minutes) only when ICS senses a device that's connected to the NIC is trying to access an IP address outside 192.168.137.*, choose Always dial my default connection.  And, of course, select 'Data Modem' in the list of connections above that and click the Set default button, if 'Data Modem' is not already indicated as the "(default)" connection. (Client for Microsoft Networks might also need to be checked on the Networking tab in Data Modem's Properties.)

I recommended Never dial a connection so that you would have strict control over when it connected, and would not be connecting by itself, just in case you did NOT have an unlimited time/bytes plan.


The Options tab doesn't look quite like the one I posted, does it.  i.e. no redial options.
I'm not certain what's causing that at the moment... perhaps there are dialing rules in effect (the General tab wasn't posted, so I don't know if Use dialing rules is checked)... or possibly that's caused by the Advanced option 'Disconnect when connection may no longer be needed' being checked.
0
 

Author Comment

by:ssurbrook
Comment Utility
I never did see the dialing options, which in the past I have seen. I'm running Windows 8.1 so I don't know if that makes a difference. Either way, when I restart the computer, it wants to automatically dial and begin an internet session. That's ok since I have unlimited data.

The issue is between my 2 pictures I posted, the "Data Modem Pre ICS" and "Modem ICS'd". After building the initial data modem connection, the LAN network access type changes to Internet, thus allowing my wireless connectivity. One the data modem disconnects (i.e. computer restart or manual disconnection) the LAN connection reverts back to an access type of No Internet access.

This is my sticking point. I want to have the LAN automatically be picked up and have Internet access.
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
OK...
First, I don't get what I'm supposed to be looking at in
http://filedb.experts-exchange.com/incoming/2013/12_w52/824914/Data-modem-connected.png

When you get the No Internet access like in
http://filedb.experts-exchange.com/incoming/2013/12_w52/824905/Data-modem-pre-ICS.png
click on the LAN link after "Connections:"
That should open a LAN Status window.  
Click the Details button in that Status dialog and take a screen shot of the Details, please.
0
 

Author Comment

by:ssurbrook
Comment Utility
Sorry for the confusion. Here's the present and recurring Network and Sharing Center.Network and Sharing Center
The Data Modem has no issue with automatically establishing an Internet connection. This is working perfectly.

The issue is with the LAN connection "Unidentified network" and is a private network. As you can see the Access type is No network access.

The Data Modem is set for sharing but is not.Data Modem Properties - Sharing
At the present time, the only way that the LAN network is able to achieve an access type of Internet is if I build a new modem connection.

I've looked into any way to bridge a modem connection to the LAN similar to that of bridging 2 LANs but have come up empty.

I would like to have the LAN connect to the modem connection each and every time without any other manipulation. Can this be achieved?

I hope this clears the previous confusion.
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
Click the circled link for the Status dialog (which should have a Details button)LAN link for Status dialog (click for larger)
0
 

Author Comment

by:ssurbrook
Comment Utility
Here's the LAN statusLAN Status and the LAN's details.LAN Connection details
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
On the LAN status dialog, click the Diagnose button and see what the network troubleshooting wizard comes up with.
0
 

Author Comment

by:ssurbrook
Comment Utility
It reported back it couldn't identify a problem. Honestly, I'm about at the point of attempting a clean install.
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
I think I would uninstall the AT&T software, while the phone is attached... hopefully that will keep it from also uninstalling the drivers. Then after a reboot see if it will still attach using the 'Data Modem' connection you made.
0
 

Author Comment

by:ssurbrook
Comment Utility
Got it working after a few days. I believe there where several errors.

1) Did a clean install of Windows 7 as I believe some registry corruption not related to our discussion;

2) had to do some research to find the BlackBerry usb modem drivers so that I could eliminate the BlackBerry Desktop Software. I found that this software was preventing repeated ICS after the clean install;

3) the AT&T Communication Manager actually provided some additional functionality once I dug into it; and

4) reflashed the E1000 with the Linksys firmware and applied the following settings, monitoring connectivity with a wireless laptop.
a. statically set the host pc Ethernet NIC to 192.168.137.1 (ICS default)
b. set router IP to 192.168.137.250
c. disabled routers DHCP ability
d. disabled routers NAT ability
e. enabled routers dynamic routing ability
f. kept SPI firewall enabled (default)
g. single port forwarded HTTP (port 80) to 192.168.137.1
h. single port forwarded DNS (port 53) to 192.168.137.1
i. cloned Ethernet NIC's MAC address

Thanks for assisting me throughout this. Points are yours. Please reply and I'll award.
0
 
LVL 44

Accepted Solution

by:
Darr247 earned 500 total points
Comment Utility
Wow... for something that should ''just work'' that was a lot of hoop jumping.  :-|
0
 

Author Comment

by:ssurbrook
Comment Utility
Yep. Thanks again. Couldn't have gotten to this point without your assistance.
0
 

Author Closing Comment

by:ssurbrook
Comment Utility
Darr247 was great with assistance and ideas. Excellent work!
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Suggested Solutions

This article is in response to a question (http://www.experts-exchange.com/Networking/Network_Management/Network_Analysis/Q_28230497.html) here at Experts Exchange. The Original Poster (OP) requires a utility that will accept a list of IP addresses …
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now