[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

SBS 2011 (Exchange 2010) AutoResponder Not Responding (is enabled in OWA)

Posted on 2013-12-16
5
Medium Priority
?
932 Views
Last Modified: 2013-12-20
Hi all,

We have a small customer running SBS 2011 - everything is working fine except that automatic replies (Out Of Office) never sends any messages.  Email are received by our users and the users can reply to the senders so it's not a routing or mail flow issue - the SBS server just never seems to prepare and send a response when automatic replies are enabled.

I have tried enabling/disabling via Outlook and OWA, checked for updates, rebooted server, etc.

Any ideas would be hugely appreciated

Thanks

Bob
0
Comment
Question by:Mango-Man
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 1

Author Comment

by:Mango-Man
ID: 39720994
Just as an update, I've continued to research this issue and have performed the following:

1) Checked for Updates, Rebooted Server, Sent Numerous Tests after enabling/disabling OOF

2) Confirmed that Out of Office is showing as enabled in OWA (so not just an Outlook Display Bug): Yes

3) Used Exchange Powershell to confirm Exchange is seeing OOF as enabled by running get-mailbox 'user.name' | get-mailboxautoreplyconfiguration | select identity, autoreplystate¿, it confirmed it was enabled.

4) A bit of research said that if auto configuration isn't working properly it can cause problems because Outlook uses this to set OOF - sure this isn't the problem because as above, Exchange is seeing it enabled but just not responding BUT just in case, I opened port 80 on the server (apparently advisable for more reliable autodiscover).  This had the benefit of OWA working better in Chrome (prior to this, the OOF options weren't working, had to use IE).

5) Performed the following tests as per this post with the same issue:

  5a) Setup User's mailbox on my copy of Outlook so I could use the CTRL + Click Outlook Tray Icon¿ trick to get to the ¿Test Email Auto-Configuration¿ option and confirm the OOF URL is ¿https://server.companyDomain.com/EWS/Exchange.asmx¿

  5b) Confirmed that Require SSL is ticked on the virtual directory EWS in IIS
0
 
LVL 14

Assisted Solution

by:Raj-GT
Raj-GT earned 2000 total points
ID: 39721019
One more thing to check is under Exchange Management Console  > Organization configuration > Hub Transport > Remote Domains. Check and see if you have OOF enabled here.
0
 
LVL 1

Author Comment

by:Mango-Man
ID: 39721135
Hi Raj,

Thanks for your help - I must admit I looked at this but couldn't work out which option to go for as they appear to say you can only have internal or external.  I've tried the third and fourth options, restarting Exchange Mailbox Assistants service in between but no joy.

I've attached a screenshot of what I see - I though it was a little odd that the domain is simply a wildcard?

Screenshot of SBS > Organization Configuration > Hub Transport > Remote Domain properties
Thanks

Bob
0
 
LVL 14

Accepted Solution

by:
Raj-GT earned 2000 total points
ID: 39721176
It should be the third one. The remote domain is a wildcard in this case as you are using the same OOF policy for all external domains. You can get crafty and create different policies for different domains if you want (i.e. No OOF for yahoo.com, hotmail.com or gmail.com etc.)

Can you run the following and check if all mailbox users have external oof enabled.
get-mailbox * | ft alias, *oof*

If it is then can you try the following and see what happens please.
1. Create a new user account and enable OOF for internal and external users in Outlook
2. Send e-mail to this user from an internal account and an external account
3. If you don't get any OOF for the above, repeat the steps but this time create the account on a new mailbox database

It's also worth checking any anti-spam and anti-virus add-ons you may have to see if they are blocking/dropping OOF.

Thanks,
Raj

P.S. Apologies for the multiple edits :-)
0
 
LVL 1

Author Closing Comment

by:Mango-Man
ID: 39731308
While this wasn't my problem - these are great steps to follow to solve the issue - for me we discovered that MailEssentials Online had - bafflingly - taken the decision to block all outbound Out of Office emails.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
With so many activities to perform, Exchange administrators are always busy in organizations. If everything, including Exchange Servers, Outlook clients, and Office 365 accounts work without any issues, they can sit and relax. But unfortunately, it…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question