Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 632
  • Last Modified:

No new logons windows 2003 terminal server

We need to drain a terminal server.
I know howto on WIndows2008 but howto do this on Windows 2003?

http://blogs.msdn.com/b/rds/archive/2007/06/15/introducing-terminal-services-server-drain-mode.aspx
0
janhoedt
Asked:
janhoedt
  • 4
  • 3
1 Solution
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Hmm not sure if 2003 knows about chglogon.exe , please try.
0
 
janhoedtAuthor Commented:
It does, but now about /drain option.
0
 
janhoedtAuthor Commented:
I could do a /disable but I need my connection to stay open for installing software. Will it disconnect my session when I use the /admin option for rdp?
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Patrick BogersDatacenter platform engineer LindowsCommented:
Right, i checked 2003 and there is no option to drain.

Have a go with these lines from MS.

Applies To: Windows Server 2003, Windows Server 2003 R2, Windows Server 2003 with SP1, Windows Server 2003 with SP2
To disable Terminal Services connections

1. Click the System in Control Panel.

2. On the Remote tab, clear the Allow users to connect remotely to your computer check box, and then click OK.

 The terminal server no longer accepts new connections, but existing connections are maintained until closed by the users. This allows administrators to shut down a terminal server gradually.
0
 
janhoedtAuthor Commented:
Yes, I saw that but according to me it discconects all existing sessions, including the one from myself. Don't have a console session avaiable now.
Also only have a Windows 2008 to test, no W2003 to test. So need to be absolutely sure first. Then also, when I loose my session for some reason, how can I re-enable it remotely?
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Hi,

There is always the /console RDP (session 0)
If unsure you could download a free version of teamviewer and build your session on there to be redundant.

When you are able to connect to the registry (remotely) after it fails you can set the fDenyTSConnections to 0 again enabling remote desktopping.
0
 
janhoedtAuthor Commented:
Console session does not work when remote connections are disabled. Sorry, but installing teamviewer on a production server ... I have my doubts.
Registry key fixed it. So only option is using regkey if connection is gone.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now