Solved

Physical Mem Maxed

Posted on 2013-12-16
16
262 Views
Last Modified: 2013-12-18
Our domain controller is a Windows Server 2008 r2 and I have been noticing that the physical memory is getting maxxed out.  On the resource monitor I am showing things like what is included in my attachment.   I am not sure what I need to do?

Any help appreciated.

In our environment, we also run 2 terminal servers (Windows server 2008 r2) and fat client users are on Windows 7.    We have a total of 3 branches and the servers are all located at the main bank and connected thru VPN.
Memory.doc
0
Comment
Question by:bankwest
  • 10
  • 5
16 Comments
 

Author Comment

by:bankwest
ID: 39721922
I meant to add...we also run WSUS for automatic updates and this is actually a virtual server.
0
 
LVL 95

Expert Comment

by:Lee W, MVP
ID: 39722005
Sort by Working Set, not Private.  What's using the RAM?
0
 

Author Comment

by:bankwest
ID: 39722022
Sorted by working set and the TrustedInstaller.exe is still at the top of the list followed by dns.exe       New screenshot attached
Memory.doc
0
Backup Solution for AWS

Read about how CloudBerry Backup fully integrates your backups with Amazon S3 and Amazon Glacier to provide military-grade encryption and dramatically cut storage costs on any platform.

 
LVL 35

Accepted Solution

by:
Seth Simmons earned 500 total points
ID: 39722498
stop the windows modules installer service
by default it's a manual start so if something needs the service it can start when it needs to

also check if windows updates is automatic.  for servers i usually do manually to prevent automatic reboots.  that could be a cause of the high memory usage.  i've seen this a few times on my servers
0
 

Author Comment

by:bankwest
ID: 39722533
On the Windows Modules Installer Properties and the Start and Stop etc buttons are greyed out.    Where is that controlled?
0
 

Author Comment

by:bankwest
ID: 39722661
FYI...    I found it.      Service is stopped.    But it didn't help.    Still running at close to 98 -99%  I also set the updates to be manual from now on.   As of right now....There are some updates that DO require a restart that I can't do until users are off server.

Will THAT  (restart needed)  make it still show memory usage at almost 100%?
0
 

Author Comment

by:bankwest
ID: 39722682
MAAAANNNNN!!    Guess I didn't find it.    Changed it to manual and stopped service.    Now its back to automatic and running.    So I guess I do need help on where to change it to Manual and Stop.    

The Stop, Start, Resume, etc as I said before, is greyed out.
0
 
LVL 35

Expert Comment

by:Seth Simmons
ID: 39723197
you stopped the windows modules installer service?  did the process disappear from task manager/resource monitor?  is dns the highest used process there?  what else is installed on this box?
0
 

Author Comment

by:bankwest
ID: 39724359
The service is stopped.   After a reboot the settings stayed????????     Yes dns is now the highest process there and with the windows module installer service stopped, I am now at about 75% memory used.

This is a domain controller.    print server, DNS server, file server
0
 
LVL 35

Assisted Solution

by:Seth Simmons
Seth Simmons earned 500 total points
ID: 39724473
sounds like problem solved
75% used of 8gb as a DC with those services running doesn't seem unusual
wouldn't hurt increasing to 16gb to give some more breathing room
0
 

Author Comment

by:bankwest
ID: 39724533
I was looking at increase, but I can seem to get to where I need.   Logged in as admin, but the slider and drop down that lets you increase from  8 to 16, I cant get to????????????????
0
 
LVL 35

Expert Comment

by:Seth Simmons
ID: 39724557
what are you using? vmware or hyper-v?
0
 

Author Comment

by:bankwest
ID: 39724568
VMWare
0
 
LVL 35

Expert Comment

by:Seth Simmons
ID: 39724591
if the options are disabled you will need to shutdown the guest first
many hardware settings can't be changed while the guest is running
0
 

Author Comment

by:bankwest
ID: 39724594
Here is what I am trying and its greyed out

ESX
1.With VMware Infrastructure Client, connect to the ESX host that is managing the virtual machine or to VirtualCenter.  
2.Right-click the entry for the virtual machine.  
3.Click Edit Settings.  
4.If not already selected, click the Hardware tab.  
5.If not already highlighted, click Memory.  
6.
From the window displayed at the right, increase the amount of memory.
0
 

Author Comment

by:bankwest
ID: 39724601
Ok, I will give that a try after hours
0

Featured Post

Space-Age Communications Transitions to DevOps

ViaSat, a global provider of satellite and wireless communications, securely connects businesses, governments, and organizations to the Internet. Learn how ViaSat’s Network Solutions Engineer, drove the transition from a traditional network support to a DevOps-centric model.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We recently had an issue where out of nowhere, end users started indicating that their logins to our terminal server were just showing a "blank screen." After checking the usual suspects -- profiles, shell=explorer.exe in the registry, userinit.exe,…
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question