?
Solved

Exchange 2010 Creates Strange "From" addresses

Posted on 2013-12-16
11
Medium Priority
?
181 Views
Last Modified: 2013-12-19
New install of Exch 2010 on SBS 2011.

Users email addresses are in the format of first initial, last name @ domain name, so John Smith is jsmith@domainname.local

When he sends an email, in the header, I see

On December 16, 2013 at 9:48 AM John Smith <SJohn@domainname.local> wrote:

Why is Exchange creating these odd "From" addresses?  They do work, if I reply he gets the email.

(Of course the domain name shown herein is fictional, only for illustrative purposes).
0
Comment
Question by:dougp23
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
11 Comments
 
LVL 14

Expert Comment

by:BlueCompute
ID: 39723545
Typically all users will get multiple SMTP addresses according to the Email Address Policies:

http://www.bluecompute.co.uk/blogposts/making-use-of-e-mail-address-policies-in-sbs2008-and-sbs2011/

However, my understanding is that the primary smtp address (the one marked SMTP: in capitals) is the one that is used as the 'reply to' address.
0
 
LVL 35

Expert Comment

by:Seth Simmons
ID: 39724046
in addition, it's working because you are on the local network on the .local internal domain

if you try to send a message to an outside account and reply from that, the reply will not go

as mentioned, sounds like your email policy is not correct and should be using your external domain name as primary instead of the internal .local
0
 
LVL 14

Expert Comment

by:BlueCompute
ID: 39724091
Incidentally, in the context of SBS2011 the "correct" way to fix this is to run the "Set up your internet address" from the "Home" page of the SBS Management Console - you should have run through all the wizards on this page as part of the server set up process.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:dougp23
ID: 39725228
I will try the wizard thing.

The addresses are not .local, there are the true domain name.  So like I said, I see an email from SJohn@truedomain.com

Should have been clearer in my example.
0
 
LVL 14

Expert Comment

by:BlueCompute
ID: 39725288
Don't just try the wizards; in SBS it's absolutely compulsory to run them else you get weird results..
0
 
LVL 1

Author Comment

by:dougp23
ID: 39725471
Ok, I already did the wizard during the setup, maybe there is something there that I missed (like how the system will forma email addys).

Will try tomorrow!
0
 
LVL 1

Author Comment

by:dougp23
ID: 39726741
I think it is under EMC, Organization, Hub Transport.  Then EMail Policies.  I can then edit the policy for my domain.  

Then it gets cryptic, with this setting:
SMTP
%1s%g@truedomain.com

So I think THAT is where it is deciding how to format email addresses,  but it is too cryptic for me to figure out!  Anyone?
0
 
LVL 14

Accepted Solution

by:
BlueCompute earned 1260 total points
ID: 39727012
You're right in that that's where the addresses are obtained from; however on SBS you shouldn't really be configuring this directly; the wizards do it for you. As you seem determined to do it the hard way though, click "Add" on the Email Addresses page (the one with "SMTP %1s%g@truedomain.com") and you'll get a pop up with a few options, one of which is the one you want (%1g%s@) - select this, add it to the list, highlight it and click "Set as reply" up at the top, then complete the wizard. You'll then want to apply the policy by right-clicking on it and selecting "Apply".
For reference on what the %s %g stuff is all about, try here.
0
 
LVL 1

Author Comment

by:dougp23
ID: 39729212
Hey Blue.

I reran the wizard and there is nothing in that wizard that asks about email address formats.  So I did it the hard way!  Thanks!
0
 
LVL 14

Expert Comment

by:BlueCompute
ID: 39729231
Hi Doug,

Yes oddly enough I ran through the wizards myself and couldn't find it - it's implicit in user naming convention or something but I got pulled onto another job before I could find the relevant pages; apologies for the disinformation and glad you got it sorted!

Cheers,

Bluecompute
0
 
LVL 1

Author Comment

by:dougp23
ID: 39729462
Thanks. I sent you a question to your website, need your thoughts on a situation.
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question