Solved

Cisco ASA Site-to-Site VPN with Dynamic Peer

Posted on 2013-12-16
1
2,175 Views
Last Modified: 2013-12-18
Ok so we have  an ASA that we use for 20 or so VPN sites, and when there is a static IP at the  other end all is well. But in order to save some $$ we have a new site that wants to use a dynamic address.

From reading I should be able to setup a dynamic crypto map. I use ASDM exclusively, so try to keep the CLI to a minimum. I went in to ASDM and created a new entry. Below is the warning I get.

[OK] access-list outside_cryptomap_8 line 1 extended permit ip 192.168.0.0 255.255.254.0 object VPN-KERMIT 
[WARNING] tunnel-group KermitDynamic type ipsec-l2l
	 L2L tunnel-groups that have names which are not an IP
address may only be used if the tunnel authentication
method is Digital Certificates and/or The peer is 
configured to use Aggressive Mode

[OK] tunnel-group KermitDynamic ipsec-attributes
      tunnel-group KermitDynamic ipsec-attributes
[OK] ikev1 pre-shared-key **********
[OK] isakmp keepalive threshold 10 retry 2
[OK] crypto dynamic-map KermitDynamic 8 match address outside_cryptomap_8
[OK] crypto dynamic-map KermitDynamic 8 set  pfs group1
[OK] crypto dynamic-map KermitDynamic 8 set  ikev1 transform-set  ESP-3DES-SHA
[OK] crypto map forsberg 8 ipsec-isakmp dynamic KermitDynamic

Open in new window


So from reading the warning it looks like the dynamic peer needs to be using Aggressive, and it is. However,what group should it be using, usually in ASDM on a staic map I can set the mode (aggressive/main) and the group (group 1, 2, ...). However on ASDM I don't get those options at all.

I cannot get the tunnel to come up. The dynamic peer log shows, Aggressive mode started...Initiate new phase 1 negotiation...IPsec SA request queued due to no phase 1 found.

Any thoughts?
0
Comment
Question by:bhieb
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 

Accepted Solution

by:
bhieb earned 0 total points
ID: 39727474
Opened a ticket with cisco. Turns out there was a port forward for port 500 to one of my internal IP's. So the ASA was never handling the packet, killed that and it worked.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

There are many useful and sometimes not well documented or forgotten IOS or ASA/PIX commands. See IPE article here , there was also one on PacketU and on Cisco Tips & Tricks. Below are my favorites. I give also a few most often used for Cisco IPS an…
Many of the companies I’ve worked with have embraced cloud solutions due to their desire to “get out of the datacenter business.” The ability to achieve better security and availability, and the speed with which they are able to deploy, is far grea…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question