• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 357
  • Last Modified:

SBS 2008 stopped receiving incoming email

It was an accident! The remote.mydomain.co.uk self signed cert in SBS2008 expired today, and I went through the process of renewing by going through the wizard in the SBS console. I've not done this for some time, so when it asked for my domain, I stupidly entered remote.mydomain.co.uk which in turn ended up with SBS configuring both the cert and Exchange for the domain of remote.remote.mydomain.co.uk.

I re-ran the Internet Connection Wizard, then re-ran the "Set up your Internet Address" wizard and this time entered just mydomain.co.uk

The problem now is that Exchange has NOT re-configured itself for mydomain.co.uk and is now not accepting emails. I ran the Fix My Network wizard, but I get an error:-

The server cannot connect to the SMTP connectors. Ensure that Exchange is running, then try again

Please help!
0
Chris Millard
Asked:
Chris Millard
  • 4
1 Solution
 
Nick RhodeIT DirectorCommented:
Check to make sure your exchange services are running, then re-run the fix my network.  If your certificate is blown you would have to reimport the certificate or get the exchange certificate re-issued.  If it is self-signed then run the add trusted certificate wizard again.  You will then have to remove the old one.
0
 
Chris MillardAuthor Commented:
The Exchange services ARE running, but the fix my network wizard fails. I think I have potentially found an issue in the the Windows SBS Internet Receive connector has gone!

I am trying to re-create it, but that too fails. However, I think that this is due to SP3 being installed, and the schema not updating as part of that install. I am currently rebooting the server before running setup.com /prepareschema in the Exchange Management Shell
0
 
Chris MillardAuthor Commented:
OK - follow up - setup.com /prepareschema fails....
0
 
Chris MillardAuthor Commented:
Right - final update. I had to download and run setup.com /prepareschema from the Exchange 2007 SP3 file. That failed again, due to a pending restart. Fixed that with the information from http://technet.microsoft.com/en-us/library/cc164360(v=exchg.80).aspx (it was the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations key that I had to delete. Once that was deleted, the schema update worked OK and I was then able to re-run the Internet connection wizard which fixed all of the Exchange problems....
0
 
Chris MillardAuthor Commented:
LOTS of worrying and 'Googling'. Problem was caused by a known bug of SP3 being installed on Exchange 2007 and a rogue registry key. Once the key was deleted, I had to update the Schema using 'setup.com /prepareschema' from Exchange 2007 SP3 installer, and once that completed I was able to finally fix by re-running the Internet connection wizard in SBS console
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now