Exchange Mailbox Report In Task Scheduler

I am attempting to run the following script via task Scheduler: Exchange 2010 Mailbox Report

I can run the script via powershell with:
PowerShell.exe -command ". 'C:\Program Files\Microsoft\Exchange Server\V14\bin\RemoteExchange.ps1'; Connect-ExchangeServer -auto; exchange2010MailboxReportV1.ps1"

I have commented out the "sendMail" command on the last line of the scrip, because I don't need the file emailed . The html file is created in the current directory.

When I try to run the same command via Task Scheduler the html file is created in the /windows/system32 directory. If I try to open the file I just get the home page.

I want to have the file created on the desktop. Any Ideas?

Exchange 2010 SP3 with Update Rollup 4
Server 2008
James McKandTechnical ConsultantAsked:
Who is Participating?
 
Gregory MillerConnect With a Mentor General ManagerCommented:
In the task scheduler, specify the desktop as the folder to Strat In under the action tab where you specify the script you are running. It is marked as optional. If you leave this blank, the script will create the output file where ever it is presently saved or where ever the script defines the output file to go.

The only other option is to modify your script to output to the Desktop folder.
0
 
James McKandTechnical ConsultantAuthor Commented:
I had tried the "Start In" - did not work.

Modified the script to place the html file in root of C:, then put a shortcut for it on the desktop.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.