Solved

Exchange 2010 Out Of Office Shared Calendars

Posted on 2013-12-16
6
582 Views
Last Modified: 2014-01-02
Users are getting a "Server unavailable" message when users are trying to set Out Of Office and accessing Shared Calendar's. I have gone through our exchange environment and could not find the issue. I opened a ticket with Microsoft and they could not find any issues either. I also worked with our load balancer support and they went through everything and could not find any issues. Users are able to access everything via OWA, but with Outlook 2010 and 2013 they are getting this message.

We are running on a 2 server CAS Array and a 2 server DAG, running on Exchange 2010 SP3 rollup 1. The load balancer we are using is from Kemp Technologies.
0
Comment
Question by:abaskett
  • 3
  • 2
6 Comments
 
LVL 3

Expert Comment

by:jrlingam
Comment Utility
Hi

Kindly check the properties of the EWS virtual directory and make sure anonymous authentication is disabled. This is normally enabled when during the migration stage where both the old and new versions co-exists.

Also make sure integrated windows authentication is selected.

If this is set correctly and still issue occurs, then try the below:

IIS Manager --> Open the EWS virtual directory --> SSL Settings --> Require SSL = enabled/checked , Client Certificates = Ignore.  Click Apply.

KINDLY MAKE A NOTE OF THE CURRENT SETTINGS BEFORE YOU MAKE CHANGES SO THAT YOU CAN ROLL BACK IF REQUIRED.

Kindly revert back.
0
 

Author Comment

by:abaskett
Comment Utility
I've tried these settings already and they did not work.
0
 

Author Comment

by:abaskett
Comment Utility
Test Exchange Connectivity gives me this error with the Microsoft Exchange Web Services Connectivity Tests - Synchronization, Notification, Availability, and Automatic Replies



 Creating a temporary folder to perform synchronization tests.
  Failed to create temporary folder for performing tests.
 
 Additional Details
 
Exception details:
Message: The response received from the service didn't contain valid XML.
Type: Microsoft.Exchange.WebServices.Data.ServiceRequestException
Stack trace:
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ReadXmlDeclaration(EwsServiceXmlReader reader)
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ReadSoapFault(EwsServiceXmlReader reader)
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ProcessWebException(WebException webException)
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.GetEwsHttpWebResponse(IEwsHttpWebRequest request)
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ValidateAndEmitRequest(IEwsHttpWebRequest& request)
 at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest`1.Execute()
 at Microsoft.Exchange.WebServices.Data.ExchangeService.BindToFolder[TFolder](FolderId folderId, PropertySet propertySet)
 at Microsoft.Exchange.Tools.ExRca.Tests.GetOrCreateSyncFolderTest.PerformTestReally()
Exception details:
Message: Root element is missing.
Type: System.Xml.XmlException
Stack trace:
 at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
 at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
 at System.Xml.XmlCharCheckingReader.Read()
 at Microsoft.Exchange.WebServices.Data.EwsXmlReader.Read(XmlNodeType nodeType)
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ReadXmlDeclaration(EwsServiceXmlReader reader)
0
Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

 
LVL 3

Assisted Solution

by:jrlingam
jrlingam earned 250 total points
Comment Utility
Can you check if anyone of the below solutions help.

1. Can you check the settings in the virtual directories for OAB and autodiscover and compare them with the EWS. I suspect there can be a mismatch as the Other outlook functionalities are working fine.

2. If still not working check whether any one of the below 2 links helps:

http://social.technet.microsoft.com/Forums/exchange/en-US/81ebc1de-c899-4097-b224-a0e4b33e4162/users-cant-open-out-of-office-assistant?forum=exchange2010

http://trikks.wordpress.com/2012/07/14/error-the-response-received-from-the-service-didnt-contain-valid-xml-in-exchange-2010/

Thanks.
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 250 total points
Comment Utility
Standard test - bypass the load balancer.
You need to prove the load balancer is not at fault - don't take the vendor's word for it.
That means bypassing it - DNS change or something like to send the traffic directly to the CAS role server.

Simon.
0
 

Author Closing Comment

by:abaskett
Comment Utility
Thank you!!
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
Viewers will learn how to maximize accessibility options in an Excel workbook for users with accessibility issues.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now