• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 482
  • Last Modified:

2008 R2 set Quota on root drive

Hi

I've moved our user home directories to a new Windows 2008 R2 server (was physical with local storage, now virtual with SAN storage).  

On our old server the physical path to the home shares were s:\home\username.

Now they are s:\username

The share name remains the same because I shared the root of S: as Home.  So from a user perspective there isn't any change (\\servername\username).  I did this because of a functional limit on our ESX servers to a 2 TB drive (the total local disk was 5 TB of data that had to be moved to the SAN).

I tried setting the quota on the root of S:, but it applied the 20 GB to the entire S drive and not the individual username folders, thus making the drive over quota.

Using FSRM I would like to do the following:

Set a 20 GB quota (from template) on the root of S: so that all the SUB folders on S: get the quota applied to it automatically (including any new folders that get created on the root).

For example:

S:\username1
S:\username2
S:\username3

All three users each get 20 GB of quota disk space (obviously I have hundreds of users).  I also want to exclude some folders like $RECYCLE.BIN and my home share (because I'm special).

This seems so easy, but yet it's not...  I appreciate any help.  Thank you.

Tony
Ps.  Sorry to babble, but more info is better than less when asking questions....
0
tonyjoewalker
Asked:
tonyjoewalker
  • 2
1 Solution
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
When you set the quota you need to select the "Auto apply template and create quotas on existing and new subfolders" option.  Otherwise it will just set the quota at the root level.

Documentation:  http://technet.microsoft.com/en-us/library/cc731577.aspx

Jeff
TechSoEasy
0
 
tonyjoewalkerAuthor Commented:
Hi

Thank you for the reply.  This is exactly what I did previously and instead of applying the quotas to all SUB folders, it applied it to the root.  When I applied the 20 GB quota on the S drive - My Computer changed the drive size from 1.3 TB to 20 GB and I wasn't able to save even a small PDF.

Now, your link and other instructions that I found describe the behavior I want.  I want the quota to apply to all SUB folders, not to the root of the drive.

Attachments:

    capture1 - my computer b4 applying quota
    capture2 - my computer after applying quota
    capture3 - settings of the quota


I can't find what I am missing.  This should be so easy...
Capture1.PNG
Capture2.PNG
Capture3.PNG
0
 
tonyjoewalkerAuthor Commented:
I found what I missed.  The radio button near the top saying "apply to new and existing sub folders"...
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now