Solved

NovaBACKUP Suddenly Runs Much, Much Slower

Posted on 2013-12-17
18
1,525 Views
Last Modified: 2014-01-06
I have been using NovaBACKUP for several years.  My current version is 15.0 (Build 10).

I run it nightly and it backs up about 175,000 files with a total size of around 166 GB.  Until three days ago, it was taking a bit under two hours to run.  Three days ago, it suddenly started running much more slowly, and took 5 1/2 hours to complete.  Two nights ago it took 4 1/2 hours, and last night it took about 4 hrs 20 mins to complete.

The connection from my Windows 7 Home Premium desktop to an external drive is a USB-3 connection.

I have two external drives that I alternate nightly, so the slowdown is occurring with both external drives.

Everything else on my desktop is running fine.  I don't perceive a slowdown anywhere else.

Does anyone have any suggestions?

Thank you very much.
0
Comment
Question by:david_m_jacobson
  • 11
  • 7
18 Comments
 
LVL 23

Expert Comment

by:Mohammed Hamada
ID: 39726738
So since it run nightly, then i'm assuming there's no body working on the PC at this time? that means it stays idle.!

If the PC have Windows 7/8 OS running on it, then on idle time it might run Maintenance during the idle hours and this might affect the PC performance.

my suggestion to you is that you disable the Maintenance and see for one night what happens.

another thing, check the event viewer and see what errors do you have there? Check the Programs and system under the Windows Logs.

Please post any errors you find here.
0
 

Author Comment

by:david_m_jacobson
ID: 39727387
Thank you for these suggestions.

Yes, you are correct to assume that I am not using the computer during the night.

I checked the Event Viewer and under "Windows => Applications", I see one error that repeats periodically through the day:

Exception 'NsDisc:8'
(list_devices.cpp(853) unexpected failure)

NsDiscFailedToGetDeviceProperty : Unable to query device property: Features. Error: DeviceError.
    --> CHECKPOINTED AT  list_devices.cpp(691)
    --> RETHROWN FROM  NsDisc.cpp(280)
    --> CHECKPOINTED AT  NsDisc.cpp(225)
    --> THROWN FROM  NsDisc.cpp(365)

But I also see this same error appearing more than four days ago.  That is, it is not new.

Regarding maintenance:

System updates are scheduled to run in the night, but there haven't been any in this time-frame.

As to any other maintenance, I don't know what might have changed since four days ago.

If you have specific suggestions regarding the maintenance, please tell me.

Thank you again for your help.
0
 
LVL 23

Expert Comment

by:Mohammed Hamada
ID: 39727555
hmmm, seems this is a known issue probably?

Could you look here and give the proposed solution a test?

http://support.novastor.com/customer/portal/questions/1118288-unable-to-query-device-settings
0
 

Author Comment

by:david_m_jacobson
ID: 39727622
I read through that posting and do not believe it is applicable to my slowdown.

First off, their OS was Windows XP SP 3, and mine is Windows 7 Home Premium.

Secondly, the external hard drive is Iomega; mine is Buffalo.

Third, they suggest a reformatting of the external drive.  Sure, I could do that, but in my case, this is happening on TWO different separate external drives (since I alternate those two drives nightly).

Do you still want me to reformat the external drive?
0
 
LVL 23

Expert Comment

by:Mohammed Hamada
ID: 39727652
No you don't want to do it since its' happening to two different external drives. what I would assume in this case is an abnormal behavior that happens to the system and slows down the transferring speed.

Is it possible that you could benchmark your PC's HDD speed? what's the maximum speed of transfer that would possible occur?

Could you also check the disk activity from the resource Monitor and check for what's running during the Backup time?

One thing I would suggest before doing the back up which is changing the USB cable with a new one.

and make sure you disable the maintenance. I have seen sometimes the maintenance starts without the scheduled time. so do it as a precaution.
0
 

Author Comment

by:david_m_jacobson
ID: 39727905
Earlier today, I had a suggestion from the NovaStor people to turn off virus scanning on my McAfee Security Center and to compress the files during the backup.  I did that and ran a full backup in only 1 hour 15 min.  This was during the day, not a night.  I'm not sure what I learned from that result and have asked the NovaStor people to suggest the next step.

I will update this case when I learn more.

In the meantime, thank you once again for helping me.
0
 
LVL 23

Expert Comment

by:Mohammed Hamada
ID: 39728518
I'm happy to help, the reason why they suggested turnning off virus scanning during the backup is that some anti-viruses or probably most of them nowadays scan on-access files . so whenever windows tries to access your files/folders it will get antivirus's attention to scan those accessed files which will slow down the transfer as a result of slow performance.
0
 

Author Comment

by:david_m_jacobson
ID: 39729473
The NovaStor tech suggested that I also run defragmentation on both the desktop's hard drive and on the external drive (onto which the backup set is to be written).  I did that.

I then turned off McAfee Security Center's "Anti-Virus Real-time Scanning".

Finally, as per his suggestion, I left in place "Compress files" in the NovaBACKUP settings.

The nightly run took only 1 hour 13 minutes to complete.

Tonight I will have it run with "Anti-Virus Real-time Scanning" turned back on.

More later ...
0
 

Author Comment

by:david_m_jacobson
ID: 39731948
Last night's backup was run with McAfee Security  Center's "Anti-Virus Real-time Scanning" running.  The backup took 5 hours and 7 minutes to complete.

Clearly, the empirical evidence points to the fact that something has change in the McAfee product that is causing this problem.  I will now turn to them for help.
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 23

Expert Comment

by:Mohammed Hamada
ID: 39732233
Yep, maybe Mcafee is fighting with the Nova application's services .. that would cause a problem.

If you can find any suspicious mcafee logs post them here, maybe we can help as well.
0
 

Author Comment

by:david_m_jacobson
ID: 39739183
Still no resolution as of 12/25/2013.  McAfee tech rep insists that McAfee could not be causing the problem.  Yet, when I turn off McAfee Anti-Virus Real-time Scanning, my backup to the external drive runs in 1 1/4 hour (or so), and when it is left on, the backup runs in 4 - 5 hours.

I have NovaBACKUP running on my wife's desktop.  Her backup does not go to an external file; it goes over to my desktop computer via our LAN to which we are both connected by an Ethernet cable.  Her backups took about 50 minutes to run, but on December 17th, they started taking 9 1/2 hours to complete.  Interestingly, when I turn off the McAfee Anti-Virus Real-time Scanning on both her computer and on mine, her backups continue to take 9 1/2 hours to complete.

Note that the problem on my computer started on December 15th and on her computer it was December 17th.

I am going to try talking to McAfee again and will continue to update this thread as I learn more.
0
 

Author Comment

by:david_m_jacobson
ID: 39748446
Still no resolution as of December 31st.

However, for the last three nights, my wife's backups have been taking around 50 minutes, and this is without my having changed anything AND with the McAfee Anti-Virus Real-time Scanning running.

I have talked now three times with McAfee.  Yesterday's conversation had them change a few things, but it had no effect on the running time of my backups.

Since my wife's computer somehow (by itself) is now running the backups in the normal time, I am wondering if my computer will start doing that, too.
0
 
LVL 23

Expert Comment

by:Mohammed Hamada
ID: 39748554
Can you check if you have any errors in the event viewer.
Go to Start button and type "eventvwr" and hit enter without quotes. and then on the left side check applications and system pane. is there anything upnormal ? red alerts ..etc
please post them here.
0
 

Author Comment

by:david_m_jacobson
ID: 39748556
I am closing this case.  I don't have a resolution.
0
 

Author Comment

by:david_m_jacobson
ID: 39748660
I am sorry -- I didn't notice your comment with the suggestion to check the event viewer.

Early on in this thread, you made that suggestion.  I did post what I found, but those errors did not seem to apply to the problem.

Thank you, though, for the suggestion.  I do appreciate it.
0
 
LVL 23

Expert Comment

by:Mohammed Hamada
ID: 39748675
No problem, and sorry for not getting your problem solved! you can proceed with closing/deleting the question.
0
 

Accepted Solution

by:
david_m_jacobson earned 0 total points
ID: 39748692
Please tell me how I can close this thread without checking "Accept as Solution".

You also suggest deleting the question.  Please tell me how I would do that (though, truthfully, I would prefer just closing the question without indicating that a solution was found.

Thanks.
0
 

Author Closing Comment

by:david_m_jacobson
ID: 39758778
There was NO solution.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Automate File Copy Tasks 8 87
Edit header 19 87
Dropbox 3 54
Need to Edit a PDF 9 81
I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
If your app took Google’s lash recently, here are the 5 most likely reasons.
This video demonstrates basic masking and how to edit the mask to reveal the desired image.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now