• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 992
  • Last Modified:

Exchange 2010 OWA Runtime Errors

Had to reset virtual directories on our Exchange 2010 server and now get runtime errors on all virtual directories we attempt to access. Have verified the dill file paths are correct in web.config. Event Viewer shows the following errors:

3008
   A configuration error has occurred.
   12/18/2013 2:14:00 PM
   12/18/2013 8:14:00 PM
   73e9cb99eb6546089866e81f3c67a0e0
   1
   1
   0
   /LM/W3SVC/1/ROOT-5-130318712400737620
   Full
   /
   C:\inetpub\wwwroot\
   EXCHANGE
   
   4316
   w3wp.exe
   IIS APPPOOL\DefaultAppPool
   ConfigurationErrorsException
   Could not load file or assembly 'Microsoft.Exchange.Clients.Owa' or one of its dependencies. The system cannot find the file specified.
   https://exchange.domain.com:443/oab/41d3cff8-9fdd-4041-b6f2-40265ddf3039/oab.xml
   /oab/41d3cff8-9fdd-4041-b6f2-40265ddf3039/oab.xml
   192.168.10.86
   
   False
   
   IIS APPPOOL\DefaultAppPool
   1
   IIS APPPOOL\DefaultAppPool
   False
   at System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase) at System.Web.Configuration.Common.ModulesEntry..ctor(String name, String typeName, String propertyName, ConfigurationElement configElement) at System.Web.HttpApplication.BuildIntegratedModuleCollection(List`1 moduleList) at System.Web.HttpApplication.GetModuleCollection(IntPtr appContext) at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
0
tamray_tech
Asked:
tamray_tech
  • 4
  • 2
1 Solution
 
Simon Butler (Sembee)ConsultantCommented:
What build level of Exchange 2010 are you on, what is the host OS and what is the latest version of netframework that you have installed?

Simon.
0
 
tamray_techAuthor Commented:
Version 14.3 (Build 123.4)

Rollup 4

2008 R2

.Net Framework 4 Client profile
.Net Framework 4 Extended
0
 
Simon Butler (Sembee)ConsultantCommented:
Looks like the app pools are wrong.
How did you reset the virtual directories? Did you use the manual Shell method, or did you use the wizards in EMC?

Simon.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
tamray_techAuthor Commented:
Used the GUI.
0
 
tamray_techAuthor Commented:
Fixed the issue doing the following:

Browsed to:C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files

change the owa directory to owa.old

replaced OWA web.config with copy from another virtual directory

restarted IIS


Works now
0
 
tamray_techAuthor Commented:
Solution fixed the problem
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now