Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 620
  • Last Modified:

Oracle Archivelogs applying but not shipping?

I recently set up my Oracle database to have a physical standby database. When I run this command: select sequence#,applied from v$archived_log order by sequence#; I see the most recent log and that it has applied. However, the physical log is not present in the directory shown when I run archive log list;

I noticed that the global database name is the same for both the primary and standby databases. Is that normal?
0
AshleySPM
Asked:
AshleySPM
3 Solutions
 
AshleySPMAuthor Commented:
I just found that the archivelogs are being stored in the RDBMS folder, which is not the location specified in archive log list or in the log_archive_dest parameter in the init.ora file.
0
 
Praveen Kumar ChandrashekatrDatabase Analysist Senior Commented:
it will be configured in log_archive_dest_n paramter the path if the stand by is configured properly. check these parameter on both primary and secondary standby database.

Also go through the below doc on data gaurd log trasport

http://docs.oracle.com/cd/B19306_01/server.102/b14239/log_transport.htm
0
 
Franck PachotCommented:
Hi,

I suppose you are using DG broker.
You can change the standby location with property StandbyArchiveLocation

For example if the standby database is STANDBY the you can:

DGMGRL> edit database 'STANDBY' set property StandbyArchiveLocation='USE_DB_RECOVERY_FILE_DEST';

Open in new window


Regards,
Franck.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
Richard OlutolaConsultantCommented:
To answer your other question about the global database name, YES it is normal for this parameter to have same value on both primary and standby. This is becuase the DB_NAME should be  the same on both pri and stby and since the global db name is a concatenation of the DB_NAME and the DB_DOMAIN, it would be the same on both.
The db_unique_name must be different on primary and standby.

Hope this helps in a small measure.

R.
0
 
AshleySPMAuthor Commented:
I don't think we are using a Data Guard Broker. The log_archive_dest_n is configured properly.

Thank you rolutola for that information.
0
 
AshleySPMAuthor Commented:
I did

alter system set standby_archive_dest='proper location';

and then started log recovery.
0
 
AshleySPMAuthor Commented:
No one provided the right solution and I found this on my own.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now