SBS 2011 Standard Exchange Autodiscover problems HELP!

Okay so this is what happend :/

A client has a SBS 2011 Standard server where the certificate ran out. A genius decided to in order to fix this issue he would run the Set up your Internet Address Wizard. He configured it the first time with a wrong domain syntax. He then ran the wizard again to type in the correct information.

Now users are reporting that some get "No connection" errors on shared calenders, its only 2 calenders at the moment.

When i run Autodiscover tests on a terminal server thats located as a vm inside the sbs 2011 machine i get errors:

0x800C8203
0x80072EE7
0x8004010F

When i browse to https://localhost/AUTODISCOVER i get the following:


<?xml version="1.0" encoding="UTF-8"?>
-<Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006"> -<Response> -<Error Id="2600584124" Time="12:32:41.2274311"> <ErrorCode>600</ErrorCode> <Message>Invalid Request</Message> <DebugData/> </Error> </Response> </Autodiscover>

When i browse to https://127.0.0.1/AUTODISCOVER i get an HTTP Error 500.0

Module: IIS Web Core
Notification: AuthenticateRequest
Handler: StaticFile
Error Code: 0x80070542

Most likely causes:
•IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
•IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
•IIS was not able to process configuration for the Web site or application.
•The authenticated user does not have permission to use this DLL.
•The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.

I really need some help here as i don't know how to repair the damage after this. Basically what i've found is that it seems Autodiscovery isn't working, resulting in the problems with the calenders.
LVL 2
Wouter MakkinjeIT ManagerAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Wouter MakkinjeConnect With a Mentor IT ManagerAuthor Commented:
Hi i got some help from a colleague it appears the server had some services running on expired certificates, thus causing the issue. The reason the autodiscovery was failing was because they dont have autodiscover setup for external access.
0
 
vSolutionsITCommented:
Run test-outlookwebservices | fl command in exchange powershell and let us know the output where it says "Error" or "warning"
0
 
Wouter MakkinjeIT ManagerAuthor Commented:
Solved it myself with help from professional exchange guru.
0
All Courses

From novice to tech pro — start learning today.