Cannot login to 2008 Server after restore

I'm trying to do a test restoration of our single domain controller using Symantec Backup Exec System Recovery into VMWare.  I can get the server to boot, but when I try to login I receive the error "The security database on the server does not have a computer account for this workstation trust relationship".  I've seen other fixes for this out there, but they all refer to logging into one of the other domain controllers.
Who is Participating?

Improve company productivity with a Business Account.Sign Up

mebaby333Connect With a Mentor It AdminCommented:
Here is a symantec convo that may benefit you....

Another user with same issue... keep reading :)

There is a hidden switch in the recovery program...
Will SzymkowskiSenior Solution ArchitectCommented:
Does this machine that you recovered hold the FSMO roles? What you might need to do is log on to the machine "locally" and then remove then re-add to the domain (without rebooting). Once you have added the machine back into the domain you can reboot and then try and logging back into the domain.

Once you have got back into the domain controller you will need to seize the FSMO roles to the domain controller you are currently logged into.

Seizing/Transfering FSMO Roles -

Thomas GrassiSystems AdministratorCommented:
you "I'm trying to do a test restoration of our single domain controller "
Is this the only domain controller on the network?

When doing a domain controller restore you perform a nonauthoritative restore of Active Directory Domain Services (AD DS)

Did you do that?

Here are the procedures

Best to have two domain controllers having just one makes it harder to recover.
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Are you trying to log into the server itself or are you trying to login on a workstation to the server?

If it's a workstation, log in locally as an administrator, then run the network ID wizard under the properties of MyComputer > Change Settings.  This will reset the computer account password in AD, which will then allow you to login to the network.

AD will periodically change an AD computer account password.  When you restored the server, it is most likely that the password had been changed and now they are not in sync causing the error you are seeing.
mebaby333It AdminCommented:
Have you tried disconnecting it from the network and logging on? Or logging in locally so you can repair the issue?

Ha ha guess I was late... :)
gk906Author Commented:
To answer your questions:

This is a single DC environment, so it has all of the FSMO roles on it.  Since it's a DC there's no way for me to log on locally

The link provided regarding non-authoritative DS restore refers to Windows Backup, which is not in play here.

This test server is not currently connected to any network.  It's just a test-restore in VMWare.
Thomas GrassiSystems AdministratorCommented:
•The link provided regarding non-authoritative DS restore refers to Windows Backup, which is not in play here.

I would then contact Symantec here is a link to what I found
mebaby333It AdminCommented:
Have you tried to restore again and change the switch within the restore program yet? I am interested to see if this repairs your issue
gk906Author Commented:
I haven't dug back into this yet, but hope to do so today.  I'll post back the results.
gk906Author Commented:
I'm just doing the test-restore again right now, but it makes sense that the Windows mini-setup generated a new SID and that's why I can't login.  I have used the hidden settings before but it's been a LONG time.  Thanks for the refresher!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.