Cannot Copy-Paste Between Computers

Computer 1 is my local box (64-bit Windows 7 Pro SP1).
Computer 2 is one I am remoted into through RDP (Windows Server 2008 R2 Enterprise SP1).
Computer 3 is one I am remoted into through RDP (Windows Server 2008 R2 Enterprise SP1).

I can copy into clipboard from either computer 1 or 2 and paste into the other, but I cannot copy from 3 and paste into either 1 or 2 and I cannot copy from 1 or 2 and paste into 3.

I can copy from 3 and paste into another application within 3, but what is in 3 stays in 3.

I am working with scripts that I test on 1 and need to execute on 2 and 3 and right now, I have to save as a file, copy to a drive that is mapped to 3, and open the file on 3, which is extra work.

Is there some kind of server setting that is preventing me from being able to copy and paste?

Between 1 and 2 I can copy and paste text, files, images, pretty much anything you can put on the clipboard, but when I go to 3, it sees none of that data.
LVL 15
dbbishopAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
13ShadowConnect With a Mentor Commented:
Have you tried ending and restarting the rdpclip.exe process on the non-working remote machine and see if that solves the issue? That process is responsible for managing a shared clipboard between your local host and the remote desktop and sometimes it fails.
0
 
dbbishopAuthor Commented:
I found something that directed me to group policies. On both servers, the settings are the same under Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection > 'Do not allow clipboard redirection'.

Both servers have this in the state of 'Not configured'.
0
 
Felix LevenSenior System and DatabaseadministratorCommented:
In mstsc.exe you can configure to use the clipboard or not. If the GPO is not configured, then the Client Setting in RDP/mstsc should énable/disable the clipboard.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
13ShadowCommented:
When you try remoting before connecting click on Options and choose the Local Resources Tab. Do you have Clipboard selected under Local Devices and Resources? How about under Apply Windows key combinations?
Compare the settings to the one that is working.
0
 
dbbishopAuthor Commented:
I am establishing both connections with the same program, just different computer names to connect to. The settings on my computer (computer 1)  from which I establish the connections has clipboard sharing enabled.
0
 
dbbishopAuthor Commented:
Apply Windows key combinations is set to 'Only when using full screen' which I am doing on all sessions (I have 3 monitors and a session on each).
0
 
dbbishopAuthor Commented:
I terminated it and that did not help. However, I then executed the task to start it back up and I was able to copy and paste between sessions.  Thanks a lot!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.