Slow network access to/from VM hosted on Server 2012 R2 Standard Hyper-V

Here is my scenario:  I have a Windows Server 2012 R2 Standard system that is running the Hyper-V role and is the host for my VMs.  I have two VMs, one is SBS2011 and the other is Server 2012 R2 Standard.  The SBS2011 VM is the domain controller and the Server 2012 R2 VM is a Terminal Server.  I connected a workstation to the domain and tried to access files from the SBS2011 but found that the network access to the SBS2011 VM was very slow.  I tried pinging the SBS2011 box from the workstation and the ping times were anywhere from 50ms to 200ms.  I then tried pinging the 2012 R2 VM and ping times were 1ms which is normal.  I then went to the VM Host and pinged from the host system to the SBS2011 VM and received the same slow ping times (50ms to 200ms), I then pinged the 2012 RS VM and the ping times were normal (1ms).

Looking around the Hyper-V Manager, I found that the status of the network adapter was “Degraded (Integration services upgrade required)”.  I upgraded the Integration Services, but network access was still slow.  I searched the net and found an article about disabling the VMQ (Virtual Machine Queue) but it changed nothing.

The host system is fine as is the TS VM but the SBS2011 VM network access is very slow.

The host system is a Dell PowerEdge T320 with four hard drive configured as RAID 10.
TechAKAsked:
Who is Participating?
 
TechAKAuthor Commented:
I tried disabling global chimney but it did not work.

I tried uninstalling Integration Services, rebooting and reinstalled, this also did not work.

When I went into the properties of the host system NIC > Advanced Tab > Virtual Machine Queues and selected Disabled and rebooted the host system everything worked correctly.

Disable Virtual MAchine Queues
0
 
JAN PAKULAICT Infranstructure ManagerCommented:
TCP chimney offloading and disabling this in the operating system as well as on the physical and virtual network adapters might fix this.

from cmd as admin

netsh int tcp set global chimney=disabled


(to turn back on do that)

netsh int tcp set global chimney=enabled



http://support.microsoft.com/kb/951037



Have you tried that

http://technet.microsoft.com/en-us/library/cc725907.aspx


and that

http://www.dell.com/downloads/global/power/ps1q10-20100101-Chaudhary.pdf


and that

have you tried uninstall integration services on sbs 2011 vm restart twice and then reinstall from integration services disk?

when pinging sbs 2011 vm

try to use wireshark and see why pings are so slow
0
 
TechAKAuthor Commented:
It worked
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.