Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2600
  • Last Modified:

Outlook 2011 and Exchange Configuration

I am having trouble getting an Outlook 2011 client connected to an Exchange 2010 server (SP3).  Here are the details.  When I do a send/receive I get the error “Unexpected data was encountered” and error number -17997.  

1)      I’m configuring the account using autodiscover
2)      In Outlook preferences the account ball is yellow (I’m not much of a Mac person but I think it’s supposed to be green)
3)      The Mac is on the Internet, not the LAN with the Exchange server
4)      Wintel machines can connect to the Exchange server from the Internet using Outlook Anywhwere and autodiscover with no problems
5)      When I run the account/domain through the Outlook Anywhere (RPC over HTTP) test on Microsoft’s Remove Connectivity Analyzer page (https://textconnectivity.microsoft.com), the account/domain passes with one warning.  It says “The certificate common name contoso.org doesn't match the mutual authentication string provided webmail.contoso.org; however, a match was found in the subject alternative name extension.”

I found several threads that suggest the problem is autodiscover.  They say the options are to 1) fix autodiscover on the server  side, or 2) turn off autodiscover on the Mac.  I don’t think 2 is an option for me as this mac has other Exchange autodiscover accounts and I fear changing this setting will break them.  I’m not sure what to fix on option 1 as the domain seems to pass Microsoft’s test with the warning.

Thanks for your help
0
labdunn
Asked:
labdunn
  • 3
1 Solution
 
David CarrCommented:
To disable Autodiscover for a specific account, Open Outlook on the Mac then open the AppleScript Editor and run the following:

tell application "Microsoft Outlook"
set background autodiscover of exchange account "accountname" to false
end tell


accountname would be the name of the Outlook account found in the description field in Exchange account Settings.

what version of Mac OS are you running?

Do you have admin access to the Exchange Server to address autodiscover ?
0
 
labdunnAuthor Commented:
The OS is 10.9.  Yes I have admin access to the Exchange server.

Is there a way I can "Show" the backgroup autodiscover setting before changing is so I can change it back if need be?

Tx

Bill
0
 
labdunnAuthor Commented:
I had to call Microsoft for a solution on this.  The fix was to enable Basic Authentication for the EWS virtual directory.  According to the MS tech Macs are often not able to authenticate using the Windows Authentication when using this resource.  The litmus test was to go to the url https://webmail.contoso.com/ews/autodiscover.aspx.  Then a machines goes to that URL they should get a login box.  The Wintel machines did and the Mac did not get the login box until we enable Basic Authentication.

Thank you to all for your suggestions.
0
 
labdunnAuthor Commented:
Self explanatory.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now