Outlook Not Showing All Calendar Appointments

We have a few users that are having issues with Outlook not displaying all of their calendar items when cached exchange mode is turned on. We turn off cached exchanged mode it displays all items. When we have the users log into OWA it displays all calendar items. We have done the following with no luck:

Removed Outlook profile and all files associated with it
Uninstalled/Reinstalled Office 2010
Upgraded to Office 2013
Downgraded back to Office 2010 (user didn't like the look of 2013)
Deleted user profile off of the PC and had them log back in

Another weird thing is that the reminder for the missing meetings still alert the user.

Any help would be awesome as this is happening to a few of our company's executives.
Who is Participating?
Will SzymkowskiConnect With a Mentor Senior Solution ArchitectCommented:
Have you tried to download the Address Book manually? If so does this work? Does this happen with all users or just a few?

I would look at the OAB Generation server and check the settings to ensure that Distribution is published using Web Based Distribution (Outlook 2007 and Up). If you are also using 2003 Outlook you need to make sure that you are also distributing it from Public Folders as well.

Move OAB Server - http://technet.microsoft.com/en-us/library/bb125184(v=exchg.141).aspx

Recreate OAB Server - http://namitguy.blogspot.ca/2012/12/rebuilding-exchange-2010-offline.html

Find the outlook.ost file in the users profile and delete that.  After doing this the user will have to recreate things like signatures but it should clear all offline content allowing the client to sync again with the server.

EDIT: Nevermind this would have been covered by the deletion of the user profile...
Jeffery HayesSystem Support Technician Commented:
Ok so it sounds like the option for download shared folders is check on some of the users.

Do this
Outlook > File> Account Settings > Account Settings > Change > More Settings
That will bring you to the Microsoft Exchange pop up box.
Select Advanced and ensure the check box's under cached exchanged mode are not selected.

So we want download shared folders to be unchecked.
Brian EngelSystem AdministratorCommented:
I had the same issue and I can verify that removing all the files in the local outlook profile does the trick. Deleting the outlook profile is not the only thing that needs done you have to manually remove all outlook files in C:\Users\xxxxxxx\AppData\Local\Microsoft\Outlook\    delete everything in that folder then re-launch outlook and your offline cache will reload and calendar items will appear.  This problem occurred for me when I had cache mode turned on and I clicked the Clear Offline Items button on my calendar properties.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.