Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

New Exchange 2010 owa ( 403 - Forbidden: Access is denied. You do not have permission to view this directory or page using the credentials that you supplied)

Posted on 2013-12-21
8
Medium Priority
?
5,799 Views
Last Modified: 2014-01-30
Hi Experts,

Help!

We just migrated to our new exchange 2010 server from 2007 and I just installed our certificate and am getting


403 - Forbidden: Access is denied.
You do not have permission to view this directory or page using the credentials that you supplied.

When going to owa.  If I go to the actual name of the server it works fine but if I go to our main domain name that is set up with everyone's mail, I get that error.

Any help would be appreciated.

Karen
0
Comment
Question by:klsphotos
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39733742
To be clear here

If you go to https://sever/owa it works, but https://host.example.com/owa does not?

Are you testing this internally or externally? Internally, do you have a split DNS setup so the external name works internally?
Do you have an RPC CAS Array setup?
It could be that the DNS doesn't go where you expect to, so the result isn't what should be happening.

Simon.
0
 

Author Comment

by:klsphotos
ID: 39733747
https://mail.server.org/owa works  https://mail.server.org/ does not.

This site does not have a split dns and should work internally as well as externally.

From outside and inside I land on a IIS 7 page.

I confirmed DNS for mail is set to the new server.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39733792
That is the expected behaviour.

Exchange only works on /owa.

If you want to drop the use of /owa then you need to put a redirection on the root of the site. However you must configure all URLs within Exchange with the subdirectory listed - so you cannot list the URL on the OWA virtual directory without the /owa.

If you are configuring a redirect ensure that it doesn't affect subdirectories as well, or better still, use an HTML redirect in the root of the site.

If you want to use the same host name internally and externally you should use a split DNS. Most firewalls will not allow an external IP address to be used internally (basically coming back on itself) so the best practise is the deployment of a split DNS.

Simon.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 5

Expert Comment

by:Kwoof
ID: 39734089
Sembee2 has it all correct.  If your firewall/router does not allow the external IP to be used internally, you may want to add your internal to the SAN certificate.  How was your 2007 exchange setup?
0
 

Author Comment

by:klsphotos
ID: 39785697
This is resolved, sort of.  It was the redirect that needed to be configured.  We had mail.company.org that needed a redirect to be set up for server.domainname.org/owa.

The issue now is that the redirect for http works fine, but the https redirect does not.  The redirect for http is set up through the 404 pages, not in IIS.  How can I redirect https as well?
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 2000 total points
ID: 39785813
Don't do it through 404s.
I always use HTML code on the root of the web site, so that it redirects to the HTTPS version at the same time.

http://exchange.sembee.info/2010/cas/default-page.asp

Simon.
0
 

Author Comment

by:klsphotos
ID: 39786629
Does that code redirect https as well?  That seems way too simple :)
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39787933
If you put the URL in the code as https://host.example.com/owa/, instead of just /owa/ then it will do so. Although if you have the URL set as https://host.example.com/owa in Exchange, then Exchange should redirect for you.

Simon.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
Are you looking for the options available for exporting EDB files to PST? You may be confused as they are different in different Exchange versions. Here, I will discuss some options available.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question