Issue with Installing IE 9 or IE 10 on Windows 2008 R2


I have a production DB server currently running Windows 2008 R2 SP1.
I was running Windows Updates on it, and it is invariably failing on the installation of Internet Explorer 9 and/or 10.
I have done quite a bit of research,  to try and resolve this issue and cannot find anything useful.
I have tried renaming the C:\Windows\SoftwareDistribution folder.
I have tried trying to download an offline version of IE 9, and disabling the NIC on the machine while installing.
I have trying booting up in safe mode with networking and installing updates, but the Windows Update service didn't seem to want to start from there.
I have ran the MS Fix It, but that didn't help either.

I would appreciate any thoughts regarding the fix to this issue.  I am really avoiding having to do a rebuild or repair install of the OS, as it is a DB server with a lot going on on there.

Any ideas would be greatly appreciated.

If you need any specific logs, please let me know which ones, and I'd be happy to post those.

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
This page shows download versions for Windows 2008 R2 64-bit in the dropdowns.  Does that not work on your machine?
JohnBusiness Consultant (Owner)Commented:
You should be able to run System File Checker on that server. Run SFC /SCANNOW and allow to complete. I would also restart afterward and then test.

There may be something else wrong with the server because IE will normally install.

... Thinkpads_User
cvservicesAuthor Commented:
Right.. I have tried the download of those, and installing it offline, I get the same error.
I have tried to also download the pre-requisite files from here: 
and when I try to run it, it says that it's not applicable to my OS.
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

cvservicesAuthor Commented:
ok .. let me run an sfc  /scannow . and try again .will report back as soon as that's done.
cvservicesAuthor Commented:
The SFC just finished, and it looks like it was clear. This is what I got:
Windows resource protection did not find any integrity violations.

Other thoughts?
JohnBusiness Consultant (Owner)Commented:
If you cannot install from Dave Baldwin's list and if SFC does not help, there is something else apparently wrong.

Are you able to use a different browser like Firefox or Chrome?

I am not sure what else to suggest.

... Thinkpads_User
cvservicesAuthor Commented:
I haven't tried another browser, but Internet Explorer 8 works just fine on the server, I just can't upgrade it.
The error I get in going to IE 9 and IE 10 is the same. It just states that the install failed.
This is the error I see in the C:\WindowsUpdate.log:

2013-12-21      00:39:49:195       896      de0      AU      >>##  RESUMED  ## AU: Installing update [UpdateId = {D8BA5DBF-AADE-4125-BBDF-48DCC5950131}]
2013-12-21      00:39:49:195       896      de0      AU        # WARNING: Install failed, error = 0x80070643 / 0x00000002

Not sure if this would be helpful in any way ...
Dave BaldwinFixer of ProblemsCommented:
Here is a Microsoft Fixit for that error code 0x80070643:
cvservicesAuthor Commented:
The .NET repair tool failed to repair , and it created a cab file that was sent to Microsoft.
I'm currently going through the appwiz.cpl, and trying to do a repair, and if that fails, maybe try an uninstall, and a reinstall. Though I'm not sure if it'll allow me to uninstall, since the server has SQL 2008 R2 on there, so it may not allow me to remove a pre-req for that.

On a slight side note, would a corrupt install of .NET cause the Internet Explorer Update from happening? or are these issues completely unrelated?
Remove .NET entirely using this tool:

Then reinstall .NET, and upgrade your Internet Explorer.
cvservicesAuthor Commented:
Alright, so , I have tried the cleanup utility, and then rebooted, then tried to reinstall IE without reinstalling .NET, that failed.

I then reinstalled .NET 4.5.1 then tried IE, and that failed.

I also remembered, that yesterday I did install SP1 on the server, and I think SP1 may have installed before IE 9, which I'm not sure if that order may have caused something to happen.

Could SP1 install have something to do with this issue? Anything I can do to resolve that? ... Try uninstalling SP1 then install IE 9, and then reinstall SP1?
IE9 should install just fine after SP1.

Have you reviewed this?:
cvservicesAuthor Commented:
This is really very bizarre.
I have looked at the pre-requisites @akahan.
The KB is actually already installed.
i did go ahead and uninstall the Service Pack 1, just because I feel like I'm out of options at this point, and everything I've tried isn't working.  
After the SP uninstall, I rebooted, and tried to reinstall IE 9 offline, and that still failed. So I'm not exactly sure what to do next here.

cvservicesAuthor Commented:
Ok Gents, Just thought I'd share the solution here.

What I ended up doing that worked:
I uninstalled SP1 completely.
Uninstalled .NET Framework.
I installed all updates EXCEPT Internet Explorer 9
Installed Internet Explorer 9 via Windows Update (SUCCESS THIS TIME! )
Installed SP1
Reinstalled .NET Framework
Reinstalled Windows updates to complete the security patches.

All is back to normal now!!
Thanks or your help on this!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnBusiness Consultant (Owner)Commented:
Thanks for the very good update. I am glad you got Internet Explorer updated.

.... Thinkpads_User
cvservicesAuthor Commented:
Thanks for your help all!!
Much appreciated.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.