?
Solved

Exchange 2003 to 2010 swing migration - stop Information Store service - Outlook prompts for password

Posted on 2013-12-21
8
Medium Priority
?
977 Views
Last Modified: 2013-12-23
I have performed a swing migration from Exchange 2003 to 2010.  I'm in the process of decommissioning the old Exchange 2003 server and thought I would just stop the Exchange services before uninstalling to see what happened.  After I stopped the Exchange 2003 Information Store service quite a few user's Outlook (various versions) started prompting for a username/password.  The password will take for a while but will return and will prompt when launching Outlook.  All mailboxes have been migrated to 2010 except for the old Exchange admin account and an old Blackberry admin account.  Public folders have been replicated to 2010 and the old 2003 replicas removed, mail flow works well, same for OWA and Activesync,  Everything seems to work well other than this annoying Outlook password prompt.  One odd behavior is my computer at the office, joined to the domain, (Windows XP/Outlook 2010) prompts for the password when the Information Store service is stopped.  But my home computer via a VPN (Windows 8/Outlook 2010), NOT joined to the domain, doesn't prompt for a password.  Same user account being used on both machines.  Both machines are running Outlook Anywhere.  Any ideas?
0
Comment
Question by:CommerceRE
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +2
8 Comments
 
LVL 31

Accepted Solution

by:
Gareth Gudger earned 800 total points
ID: 39734347
At the top of the dialog does it say which server is prompting for the credentials?

Also, with Outlook open, hold down CTRL and right click on the Outlook icon in your Taskbar. From the pop-up menu select "Connection Status" and see if there are any old references to your old server.

Also, repeat the above but select "Test Autoconfiguration". Uncheck the two Guessmart boxes, put in your email and click Test. Looks for anything wrong here, including references to old servers.
0
 
LVL 5

Expert Comment

by:nashim khan
ID: 39734399
Hi,

Please refer the below link for 2003 to 2010 swing migration.

http://www.petenetlive.com/KB/Article/0000234.htm
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 39734624
When you open Outlook hold crtl+right click the outlook icon in the system tray. Click "Connecton Status" and this will show you which servers the user is connecting/authenticating to. You can then see if it is trying to connect to to your Exchange 2003 server.

Also, chcek your authentication methods on your Exchange 2010 CAS server.

Will.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39734667
Check the properties of the Mailbox Database and ensure that the correct public folder store is selected. By default it will be using the Exchange 2003 database.
Check the OAB distribution method and ensure the Exchange 2010 server is setup to do it correctly.

Have you replicated all public folders off the old server? Including the system folder - so Public Folder Instances is empty?

Simon.
0
 

Author Comment

by:CommerceRE
ID: 39734822
Thank you for the responses -

diggisaur - nothing at the top of the dialog prompting for a password.  "Test Autoconfiguration" looks good (no references to the Exchange 2003 server).  However while the Information Store service was stopped on Exchange 2003 I performed the "Connection Status" and do see a reference to the old server (Exchange) and it looks like a Public Folder.  I have attached it for review.Outlook connection status
nashimkhan123 - That is the article I used for performing the swing migration.  I believe I have successfully followed procedure.

spec01 - Yes, I do see it trying to connect to the old Exchange server as note above to diggisaur.  I believe the authentication methods on Exchange 2010 CAS are good.

Sembee2 - The mailbox database where my mailbox is located does point to the Exchange 2010 Public Folder.  OAB is going to the \Default Offline Address List which the generation server is Exchange 2010.  Under Distribution all Client Support are checked.  Enable Web-based distribution is unchecked and Enable public folder distribution is checked.  Maybe there are some system public folders that never were replicated.  I'm replicating now and will remove the replica from Exchange 2003 when completed.  When you mention "so Public Folder Instances is empty" how do you do that?
0
 
LVL 31

Assisted Solution

by:Gareth Gudger
Gareth Gudger earned 800 total points
ID: 39734834
On Exchange 2003 in ESM, under Public Folders, you should see a subfolders called Publc Folder Instances. This should be empty. Try right clicking on Public Folders and doing "Move All Replicas".

Also move the Public Folder hierarchy from the 2003 Administrative Group to the 2010 Administrative Group. Just drag it from the "Folders" node to the 2010 "Folders" node works fine. You do this in ESM on the 2003 server.
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 39734841
Sorry i did not realize that Diggisaur had mentioned that, totally skipped that. Anyways based on the connection status you are still pointing to public folders in some fasion or another regardless of your Default OAB server. If you are using Outlook clients 2007 or higher they use EWS (Exchange Web Services) to obtain address book info, free busy etc. It is recommened that you enable this so that in the event you are using newer clients are in the environment they will be able to retrieve Exchange data accordingly.

Will.
0
 

Author Comment

by:CommerceRE
ID: 39737082
The ctrl right-click on Outlook in system tray pointed me to a public folder.  Turned out to be one public folder and one system public folder that were totally confused.  I finally got public folders removed and was able to decommission the Exchange server.  Thank you to everyone for the help.
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Outlook for dependable use in a very small business   This article is about using the Outlook application (part of Microsoft Office) in a very small business, or for homeowners where dependability and reliability are critical requirements. This …
I don't pretend to be an expert at this, but I have found a few things that are useful. I hope that sharing them here will help others, so they will not have to face some rather hard choices. Since I felt this to be a topic of enough importance and…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question