Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

RDP not saving do not prompt again

Posted on 2013-12-22
8
389 Views
Last Modified: 2013-12-28
I have a workstation that has a local administrator, which when I rdp into another server, it does not prompt to connect anyway.  I added a domain user, to the local adiminstrators group on the pc.  When I log on as the domain user and build the rdp connection, then save it.  I put the check mark in not to prompt again, then I close out, go back in using my saved rdp icon and it asks again.  Every time!  I have found in the registry where it should be updating and the domain user (with local admin rights (built-in Administrators)) won't save the setting like the 'local' administrator.  This is for Windows 7 Pro, 64-bit op system.  What am I missing?  Thanks, Mike
0
Comment
Question by:sborchers
8 Comments
 
LVL 93

Expert Comment

by:John Hurst
ID: 39734976
Check in the expanded RDP settings to see if you are saving credentials there.

Windows-7-RDP-Settings
Also look in Control Panel, Credential Manager. Are the credentials in there? I think they should be.

You can try running System File Checker to see if that corrects Windows issues. Run SFC /SCANNOW and allow to complete. Restart and test.

.... Thinkpads_User
0
 
LVL 5

Expert Comment

by:Kwoof
ID: 39735083
I agree with above...click show option in the lower left and check the box as Thinkpads_User indicated.

When connecting to a server...also consider whether you want to use the /admin switch to take over the console session as well, instead of creating a separate login session on that server.
0
 

Accepted Solution

by:
sborchers earned 0 total points
ID: 39735313
I found the only way to get this to work was rename the Registry Key Terminal Server Client.  Then make a new Terminal Server Client key.  Once I did that it would save my prompt to not ask me again to verify I wanted to connect.  The key is located in HKCU\Software\Microsoft\Terminal Server Client.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 5

Expert Comment

by:Kwoof
ID: 39735368
That's a good solution, although I am wondering what was causing the original key to fail.  I use RDP a lot, and have never run into that situation.
0
 
LVL 69

Expert Comment

by:Qlemo
ID: 39735750
Maybe the key is write-protected :D
0
 

Author Comment

by:sborchers
ID: 39736239
I checked the permissions for the key and the user had Full Access.  There was no reason for it to fail, but it was.  I know I shouldn't have had to do it, but I had spent about 4 hours trying everything else.  Thanks, Mike
0
 
LVL 5

Expert Comment

by:chanderpal singh rathore
ID: 39738096
Hi,

You can use mREMOTEng software it will help you to solve your problem, this will remember our all credentials.
0
 

Author Closing Comment

by:sborchers
ID: 39743280
Ended up trying this, and it worked.  Nothing else had worked up until this point.  Including the suggested solutions.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
When you try to extract and to view the contents of a Microsoft Update Standalone Package (MSU) for Windows Vista, you cannot extract the files from the MSU. Here we are going to explain how to extract those hotfix details without using any third pa…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…

789 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question