Enabling a folder share in Windows Server 2012 R2 Core installation

Heyas,

How do I create and enable full access to folder share in Windows Server 2012 R2? The netshare command doesn't seem to work.

Thank you.
ZackGeneral IT Goto GuyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lee W, MVPTechnology and Business Process AdvisorCommented:
have you tried the NET command?

Type NET /? at a command prompt.  NETSHARE won't work and won't be found because it's not correct.  NET SHARE is.
ZackGeneral IT Goto GuyAuthor Commented:
Sorry my mistake I meant the Net Share command doesn't work.
Lee W, MVPTechnology and Business Process AdvisorCommented:
What is there error?
Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

Lee W, MVPTechnology and Business Process AdvisorCommented:
Post a screen shot.
Lee W, MVPTechnology and Business Process AdvisorCommented:
Did you add the File Server role?
ZackGeneral IT Goto GuyAuthor Commented:
Hi Leew,

See screenshot

Thank you.
ShareIssue.PNG
Lee W, MVPTechnology and Business Process AdvisorCommented:
Why are you running that in a PowerShell prompt?  Run it in a command prompt.
ktaczalaCommented:
Try,

 net share corefig=c:\corefig /G everyone:f
ZackGeneral IT Goto GuyAuthor Commented:
Hi Leew,

No options to launch CMD from the Windows Server Core.  The command
'net share corefig=c:\corefig /G everyone:f' didn't work error message 'You have used an option with an invalid value'.

Thank you.
ktaczalaCommented:
OOPs sorry wrong command. Ignore that

 Are you in powershell?  Try from C:\ prompt.
ktaczalaCommented:
gee leew is too fast,  I didn't see his comment before I typed mine.
ZackGeneral IT Goto GuyAuthor Commented:
Tried from C:\ directory same result.
ktaczalaCommented:
Here's a link for exactly what you are trying to do.  Notice they are at the command prompt,
http://www.omnisecu.com/windows-2008/server-core/how-to-create-and-manage-network-shares-in-windows-2008-server-core-computer.php
ktaczalaCommented:
here's how to get to cmd prompt.

press CTRL+ALT+DELETE, open Task Manager, click More Details. The File menu opens. In the File menu, click Run new task, and then start either Cmd.exe or Powershell.exe.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ktaczalaCommented:
try testing without the /grant part just share the folder. lets do this one step at a time.
Lee W, MVPTechnology and Business Process AdvisorCommented:
You're problem is that you're running this in a PowerShell prompt.  

You can use powershell to create a share, but NET SHARE works just fine in a COMMAND prompt.  Run CMD and you'll find it works.

More on PowerShell share creation:
http://blogs.technet.com/b/heyscriptingguy/archive/2010/09/16/how-to-use-powershell-to-create-shared-folders-in-windows-7.aspx

WHY are you running a core install?
ZackGeneral IT Goto GuyAuthor Commented:
Thanks man that did the trick.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.