Solved

Interface in etherchannel shows a stand-alone flag

Posted on 2013-12-23
48
4,054 Views
Last Modified: 2014-03-26
Hello,

I have a etherchannel configured between a Cisco 3750 and a Cisco 3560 that are connected over a MPLS line.

Currently I am using two interfaces on both devices for the etherchannel. On the 3750 switch I have one interface that shows that it is "in the port-channel" and the other interface shows a stand-alone flag and is not in the channel/bundle

Both interfaces on the 3560 switch are showing in the port-channel. Does anyone have any idea what could be wrong?

Thank you
0
Comment
Question by:Yeloball
  • 23
  • 17
  • 4
  • +1
48 Comments
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39736884
Can you post the config from the 3750?  Just the config from the interfaces you want to be in the PortChannel will do if you can't post the whole lot.
0
 

Author Comment

by:Yeloball
ID: 39737234
Hi craigbeck,

Do you just need a sh int gi1/0/x or a sh run int gi1/0/x output?
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39737558
show run int gi1/0/1 will be fine.  I'll need to see each interface which you want to be in the PortChannel though.  Can you also tell me which interface is showing in the PortChannel, and which isn't?
0
 

Author Comment

by:Yeloball
ID: 39737845
interface GigabitEthernet1/0/24
 description My-Etherchannel
 switchport access vlan 5
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5
 channel-group 30 mode active
end

AN_S#sh run int gi1/0/22
Building configuration...

Current configuration : 185 bytes
!
interface GigabitEthernet1/0/22
 description My-Etherchannel
 switchport access vlan 5
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5
 channel-group 30 mode active
end

Open in new window


Interface Gi1/0/22 shows in port-channel, Interface Gi1/0/24 is the interface that is showing stand-alone and not in the bundle.
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39737862
Ok that looks good.  You don't need the trunk commands if you only want to pass one VLAN though.  It might be better to tidy it up a bit for simplicity and make it an access port instead...

interface Po30
 description My-Etherchannel
 switchport access vlan 5
 switchport mode access
! 
interface range GigabitEthernet1/0/22 , GigabitEthernet1/0/24
 description My-Etherchannel
 switchport access vlan 5
 switchport mode access
 channel-group 30 mode active
end

Open in new window

Can you give the show int gi1/0/22 and show int gi1/0/24 output please?
0
 

Author Comment

by:Yeloball
ID: 39737873
GigabitEthernet1/0/22 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is
  Description: My-Etherchannel
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:17, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     755335733 packets input, 822161042559 bytes, 0 no buffer
     Received 19507 broadcasts (19369 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 19369 multicast, 0 pause input
     0 input packets with dribble condition detected
     872931897 packets output, 964032290705 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

Open in new window


GigabitEthernet1/0/24 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is
  Description: My-Etherchannel
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:09, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     15740613 packets output, 1507160283 bytes, 0 underruns
     0 output errors, 0 collisions, 11 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

Open in new window

0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39738212
Nothing wrong there!

Does your PortChannel config match the physical port config?
0
 
LVL 10

Expert Comment

by:Mohammed Rahman
ID: 39740326
Try remove Gi1/0/24 from ether channel group anf add it to same group again. Then look at ether channel summary. Also try swapping cables on ports. We know that port 22 and its cable are good. The port 24 configuration is also good. If you swap and still have problem, chances are the port is physically bad. If it starts to function, the cable that is now on port 22 might be bad.
0
 

Author Comment

by:Yeloball
ID: 39740363
Another question. Do the VLAN's have to match on the 3560 at the remote location? Or can they be different?
0
 

Author Comment

by:Yeloball
ID: 39740425
Additionally; should I have administrative Native VLAN tagging enabled or disabled?

Thanks
0
 
LVL 10

Expert Comment

by:Mohammed Rahman
ID: 39740428
Please provide output for
Show etherchannel summary and show etherchannel 30 detail.

As your ports are trunked, they ll allow all vlans except the ones explicitly blocked. Trunk is member of all vlans.

If ether channel is not active.. STP could be blocking that port.
0
 

Author Comment

by:Yeloball
ID: 39740459
Okay, I changed it from a trunk to access because only 1 VLAN was going across it as mentioned above. I am starting to think it is something with STP.

Group state = L2
Ports: 2   Maxports = 21
Port-channels: 1 Max Port-channels = 20
Protocol:   LACP
Minimum Links: 0
                Ports in the group:
                -------------------
Port: Gi1/0/22
------------

Port state    = Up Mstr Assoc In-Bndl
Channel group = 30          Mode = Active          Gcchange = -
Port-channel  = Po30        GC   =   -             Pseudo port-channel = Po30
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi1/0/22  SA      bndl      32768         0x1E      0x1E    0x117       0x3D

Partner's information:

                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Gi1/0/22  SA      255          

Age of the port in the current state: 0d:00h:17m:04s

Port: Gi1/0/24
------------

Port state    = Up Sngl-port-Bndl Mstr Not-in-Bndl
Channel group = 30          Mode = Active          Gcchange = -
Port-channel  = null        GC   =   -             Pseudo port-channel = Po30
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi1/0/24  SA      indep     32768         0x1E      0x1E    0x119       0x7D

Age of the port in the current state: 0d:00h:17m:00s

                Port-channels in the group:
                ---------------------------

Port-channel: Po30    (Primary Aggregator)

------------

Age of the Port-channel   = 0d:00h:17m:37s
Logical slot/port   = 10/30          Number of ports = 1
HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   LACP
Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Gi1/0/22 Active             0

Time since last port bundled:    0d:00h:17m:04s    Gi1/0/22


30     Po30(SU)        LACP      Gi1/0/22(P) Gi1/0/24(I)

Open in new window

0
 
LVL 10

Expert Comment

by:Mohammed Rahman
ID: 39740523
1) Eliminate LACP from the equation at this point by setting both sides to ON mode.
 2) On one switch - issue the shutdown command on all physical interfaces in the bundle
 3) Power cycle each switch
 4) Once both switches are rebooted - no shut the physical interfaces of the bundle

Also, the ports on this switch are in active mode. Can you please check the ports mode on other switch.
I read that active will negotiate with either active or passive. If the other side mode is set to ON , it will not negotiate as ON only negotiates with ON. STP port status..
0
 
LVL 10

Expert Comment

by:Mohammed Rahman
ID: 39740537
Try the first four steps in above post as a last resort. Probably the other end is set to ON and not active or passive. Cisco also recommends not to keep ports in port-fast mode for uplinks (trunks)
0
 

Author Comment

by:Yeloball
ID: 39741720
Mohammed,

The two interfaces on the other switch are in active mode as well, so they match up.
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39741736
You don't have the port configured as a SPAN port do you?
0
 

Author Comment

by:Yeloball
ID: 39741760
How do I check craig?

Here is something interesting. I configured the 3750 port-channel with the mode ON and now shows both interfaces in the channel.

The 3560 still has mode LACP and shows both interfaces in the channel?
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39741771
Hmmm I'd say not in a SPAN session then.

If that's what you're seeing you have an issue between the two switches.  If you configure the 3750 end as passive, what happens?
0
 

Author Comment

by:Yeloball
ID: 39741790
If I put the 3750 to LACP (passive) interface 24 goes into stand-alone mode again.
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39741807
Ok can you do some debugging?

debug etherchannel all

Reconfigure the ports in active mode, then shut and no shut while the debug is running, then post the output of the debug for us to see.

I would do this debug on both switches at the same time.
0
 

Author Comment

by:Yeloball
ID: 39741813
shut and no shut the port channel interface or the two physical interfaces?
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39741821
The physical interfaces - do them at the same time, or individually - it won't matter.
0
 

Author Comment

by:Yeloball
ID: 39741837
Do you have to add some sort of switch in there to tell it where to output the debug information to?
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 45

Expert Comment

by:Craig Beck
ID: 39742047
If you're in a TELNET or SSH session you need to issue the terminal monitor command.  If your session breaks you'll have to issue the command again to start logging to the console.
0
 

Author Comment

by:Yeloball
ID: 39742057
Is there any reason the debug command is not outputing any information for me?
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39742073
Hmmm try debug lacp all too
0
 

Author Comment

by:Yeloball
ID: 39754782
Does anyone else possibly know why I am unable to display debugging information. I am currently connecting to the switch via telnet. I have also even directly connected to the switch via console and experienced the same results.
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39754940
Try this...
conf t
logging console

Open in new window

0
 
LVL 22

Expert Comment

by:eeRoot
ID: 39759582
You may nerd to change the mode from "active" to "desirable" on one or both switches.  Although Cisco says active mode works, occasionally it does not on newly crested etherchannel links.
0
 

Author Comment

by:Yeloball
ID: 39821110
eeRoot,

When I put my switch that is showing the one port that is in stand-alone mode to "desirable" both interfaces go into stand-alone mode and do not form a port channel.
0
 

Author Comment

by:Yeloball
ID: 39821800
Here is the output when I debug etherchannel all and also debug LACP all. Please take a look, for some reason it will not see int gi1/0/24.

002991: *Aug 14 20:36:55.792: FEC: pagp_switch_hwif_goingdown: port Po30
002992: *Aug 14 20:36:55.818: FEC: pagp_is_idb_in_port_channel: Gi1/0/22 is not bundled in an agport
002993: *Aug 14 20:36:55.868: FEC: lacp_fec_unbundle_internal: Gi1/0/22
002994: *Aug 14 20:36:55.868: FEC: Un-Bndl msg NOT send to PM for port Gi1/0/22 from Po30
002995: *Aug 14 20:36:55.868: FEC: pagp_switch_reset_load_index: reading load-index for port Po30
002996: *Aug 14 20:36:55.868: FEC: lacp_switch_delete_port_from_agport_internal: removing Gi1/0/22 from Po30
002997: *Aug 14 20:36:55.868: FEC: delete port (Gi1/0/22) from agport (Po30)
002998: *Aug 14 20:36:55.868: FEC: pagp_switch_delete_port_from_agport_list: afb->nports-- = 0 [Gi1/0/22]
002999: *Aug 14 20:36:55.868: FEC: lacp_switch_remove_port_from_associated_list_internal: Gi1/0/22 deleted from the associated list for Po30
003000: *Aug 14 20:36:55.868: FEC: pagp_switch_reset_cannot_bundle_ports: group 30
003001: *Aug 14 20:36:55.868: FEC: lacp_switch_is_aggregator_valid: aggregator Po30 is still valid
003002: *Aug 14 20:36:55.876: FEC: pagp_switch_reset_load_index: reading load-index for port Po30
003003: *Aug 14 20:36:55.876: lacp_handle_standby_port_internal called, depth = 1
003004: *Aug 14 20:36:55.876: FEC: lacp_switch_is_aggregator_valid: aggregator Po30 is still valid
003005: *Aug 14 20:36:55.876: FEC: lacp_switch_get_first_associated_port_from_agg_id: no associated ports in the aggregator Po30
003006: *Aug 14 20:36:57.797: %LINK-5-CHANGED: Interface GigabitEthernet1/0/22, changed state to administratively down
003007: *Aug 14 20:36:57.797: %LINK-5-CHANGED: Interface GigabitEthernet1/0/24, changed state to administratively down
003008: *Aug 14 20:36:57.797: %LINK-5-CHANGED: Interface Port-channel30, changed state to administratively down
003009: *Aug 14 20:36:58.804: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/22, changed state to down
003010: *Aug 14 20:36:58.804: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/24, changed state to down
003011: *Aug 14 20:36:58.804: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel30, changed state to down
003012: 000047: *Aug 14 20:37:00.893: %LINK-5-CHANGED: Interface Port-channel30, changed state to administratively down (AN_S-1)
003013: 000066: *Aug 14 20:37:00.893: %LINK-5-CHANGED: Interface Port-channel30, changed state to administratively down (AN_S-2)
003014: 000041: *Aug 14 20:37:00.884: %LINK-5-CHANGED: Interface Port-channel30, changed state to administratively down (AN_S-3)
AN_S(config-if)#
AN_S(config-if)#no shut
AN_S(config-if)#
003015: *Aug 14 20:37:48.364: FEC: pagp_switch_stay_shutdown: port Gi1/0/22 agport Po30
003016: *Aug 14 20:37:48.364: FEC: pagp_switch_stay_shutdown: port Gi1/0/22 agport Po30
003017: *Aug 14 20:37:48.364: FEC: pagp_switch_stay_shutdown: port Gi1/0/24 agport Po30
003018: *Aug 14 20:37:48.364: FEC: pagp_switch_stay_shutdown: port Gi1/0/24 agport Po30
003019: *Aug 14 20:37:48.364: FEC: pagp_switch_hwif_comingup: port Po30
003020: *Aug 14 20:37:48.364: FEC: pagp_switch_reset_cannot_bundle_ports: group 30
003021: *Aug 14 20:37:50.369: %LINK-3-UPDOWN: Interface Port-channel30, changed state to down
003022: *Aug 14 20:37:50.369: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/22, changed state to down
003023: *Aug 14 20:37:50.369: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/24, changed state to down
003024: *Aug 14 20:37:51.082: FEC: lacp_switch_add_port_to_associated_list_internal: Gi1/0/22 added to list for Po30
003025: 000048: *Aug 14 20:37:50.369: %LINK-3-UPDOWN: Interface Port-channel30, changed state to down (AN_S-1)
003026: 000067: *Aug 14 20:37:50.369: %LINK-3-UPDOWN: Interface Port-channel30, changed state to down (AN_S-2)
003027: 000042: *Aug 14 20:37:50.369: %LINK-3-UPDOWN: Interface Port-channel30, changed state to down (AN_S-3)
003028: *Aug 14 20:37:52.860: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/24, changed state to up
003029: *Aug 14 20:37:52.936: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/22, changed state to up
003030: *Aug 14 20:37:53.087: lacp_handle_standby_port_internal called, depth = 1
003031: *Aug 14 20:37:53.087: FEC: lacp_switch_is_aggregator_valid: aggregator Po30 is still valid
003032: *Aug 14 20:37:53.087: FEC: lacp_switch_get_first_associated_port_from_agg_id: found port Gi1/0/22 associated to Po30
003033: *Aug 14 20:37:53.087: FEC: lacp_switch_is_port_in_associate_list: port Gi1/0/22 is present in the associate list
003034: *Aug 14 20:37:53.087: FEC: lacp_switch_get_next_associated_port_from_agg_id: no associated port next to Gi1/0/22 in aggregator Po30
003035: *Aug 14 20:37:53.087: FEC: lacp_switch_is_aggregator_valid: aggregator Po30 is still valid
003036: *Aug 14 20:37:53.087: FEC: lacp_switch_check_hw_sw_constraints_internal: port Gi1/0/22 can be bundled in the aggregator Po30, new afb->nports [0]
003037: *Aug 14 20:37:53.087: LACP: Gi1/0/22 standby->selected
003038: *Aug 14 20:37:55.058: FEC: lacp_switch_is_aggregator_valid: aggregator Po30 is still valid
003039: *Aug 14 20:37:55.058: FEC: add port (Gi1/0/22) to agport (Po30)
003040: *Aug 14 20:37:55.058: FEC: pagp_switch_add_port_to_agport_list: afb->nports++ = 1 [Gi1/0/22]
003041: *Aug 14 20:37:55.058: FEC: lacp_switch_add_port_to_agport_internal: Gi1/0/22 added to aggregator Po30 list
003042: *Aug 14 20:37:55.066: FEC: lacp_fec_bundle_internal: Determine if msg to PM to bundle port Gi1/0/22 with Po30 is needed
003043: *Aug 14 20:37:55.066: FEC: pagp_switch_want_to_bundle: Bndl msg to PM for port Gi1/0/22 to Agport Po30
003044: *Aug 14 20:37:55.066: FEC: pagp_switch_reset_load_index: reading load-index for port Po30
003045: *Aug 14 20:37:55.075: FEC: pagp_switch_port_attrib_diff: Gi1/0/22 Po30 same
003046: *Aug 14 20:37:55.083: FEC: pagp_is_idb_in_port_channel: Gi1/0/22 is part of agport
003047: *Aug 14 20:37:55.083: FEC: pagp_is_idb_in_port_channel: Gi1/0/22 is bundled in agport Po30
003048: *Aug 14 20:37:55.091: lacp_handle_standby_port_internal called, depth = 1
003049: *Aug 14 20:37:55.091: FEC: lacp_switch_is_aggregator_valid: aggregator Po30 is still valid
003050: *Aug 14 20:37:55.091: FEC: lacp_switch_get_first_associated_port_from_agg_id: found port Gi1/0/22 associated to Po30
003051: *Aug 14 20:37:55.091: FEC: lacp_switch_is_port_in_associate_list: port Gi1/0/22 is present in the associate list
003052: *Aug 14 20:37:55.091: FEC: lacp_switch_get_next_associated_port_from_agg_id: no associated port next to Gi1/0/22 in aggregator Po30
003053: *Aug 14 20:37:56.098: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/22, changed state to up
003054: *Aug 14 20:37:57.080: %LINK-3-UPDOWN: Interface Port-channel30, changed state to up
003055: *Aug 14 20:37:58.086: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel30, changed state to up
003056: *Aug 14 20:37:59.680: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/24, changed state to up

Open in new window

0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39821964
Why is the log showing PAgP and LACP debugs?

Can you post the config for the PortChannel interfaces and the physical interfaces at each end?
0
 
LVL 22

Expert Comment

by:eeRoot
ID: 39822006
Can you show the current port configs and the results of the command "show cdp nei" from both switches?
0
 

Author Comment

by:Yeloball
ID: 39824313
Craig, I am not sure why it is showing PAgP, I just debugged etherchannel all and LACP.

Port channel configuration 3750

interface Port-channel30
 switchport access vlan 5
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5
 switchport mode access


3750 physical interface:

interface GigabitEthernet1/0/22
 switchport access vlan 5
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5
 switchport mode access
 channel-group 30 mode active


interface GigabitEthernet1/0/24
 switchport access vlan 5
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5
 switchport mode access
 channel-group 30 mode active






Port channel configuration 3560

interface Port-channel5
 switchport access vlan 10


3560 Physical interface:


interface GigabitEthernet0/15
 switchport access vlan 10
 channel-group 5 mode active


interface GigabitEthernet0/16
 switchport access vlan 10
 channel-group 5 mode active
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39824378
Ok let's clean up a bit...

Port channel configuration 3750

interface Port-channel30
 switchport access vlan 5
 switchport mode access


3750 physical interface:

interface GigabitEthernet1/0/22
 switchport access vlan 5
 switchport mode access
 channel-group 30 mode active

interface GigabitEthernet1/0/24
 switchport access vlan 5
 switchport mode access
 channel-group 30 mode active




Port channel configuration 3560

interface Port-channel5
 switchport mode access
 switchport access vlan 10



3560 Physical interface:


interface GigabitEthernet0/15
 switchport access vlan 10
 switchport mode access
 channel-group 5 mode active

interface GigabitEthernet0/16
 switchport access vlan 10
 switchport mode access
 channel-group 5 mode active



Note though that your PortChannels don't join the same VLAN at each end, so while it will work, traffic won't be tagged in the right VLAN if you want VLAN5 and VLAN10 to be the same at each side.
0
 

Author Comment

by:Yeloball
ID: 39824388
So should I then go ahead and match the 3560 VLAN's to my 3750?
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39824498
If that's what you want to achieve, yes.

You don't have to do this though - that's my point.  You could want VLAN5 on one switch to be on VLAN10 on the other switch.  Not likely, but possible.

Let's say that you want users in VLAN10 on the 3560 stack to be on the same VLAN as users in VLAN10 on the 3750 stack.  You'd need the 3560 and the 3750 to pass VLAN10 between eachother via the PortChannel.

I'd change it a bit and do this...

Port channel configuration 3750

interface Port-channel30
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5,10
 switchport mode trunk



3750 physical interface:

interface GigabitEthernet1/0/22
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5,10
 switchport mode trunk
 channel-group 30 mode active

interface GigabitEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5,10
 switchport mode trunk
 channel-group 30 mode active




Port channel configuration 3560

interface Port-channel5
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5,10
 switchport mode trunk



3560 Physical interface:


interface GigabitEthernet0/15
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5,10
 switchport mode trunk
 channel-group 5 mode active

interface GigabitEthernet0/16
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5,10
 switchport mode trunk
 channel-group 5 mode active
0
 

Author Comment

by:Yeloball
ID: 39824524
Okay, could the native VLAN be causing Gi1/0/24 not to bundle in the port-channel on the 3570? The 2 ports on the 3560 bundle perfectly for the etherchannel.
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39824562
It shouldn't matter, as long as it's the same for each physical interface.

Generally you configure the PortChannel how you want it, and it pushes the config to the ports which are in that PortChannel, so you shouldn't be able to mix them up.

It may be that the VLAN you're using as native doesn't exist in the VLAN database though.
0
 

Author Comment

by:Yeloball
ID: 39824587
Okay, I will make these changes, then if it still will not join we will check the vlan database.
0
 

Author Comment

by:Yeloball
ID: 39824702
When I attempted to issue the command on the 3560 I get a message stating VLAN id 5 not found in the current VLAN configuration, Or does this VLAN need to be different than the 3750?
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39824866
That may be your problem.

How do you want it?  Do you want users on VLAN 10 on the 3560 to be able to see users on the other switch on VLAN 10?

Are you creating a VLAN purely for the link between the sites over the MPLS?  I would.  I would route between the sites across the MPLS though, not use the same VLAN.

I think you need to tell us a bit more about what you're trying to achieve - we may be helping you to do something which might not work for you.
0
 

Author Comment

by:Yeloball
ID: 39825129
I have a backup node with 2 ports, it is setup in high availability using 802.3AD, which I am trying to form an etherchannel between that node and the 3750 switch, this is where I have 1 interface in the port-channel and the other in stand-alone mode, which will not bundle.

Data is replicated over the MPLS to a storage node that is connected to the 3560 that has the working etherchannel, routes are in place for this. Make sense?

Thanks
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39834423
Ok, let me ask it this way...

Is there any other device between the 3750 and 3560?
Does your MPLS provider support EtherChannel-over-MPLS?
0
 

Accepted Solution

by:
Yeloball earned 0 total points
ID: 39945184
The network card on the node had one interface that could not be recognized. That is why the Cisco switch could not for the channel and would put one interface into stand-alone mode. Upon replacing the network card, it could form the etherchannel.
0
 

Author Closing Comment

by:Yeloball
ID: 39955425
Had to replace hardware.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Suggested Solutions

The article explains the protocols and technology which is involved when two computers on different TCP/IP networks communicate with each other. In the diagram, a router is used to segregate two networks. The networks are 192.168.1.0/24 and 192…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now