• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2386
  • Last Modified:

Citrix universal printing issue after installing Rollup Pack 3 for XenApp 6.5

I installed Rollup Pack 3 on our XenApp 6.5 hosts last night and it seems to have broken Citrix universal printing (was working previously).

The printers all seem to deploy correctly still, but now when users try to print, the pages come out blank. If you do a print preview, you can also see an empty page.

All I can assume is that there is a mismatch regarding the paper size (eg like how A4 & letter are similar size, but not exactly the same). I am trying to print in A4. I assume Citrix Universal drivers are trying to print in Letter possibly?

I noticed there was also an update for Citrix universal print server & client. I testing installing these, but same issue still occurs.

Merry Christmas!!
0
Howzatt
Asked:
Howzatt
  • 2
  • 2
1 Solution
 
Rick HobbsRETIREDCommented:
When printing from a client printer through a XenApp session, the page size option defaults to "Letter." Additionally, the printing preferences might not be retained on a XenApp 6.5 session by publishing the "Printers" folder as described in Knowledge Center article CTX884335.

[From XA650W2K8R2X64R03][#LA4474]

from:

http://support.citrix.com/article/CTX138537?print
0
 
Rick HobbsRETIREDCommented:
Also
1. what UPS client are you using?
2. have you tried uninstalling Rollup 3?
0
 
basrajCommented:
Try changing the print processor setting on local printer to EMF 1.008 (print properties i believe). If that doesn't work, try adding the printer details to registry as shown in the link and it should fix:

http://support.citrix.com/article/ctx115553
0
 
HowzattAuthor Commented:
RickHobbs - Rolling back to RP2 seems to have resolved the issue for now, however would like to find the resolution and take the advantage of using RP3.

We are running UP client 1.0.1.0.

Regarding your first post re publishing the printers folder, we aren't publishing it. We are publishing the print share unc path via Citrix group Policy. so I assume that info does not apply to us?

Basraj - I will look into that if I am unable to find a resolution from the Citrix side. As we have a few hundred print devices, that is going to be a very long task as you can imagine. Also that document pre-dates the release of RP3.

Thank you both for your answers
0
 
HowzattAuthor Commented:
I ended up signing up for Citrix premier support (not just for this issue), and we were able to resolve the issue by changing the print processor on the Citrix UP GP's from EMF to XPS. So I would assume what Basraj is saying is also correct about changing the processor on the client devices. Something in RP3 has created this mismatch.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now