Solved

"Boot controller details could not be fetched"

Posted on 2013-12-24
26
1,346 Views
Last Modified: 2016-11-23
I am setting up a Dell 2950 Gen 2 Poweredge server with the latest version of the Systems Management Tools and Documentation dvd. I have configured a Raid 10, but its setup stops with the message "Boot controller details could not be fetched".

Someone on the net suggests I should set the Raid as first boot device, and I have tried to do that, but not in the bios (since then it will not boot from the DVD anymore) but in the DVD-tool itself. I do however not know if I did this right since the message does not go away, and this is maybe altogether something different. I hope I am clear.
0
Comment
Question by:TheoRichel
  • 16
  • 9
26 Comments
 
LVL 11

Expert Comment

by:Technodweeb
ID: 39738247
You should be able to set the boot order in BIOS the way you desire and then if you want to boot from an alternate device, at POST you should get a boot device option. I cannot remember which Fn key it is on Dell but the 2950 supported that I am certain.

Overall I do not know if this will solve you main issue but at least you can try the Boot configuration solution.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39738419
If you are using the SMTD/SBUU DVD anyway, boot to it (must be listed first - and enabled - in the boot sequence) and let SBUU configure RAID using the wizards.

Are you using a PERC 5/6 or a third-party card?  If a PERC, and using SMTD doesn't work, try clearing the NVRAM (BIOS settings) using the jumpers on the motherboard.  Also, make sure that Integrated RAID is enabled in the BIOS.
0
 

Author Comment

by:TheoRichel
ID: 39738493
Booting from the SMTD is no problem, and all this happens when I let SBUU configure the RAID. And yes I am using a Perc 5 and integrated Raid is enabled.
According to the manual NVRAM should only be cleared when the system doesnt boot anymore, but it does boot.

In the Bios options of booting sequence, CDrom is now number one, Then a USB stick I inserted, then a NIC and then HD C. No mention of RAID here.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39738868
"According to the manual NVRAM should only be cleared when the system doesnt boot anymore, but it does boot."

Clearing the NVRAM is not reserved only for no-boot situations.  The BIOS keeps a list of its hardware and configurations, if this list becomes corrupt, clearing the NVRAM forces the BIOS to rebuild this "list" and can remove any prejudice for hardware/settings that don't work or cannot be updated/changed.  Problems with installing new hardware - processors and memory in particular - are particularly common issues fixed by clearing the NVRAM ... not just in a no-boot situation, but with recognizing size, specs, etc.
0
 

Author Comment

by:TheoRichel
ID: 39741428
Well it makes no difference to clear NVRam. Might it be a BIOS problem? My current BIOS is v 1.5.1 and 2.7.0 is now available.I would already have done it when I had a USB-stick available during Christmas, and strange enough only options to update BIOS from USB or Diskette are offered, not from CD.
0
 

Author Comment

by:TheoRichel
ID: 39741774
I created a bootable USB with the new BIOS, only to find out that I cannot boot from USB. I checked online and found that I had to apply some changes in my current BIOS but everything was allright already. Despite that my only boot options in BIOS are CDRom, HD C and NIC.

Then SBUU booted and offered me the option to try the Lifecycle Controller. That one failed with the message 'Machine doesnt support USC-boot'.
So I am somewhat stuck.
0
 
LVL 32

Assisted Solution

by:PowerEdgeTech
PowerEdgeTech earned 500 total points
ID: 39742095
The 2950 does not have a USC/Lifecycle Controller.  You can update all system firmware using the SBUU utility, but when you select Update Firmware and are asked for the 'repository', you need to insert the SUU DVD (Server Updates Utility - can also be run from the OS).

To boot to USB, you MUST have the USB in the system when it is powered on - only then will you have the option to put USB at the top of the boot order.
0
 

Author Comment

by:TheoRichel
ID: 39742119
Thanks again.
As for the repository, I was just creating one, I suppose that I can burn a SUU from it. Or is the SUU another downloadable file?

The USB was in while booting, but it nevertheless didnt appear in the boot order.

However, I hadnt tried yet to do Ctl R, but I have done now and now there seems to be a raid being built.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39742132
You can download the entire repository (called SUU - fits on a DL-DVD), or you can create a custom repository  using Repository Manager.

Check BIOS settings for USB - make sure all ports are turned on and set to Auto for emulation type.  This system can boot to USB, regardless of BIOS version.
0
 

Author Comment

by:TheoRichel
ID: 39742146
I will look up the SUU, thanks for that.

Wrt to the USB-booting, I have seen on many places that it is possible to boot from USB.  My emulation type  for the USB is set to auto. In Integrated devices USB is set to 'All ports are on', but nevertheless it isnt offered as an option to boot from.
0
 

Author Comment

by:TheoRichel
ID: 39742188
After the RAID build completed I did a contingency check which ended at 99%. Maybe that is normal. I thought I'd try the Windows setup thereafter but it refused to, complaining about the Nic cabling (the machine is standalone in this phase). So I switched off the NIC as the third boot option, and now it complains that there is nothing to boot from. It looks like the BIOS is messed up.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39742264
"Well it makes no difference to clear NVRam. Might it be a BIOS problem?"

Did you actually clear the NVRAM then?  This is usually how BIOS-related issues are usually resolved (although, yes, some BIOS code corruption can't be fixed by clearing the BIOS - sometimes updating the BIOS can fix it, but sometimes updating the BIOS when the BIOS is corrupt can just crash the system altogether).  You'll KNOW if you cleared the NVRAM successfully by the BIOS/POST message indicating the jumper is installed (put NVRAM jumper on CLR, then power on until you get that  message, then power off, replace the jumper, then power back on).

"I thought I'd try the Windows setup thereafter but it refused to, complaining about the Nic cabling (the machine is standalone in this phase)."

What was the exact message?  Windows Setup shouldn't care if it is connected to a network or not.
0
 

Author Comment

by:TheoRichel
ID: 39742546
Re: NVRam, the message I got on screen was something like "NVRam jumper is set". Then I switched off the machine and put the jumper back and didnt get that message anymore.

The seciond message was needlessly confusing. My fault: Windows setup never started at all because the system wouldnt boot because of the cabling. I know Windows doesnt care about networks, while setting up.
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 

Author Comment

by:TheoRichel
ID: 39743422
Can I run this SUU disk from within the SBUU?
0
 

Author Comment

by:TheoRichel
ID: 39743471
Sorry, I have already found it in the SBUU although it remains unclear whether with updating the firmware, also the BIOS will be updated.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39743607
You don't "run" SUU from within SBUU ... when you boot to SBUU, one of the options is to update firmware.  When you do, it will prompt you for the repository, which is when you will insert the SUU DVD.

It will update ALL system firmware - BIOS, ESM, backplane, PERC, NIC, and DRAC.
0
 

Author Comment

by:TheoRichel
ID: 39743636
That's right, but in my case then the DVD-drive refused to open (this happens 'only' when SBUU is running) so then I forced it with a paper clip and inserted the SUU disk. It then complained that there was no repository on it. Which is not true.
Brrrr.

Now I have booted from Windows setup, maybe I can run the SUU disk from there.
0
 
LVL 32

Accepted Solution

by:
PowerEdgeTech earned 500 total points
ID: 39743686
The latest SUU is HUGE (+7GB), so it must be put on a dual-layer DVD, and while I think most DVD drives will read them, it's possible yours is too old.  You could use the older version of SUU - it will have all but the latest version of the BIOS and ESM firmware on it - but it will fit on a normal DVD:

http://www.dell.com/support/drivers/us/en/555/DriverDetails/Product/poweredge-2950?driverId=NHNF2&osCode=WNET&fileId=2731103763&languageCode=en&categoryId=SM

Sorry to mention this, but I've noticed it overlooked too many times, even by seasoned IT guys ... make sure you are creating the DVD using appropriate ISO-burning software :)
0
 

Author Comment

by:TheoRichel
ID: 39743732
I use IMGBurn havent checked fort the iso yet.

Yes the Repository was huge, but I couldnt burn it because I had no DL disks in the house and I live in a somewhat isolated village. So I decided to create my own repository. That one was 900 mb so no problem. When Windows setup is finished I hope I can run it.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39743737
Ah .... ok :)
0
 

Author Comment

by:TheoRichel
ID: 39743853
Windows setup has finished without complaining. I ran the disk with 'my' repository on it. I do not understand yet completely however. It reportedly only has updates for the firmware for the SAS and the Nics, but when I click 'upgrade' only the NIC's are upgraded. Nothing about the DRAC, the PERC or the BIOS. Maybe in the link you provided. I'll try it.

This install is a new install only for testing purposes and to have a machine to update the firmware. When this is done I'll run windows setup again and now for the migration of my SBS 2003.
0
 

Author Comment

by:TheoRichel
ID: 39744525
Can I ask one final question before I close this thread (tell me if I am crossing a line). I have found a BIOS update which is supposed to run under WOW64. There are a lot of theoretical articles on the net on WOW64, but I still do not know how to use it. Can I just run the bios.exe from my W 2011 64 desktop?
0
 

Author Comment

by:TheoRichel
ID: 39744640
Forget it, I have done it that way and the bios update has succeeded.
0
 

Author Comment

by:TheoRichel
ID: 39744680
And now the USB noot option is back.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39744747
Sorry ... it was still pretty early for me when you posted :)

As you found out, it can simply be run in Windows.  WOW64 is simply a 64-bit OS's ability to run 32-bit packages.  Dell's packages are 32-bit, so as long as WOW is enabled (can be disabled in 2008+ and is disabled by default in 'core' installations I believe), it can be run.

Glad you got it ...
0
 

Author Comment

by:TheoRichel
ID: 39746872
Sorry ... it was still pretty early for me when you posted :)

I realised that, no problem there.

Meanwhile the server seems to behave. I have setupt a RAID now and booting from whatever medium seems possible now. I only do not use the SBUU disk anymore and have found out that in BIOS the boot priority can only be set by the minus sign, the plus sign doesnt react (and it doesnt appear to be a keyboard problem. So it looks I can continue now with setting up W2011. There will be problems there of course, but I'll open e new thread for that, many thanks so far. This was not a problem to be solved by a silver bullet, but by mukltiple worthwhile tiups from someone in the know, thanks again.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Usually shares are where we want them for our users and we tend to take them for granted. There are times, however, when those shares may disappear causing difficulty for your users. One of the first things to try is searching for files that shou…
Hyper-convergence systems have taken the IT world by storm and have quickly started to change our point of view of how the data center should and could be architected. In this article, I’ll explain the benefits of employing a hyper-converged system …
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now