Add Driver to Boot Image [WDS], parameter is incorrect

Successfully installed WDS on Server 2012 R2 and I am able to 'boot from network' on client machines, [WDS server is found, etc.], but just after setup starts, I get the following error:

image 1
Next, I copied the 'network' folder from the drivers CD included with the client computers, located the .inf files and added them to the 'Driver' folder in WDS.

image 2
Next, I try to add the drivers to boot.wim:

image 3
image 4
The image mounts, but the moment it starts to add the first driver, the image dismounts and I get the following error:

image 5
At this point I'm lost, I I've searched near and far troubleshooting, but can't seem to get any further.

The boot.wim file is from a Windows 7 Professional SP1 disk that is shipped with the HP computers, the client computers are HP COMPAQ PRO 6300 SMALL FORM FACTOR BUSINESS PCs with Intel 82579LM Gigabit Network Connection (integrated).

Any help would be genuinely appreciated.
jerryrylesAsked:
Who is Participating?
 
Mike TConnect With a Mentor Leading EngineerCommented:
Hi,

You are correct, NDIS refers to the OS generation and has nothing to do with NIC speed per se.

I believe the error you are getting is either from a dirty WIM (partially mounted files) or the process is slightly wrong. I found this good blog article which covers both issues:

http://tristanwatkins.com/adding-drivers-wds-boot-images/

Emptying the temp folder has worked for me in the past.

thanks,
Mike
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Hi

Is this Windows 7 Pro SP1 64bit?
0
 
jerryrylesAuthor Commented:
Yes, 64-bit.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
MohanrajMCommented:
Please download the latest driver from intel website and add it to the wds database. i have faced this same problem with MDT 2012 and resolved it by adding latest drivers and also deleted the old one.

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3299&DwnldID=18713&ProductFamily=Ethernet+Components&ProductLine=Ethernet+Controllers&ProductProduct=Intel%C2%AE+82579+Gigabit+Ethernet+Controller&DownloadType=Drivers&OSFullname=Windows+7+(64-bit)*&lang=eng
0
 
jerryrylesAuthor Commented:
Thank you for your comments.

MohanrajM, I've downloaded the drivers from the link you provided, and was able to locate the extracted files in my temp directory.

Do you recall which of the three folders below contain the correct drivers? They all contain multiple .inf files.

image 6
Pardon my ignorance.
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Hi.

NDIS interface 62 stands for Fast Ethernet (100BaseT), guessing this is the one you are looking for?
0
 
jerryrylesAuthor Commented:
I have since tried to load the .inf files from the NDIS62 and NDIS63 folders, which are the drivers for  what I believe to be Windows 7 and Windows 8 respectively.

Both attempts resulted in the same error: "The parameter is incorrect."
0
 
jerryrylesAuthor Commented:
Patrick,

In that regard, I would need 1000BASE-T as it is a gigabit network connection.

But it is my understanding that NDIS6x, refers to the operating system. For example

NDIS61 for Win2008
NDIS62 for Win2008 R2\Win7
NDIS63 for Win8\Win2012
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.