Solved

Creating a trunk between two switches

Posted on 2013-12-24
17
3,665 Views
Last Modified: 2013-12-27
I'm new to Cisco switches. We have two SG300-28 (small business switches), and I would like to trunk them together on ports 27 & 28. Here's what I've done so far:

* I changed both ports from Access to Trunk mode.
* Configured both ports to be Tagged on all VLANs
* GVRP is NOT enabled on either switch.

What else do I need to do to complete the trunking. Do I need to configure static routes?

Side Note: They are both configured in L3 mode.
0
Comment
Question by:pzozulka
  • 7
  • 7
  • 3
17 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 39738675
What else do I need to do to complete the trunking.
Run the cable between the switches. Other than that, it sounds like you've done everything else.   :-)  

Do I need to configure static routes?
Maybe, It's hard to say. But it's not relevant to trunking.
0
 
LVL 8

Author Comment

by:pzozulka
ID: 39738687
Don't I need to configure some kind of a static trunk group (I believe Cisco calls it EtherChannel)? Not to confuse it with LACP (which we don't want in this case).
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 39738721
Yes, (I missed that in the original post)

LACP is just a protocol that can negotiate an etherchannel group. On the two ports the IOS command on both ports is: "channel-group x mode on" (where "x" is a user defined number).
0
 
LVL 10

Assisted Solution

by:Mohammed Rahman
Mohammed Rahman earned 200 total points
ID: 39739178
SW1(config)#interface fa 27
SW1(config-if-range)#switchport trunk encapsulation dot1q
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#exit

SW1(config)#interface fa 28
SW1(config-if-range)#switchport trunk encapsulation dot1q
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#exit

To Enable ether channel...


SW1#configure terminal
SW1(config)#interface range fa 27 - 28
SW1(config-if-range)#no shut
SW1(config-if-range)#channel-group 1 mode active
SW1(config-if-range)#end

SW2#configure terminal
SW2(config)#interface range fa 27 - 28
SW2(config-if-range)#no shut
SW2(config-if-range)#channel-group 1 mode passive
SW2(config-if-range)#end

To Verify Ether Channel, use:
SW1#show etherchannel summary
0
 
LVL 8

Author Comment

by:pzozulka
ID: 39739233
When I type "interface fa 27" it tells me the command was unrecognized -- I think because these aren't regular Cisco switches. They are the SG300 Small Business models, so I think the CLI for them is a bit different.

Is there a way to make these changes happen from within the Web Interface?
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 300 total points
ID: 39739247
Page 130 on the Admin Guide.

Looks like: Click Port Management > Link Aggregation > LAG Management.

Then you can define static or dynamic (LACP).
0
 
LVL 10

Expert Comment

by:Mohammed Rahman
ID: 39739255
If fa 27 doesn't work, the ports may be gigabit. Please try

SW1(config)#interface gi27

SW2(config)#interface gi28

Same applies to Range for ether channel.

To get into GUI, open web browser and type 192.168.1.254
Default username and password: cisco/cisco
0
 
LVL 10

Accepted Solution

by:
Mohammed Rahman earned 200 total points
ID: 39739752
As you already have worked on below 2 steps.

* I changed both ports from Access to Trunk mode.
* Configured both ports to be Tagged on all VLANs

Let me try to assist you with Ether Channel (LACP) as you want to trunk 27 and 28 "Together"

To get into GUI, open web browser and type 192.168.1.254
Default username and password: cisco/cisco  (unless you have not changed them :-) )

SG300-28
Select Port Management, LACK -- Highlight Port 27 and click Edit, A new window should pop -- select GE27 from dropdown -- Enter a number in "LACP Port priority" -- Apply

Repeat the same for Port 28 and ensure you use same number in "LACP Port priority" for 27 and 28.

Also, go to LAG management -- Select LAG1 -- edit -- select LAG number from dropdown -- provide LAG name and add GE27 and GE28 to LAG Members list -- Once you add ports to members "LACP Enable check box will let you place a check mark in it -- place the check mark -- Apply

Now, go to LAG Settings -- Select LAG 1 (assuming you selected LAG 1 in above case too) -- provide description -- Select Administrative states "UP" -- Enable Auto Negotiation on one of the two Switches (I guesss if you enable Auto Neg on both, they will not negotiate)

Select Speed 10/100/1000 (based on your requirement) -- Apply

For additional assistance, you can provide the SG300-28 emulator link to your friends or EE experts over here and it will help them/us provide proper resolution (if need be)
SG300-28 Emulator Link
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 8

Author Comment

by:pzozulka
ID: 39740228
Thanks all. I thought EtherChannel meant the same thing as a Trunk in ProCurve switches. If that's the case, ProCurves have Static Trunks and Dynamic Trunks which is LACP.

Having said that, what's the cisco equivalent to a ProCurve Static Trunk? And how would you configure one using the above mentioned web gui?

I'm just curious -- it seems fairly straight forward to config LACP based on above responses.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 39740238
You are correct. "EtherChannel" (Cisco) is the exact same thing as "Trunk" (HP).

The Cisco term "Trunk" is referred to as "tagged" or "tagging" in HP parlance.
0
 
LVL 8

Author Comment

by:pzozulka
ID: 39740274
What type of LAG do you guys recommend between the two switches: EtherChannel (Static LAG) or LACP (Dynamic LAG) ?
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 300 total points
ID: 39740287
I prefer using LACP to negotiate the link.

If all the required parameters are not correctly set and the channel is statically defined, exciting things can happen.  

With LACP implemented, the links will go err-disabled and excitement is avoided.

Excitement = bad in the network world. :-)
0
 
LVL 8

Author Comment

by:pzozulka
ID: 39740785
As I'm reading through the Admin manual, I came across this:


* To add a port to the LAG, it cannot belong to any VLAN except the default VLAN.
* All the ports in a LAG must have auto-negotiation disabled, although the LAG can have auto-negotiation enabled.

As mentioned in the original post:
* I changed both ports from Access to Trunk mode.
* Configured both ports to be Tagged on all VLANs

Does that mean I have to change both ports back to Access mode, and remove all VLANs from them? If so, how do I make the LAG into a Trunk mode and TAG it on all VLANs via the web gui?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 39740899
Wow... that's the most confusing thing I've read this... year!  I got ni idea what they're trying to say. Could be that VLAN 1 must be allowed.
0
 
LVL 8

Author Comment

by:pzozulka
ID: 39740947
If I make the LAG untagged on the native VLAN (1), and tagged on all other VLANs, does that mean that a server on switch 1 will NOT be able to communicate to a server on switch 2 if both of them are UNTAGGED on VLAN 2?

To be more specific the servers are ESXi hosts, and the virtual switch LAN settings are set to NONE for the storage VLAN. However, on the physical switch the ports connected to these two hosts are untagged on VLAN 2.
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 300 total points
ID: 39740954
does that mean that a server on switch 1 will NOT be able to communicate to a server on switch 2 if both of them are UNTAGGED on VLAN 2?
No. As long as both are in the same VLAN (untagged... In Cisco terminology that would be access ports that are members of VLAN2), they will be able to communicate.
0
 
LVL 8

Author Comment

by:pzozulka
ID: 39742320
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Suggested Solutions

I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now