Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6242
  • Last Modified:

Creating a trunk between two switches

I'm new to Cisco switches. We have two SG300-28 (small business switches), and I would like to trunk them together on ports 27 & 28. Here's what I've done so far:

* I changed both ports from Access to Trunk mode.
* Configured both ports to be Tagged on all VLANs
* GVRP is NOT enabled on either switch.

What else do I need to do to complete the trunking. Do I need to configure static routes?

Side Note: They are both configured in L3 mode.
0
pzozulka
Asked:
pzozulka
  • 7
  • 7
  • 3
5 Solutions
 
Don JohnstonInstructorCommented:
What else do I need to do to complete the trunking.
Run the cable between the switches. Other than that, it sounds like you've done everything else.   :-)  

Do I need to configure static routes?
Maybe, It's hard to say. But it's not relevant to trunking.
0
 
pzozulkaAuthor Commented:
Don't I need to configure some kind of a static trunk group (I believe Cisco calls it EtherChannel)? Not to confuse it with LACP (which we don't want in this case).
0
 
Don JohnstonInstructorCommented:
Yes, (I missed that in the original post)

LACP is just a protocol that can negotiate an etherchannel group. On the two ports the IOS command on both ports is: "channel-group x mode on" (where "x" is a user defined number).
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Mohammed RahmanCommented:
SW1(config)#interface fa 27
SW1(config-if-range)#switchport trunk encapsulation dot1q
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#exit

SW1(config)#interface fa 28
SW1(config-if-range)#switchport trunk encapsulation dot1q
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#exit

To Enable ether channel...


SW1#configure terminal
SW1(config)#interface range fa 27 - 28
SW1(config-if-range)#no shut
SW1(config-if-range)#channel-group 1 mode active
SW1(config-if-range)#end

SW2#configure terminal
SW2(config)#interface range fa 27 - 28
SW2(config-if-range)#no shut
SW2(config-if-range)#channel-group 1 mode passive
SW2(config-if-range)#end

To Verify Ether Channel, use:
SW1#show etherchannel summary
0
 
pzozulkaAuthor Commented:
When I type "interface fa 27" it tells me the command was unrecognized -- I think because these aren't regular Cisco switches. They are the SG300 Small Business models, so I think the CLI for them is a bit different.

Is there a way to make these changes happen from within the Web Interface?
0
 
Don JohnstonInstructorCommented:
Page 130 on the Admin Guide.

Looks like: Click Port Management > Link Aggregation > LAG Management.

Then you can define static or dynamic (LACP).
0
 
Mohammed RahmanCommented:
If fa 27 doesn't work, the ports may be gigabit. Please try

SW1(config)#interface gi27

SW2(config)#interface gi28

Same applies to Range for ether channel.

To get into GUI, open web browser and type 192.168.1.254
Default username and password: cisco/cisco
0
 
Mohammed RahmanCommented:
As you already have worked on below 2 steps.

* I changed both ports from Access to Trunk mode.
* Configured both ports to be Tagged on all VLANs

Let me try to assist you with Ether Channel (LACP) as you want to trunk 27 and 28 "Together"

To get into GUI, open web browser and type 192.168.1.254
Default username and password: cisco/cisco  (unless you have not changed them :-) )

SG300-28
Select Port Management, LACK -- Highlight Port 27 and click Edit, A new window should pop -- select GE27 from dropdown -- Enter a number in "LACP Port priority" -- Apply

Repeat the same for Port 28 and ensure you use same number in "LACP Port priority" for 27 and 28.

Also, go to LAG management -- Select LAG1 -- edit -- select LAG number from dropdown -- provide LAG name and add GE27 and GE28 to LAG Members list -- Once you add ports to members "LACP Enable check box will let you place a check mark in it -- place the check mark -- Apply

Now, go to LAG Settings -- Select LAG 1 (assuming you selected LAG 1 in above case too) -- provide description -- Select Administrative states "UP" -- Enable Auto Negotiation on one of the two Switches (I guesss if you enable Auto Neg on both, they will not negotiate)

Select Speed 10/100/1000 (based on your requirement) -- Apply

For additional assistance, you can provide the SG300-28 emulator link to your friends or EE experts over here and it will help them/us provide proper resolution (if need be)
SG300-28 Emulator Link
0
 
pzozulkaAuthor Commented:
Thanks all. I thought EtherChannel meant the same thing as a Trunk in ProCurve switches. If that's the case, ProCurves have Static Trunks and Dynamic Trunks which is LACP.

Having said that, what's the cisco equivalent to a ProCurve Static Trunk? And how would you configure one using the above mentioned web gui?

I'm just curious -- it seems fairly straight forward to config LACP based on above responses.
0
 
Don JohnstonInstructorCommented:
You are correct. "EtherChannel" (Cisco) is the exact same thing as "Trunk" (HP).

The Cisco term "Trunk" is referred to as "tagged" or "tagging" in HP parlance.
0
 
pzozulkaAuthor Commented:
What type of LAG do you guys recommend between the two switches: EtherChannel (Static LAG) or LACP (Dynamic LAG) ?
0
 
Don JohnstonInstructorCommented:
I prefer using LACP to negotiate the link.

If all the required parameters are not correctly set and the channel is statically defined, exciting things can happen.  

With LACP implemented, the links will go err-disabled and excitement is avoided.

Excitement = bad in the network world. :-)
0
 
pzozulkaAuthor Commented:
As I'm reading through the Admin manual, I came across this:


* To add a port to the LAG, it cannot belong to any VLAN except the default VLAN.
* All the ports in a LAG must have auto-negotiation disabled, although the LAG can have auto-negotiation enabled.

As mentioned in the original post:
* I changed both ports from Access to Trunk mode.
* Configured both ports to be Tagged on all VLANs

Does that mean I have to change both ports back to Access mode, and remove all VLANs from them? If so, how do I make the LAG into a Trunk mode and TAG it on all VLANs via the web gui?
0
 
Don JohnstonInstructorCommented:
Wow... that's the most confusing thing I've read this... year!  I got ni idea what they're trying to say. Could be that VLAN 1 must be allowed.
0
 
pzozulkaAuthor Commented:
If I make the LAG untagged on the native VLAN (1), and tagged on all other VLANs, does that mean that a server on switch 1 will NOT be able to communicate to a server on switch 2 if both of them are UNTAGGED on VLAN 2?

To be more specific the servers are ESXi hosts, and the virtual switch LAN settings are set to NONE for the storage VLAN. However, on the physical switch the ports connected to these two hosts are untagged on VLAN 2.
0
 
Don JohnstonInstructorCommented:
does that mean that a server on switch 1 will NOT be able to communicate to a server on switch 2 if both of them are UNTAGGED on VLAN 2?
No. As long as both are in the same VLAN (untagged... In Cisco terminology that would be access ports that are members of VLAN2), they will be able to communicate.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 7
  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now