Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Can't scan from Brother MFC-J470DW over WiFi connection

Posted on 2013-12-25
11
Medium Priority
?
38,188 Views
Last Modified: 2013-12-30
I have a Brother MFC-J470DW multifunction scanner/printer/fax. It's connected to my Win7 Pro 64 bit PC via Wifi, using Infrasturcture mode, with a fixed IP.

It's configured in my Windows Printer setup properly, and I can print to it with no problem.

But when I open the Brother Control Center 4 app, and select Scan, it says:

MFC-J470DW cannot be found

If I go into CC4 Device Settings / Remote Setup, I get a similar message.

If I go into CC4 Device Settings / BRAdmin, it opens the BRAdmin Lite app, and it sees the device at it's proper IP address. If the device is in Sleep mode, BRAdmin shows that. If I wake it up, BRAdmin shows the device is Ready.

I've been through the Brother FAQs and web site troubleshooting, and don't find a solution for this scenario, so I'm trying here.

Thanks!
Dwaine
0
Comment
Question by:Dwaineo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 3
11 Comments
 
LVL 11

Expert Comment

by:Gregory Miller
ID: 39739581
Turn off the windows firewall from inside the control panel. Test it again.
0
 

Author Comment

by:Dwaineo
ID: 39739584
That was a good thought. I'm using Norton Internet Security, so I turned off the Smart Firewall. Unfortunately, that had no effect on the problem.
0
 
LVL 11

Assisted Solution

by:Gregory Miller
Gregory Miller earned 750 total points
ID: 39739586
here is another test... If you have another computer on the network, try pinging the IP address of the computer you are trying to get working. If you can ping it, then the firewall is indeed turned off, if you cannot ping it, you have more work to turn the firewall off. Norton plays some silly games in the firewall area. Even when uninstalled, it can still be active unless you use their uninstall tools.

I do not know if this will give us any good intel but before we stab at other things, lets make certain this is not an issue.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 11

Expert Comment

by:Gregory Miller
ID: 39739588
Also what is the IP address of the computer in question and the IP address of the MFC?
0
 

Author Comment

by:Dwaineo
ID: 39739605
Yes, I have another PC on the network. I can ping the Win7 PC in question, with Smart Firewall disabled.

Win7 PC is 192.9.0.100
MFC-J470DW is 192.9.0.103

The Windows XP PC I pinged the Win7 PC from is 192.9.0.107

I'm in the process of installing the Brother CC4 software on the WinXP PC to see if it works from there. That PC is also setup to print on the MFC-J470DW, and does that properly.
0
 

Author Comment

by:Dwaineo
ID: 39739628
Why does Win7 networking have to be such a pain?

The Brother CC4 software works fine on the XP machine, even with NIS Smart Firewall enabled. Scanning works, and Remote Setup works. I guess this proves there are no setup issues on the MFC-J470DW itself. And that it can do all this stuff over WiFi.

Now, if only it worked with the Win7 PC.
0
 
LVL 55

Assisted Solution

by:Joe Winograd, EE MVE 2015&2016
Joe Winograd, EE MVE 2015&2016 earned 750 total points
ID: 39739644
Hi Dwaine,
I have several Brother MFCs. My experience with them is that using a static IP address (which you said you're doing) and installing what they call the Full Driver & Software Package is the way to go. There has been a relatively recent update to the W7/64-bit package (Release Date 05/28/2013) for your model:
http://welcome.solutions.brother.com/bsc/public/us/us/en/dlf/download_index.html?reg=us&c=us&lang=en&prod=mfcj470dw_us_eu_as&dlid=&flang=English&os=93&type2=-1

If you're not on that, give it a try. I've had great success in doing this with all of my Brother MFCs (although I don't have a J470DW). If that doesn't work, I'll recommend some other troubleshooting steps. Regards, Joe
0
 
LVL 55

Expert Comment

by:Joe Winograd, EE MVE 2015&2016
ID: 39739646
Dwaine,
One other thing – firmware. There has been an extremely recent update to that (Release Date 12/12/2013) for your model:
http://welcome.solutions.brother.com/bsc/public/us/us/en/dlf/dlf/000000/004200/dlf004228.html?reg=us&c=us&lang=en&prod=mfcj470dw_us_eu_as&type2=4&os=93&flang=8&dlid=dlf004228

I've had some Brother MFC firmware updates fix serious issues in the past. Regards, Joe
0
 

Accepted Solution

by:
Dwaineo earned 0 total points
ID: 39739664
So, after I saw the WinXP PC work properly, I ran the Brother Install Diagnostics on the Win7 PC. It said the scanner and printer driver were not installed. Odd, since it prints fine. It recommended to put the install CD in, and run Repair. I attempted that, and got to a point where you select a USB or Wireless connection. USB was selected, and it would not let me select Wireless. Doh! So I uninstalled the whole Brother package, rebooted, reinstalled from scratch, selecting Wireless when I had the opportunity, and then rebooting again. Yay, it still printed, but no CC4 control. I had NIS Smart Firewall enabled again, so turned that back off, and now the CC4 Remote Device Config saw the thing. Configured Smart Firewall to let the Brother stuff through, and now it's all working. Annoying, since on the XP PC, the Brother sw apparently setup NIS to allow it through. But it's all good now.

I'm going to split the points between Technodweeb, who got me going on the XP side of things with his ping recommendation, and Joe for his detailed Brother insight. Thanks guys!
0
 
LVL 55

Expert Comment

by:Joe Winograd, EE MVE 2015&2016
ID: 39739681
Interesting stuff! Thanks for letting us know how it all played out. Very glad to hear all is good now. Regards, Joe
0
 

Author Closing Comment

by:Dwaineo
ID: 39745787
Joe and Technodweeb put me on the correct track to doing more detailed diagnosis on my end, and reinstalling the Brother software/driver package, and properly setting up the NIS Smart Firewall settings.
0

Featured Post

[Video] Create a Disruption-Free Workspace

Open offices have their challenges. And Sometimes, it's even hard to work at work. It's time to reclaim your office and create a disruption-free workspace. With the MB 660, you can:

-Increase Concentration
-Improve well-being
-Boost Productivity

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Well I am not sure whether i deserve anything (credit or points) for this article, since I have not written the source code but discovered the same while browsing the net. I only wish to help EE users save some money and probably help the environmen…
It started not too long ago. It was at first annoying. My keystrokes seemed to be randomly generated, not the ones I typed on the keyboard. For some reason this only happened in certain applications (especially browsers such as IE11, Firefox and Chr…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question