SCCM 2012 R2 - Report Services

Good day Experts!

I am working on getting SCCM 2012 R2 setup and have the basics of it working, but having a problem the Reporting Services role.  I have installed the role without a problem but when I try to look at reports, the selection is blank.  If I try to create a report I the message "At least one report category must exist before a report can be created. Create a report folder, then try again."

If I look on my SCCM server I find the "stock" reports in C:\Program Files\SMS_SRSRP but don't see how to tie the two together. I am sure I either missed something in the setup or entered something correct.

How can I fix?  Thanks so much in advance.
jchauncey60Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JAN PAKULAICT Infranstructure ManagerCommented:
jchauncey60Author Commented:
Thanks for the quick response. This is what I am seeing from the log:

System.Web.Services.Protocols.SoapException: An error occurred when invoking th
 authorization extension. ---> Microsoft.ReportingServices.Diagnostics.Utilitie
.AuthorizationExtensionException: An error occurred when invoking the authoriza
ion extension. ---> System.ServiceModel.FaultException`1[[System.ServiceModel.E
ceptionDetail, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKey
oken=b77a5c561934e089]]: Value does not fall within the expected range.~   at M
crosoft.ReportingServices.Library.ReportingService2005Impl.GetItemType(String I
em, ItemType& Type)~   at Microsoft.ReportingServices.WebServer.ReportingServic
2005.GetItemType(String Item, ItemTypeEnum& Type)  $$<SMS_SRS_REPORTING_POINT><
2-26-2013 09:30:25.466+300><thread=5504 (0x1580)>
(!) SRS not detected as running  $$<SMS_SRS_REPORTING_POINT><12-26-2013 09:30:2
.466+300><thread=5504 (0x1580)>
Failures reported during periodic health check by the SRS Server <NODE>.har
is-hc-lab.com.~  $$<SMS_SRS_REPORTING_POINT><12-26-2013 09:30:25.466+300><threa
=5504 (0x1580)>
Registry change~  $$<SMS_SRS_REPORTING_POINT><12-26-2013 09:30:25.466+300><thre
d=5504 (0x1580)>
~Waiting for changes for 1 minutes  $$<SMS_SRS_REPORTING_POINT><12-26-2013 09:3
:25.466+300><thread=5504 (0x1580)>
JAN PAKULAICT Infranstructure ManagerCommented:
1 Add yourself to  Operations Manager Administrators in SCOM User Roles

2 What is the health status under Monitoring -> System Status -> Site Status -> Reporting services point?

3 have you installed this

http://www.microsoft.com/en-us/download/details.aspx?id=6442

http://www.microsoft.com/en-us/download/details.aspx?id=35747
Introduction to Web Design

Develop a strong foundation and understanding of web design by learning HTML, CSS, and additional tools to help you develop your own website.

jchauncey60Author Commented:
Thanks again for the quick reply.

1.  I was already a 'Full Administrator' by my username and by group 'Domain Admins'

2. Reporting services point is Green.  The only one that is not green is 'State migration point' which is Yellow (we are not currently using this role)

3.  First link was already installed. Second link had a previous version so I upgraded

Still the same results
JAN PAKULAICT Infranstructure ManagerCommented:
jchauncey60Author Commented:
Both SCOM and SCCM are running on the same box and from reading the articles seems like I need to create another instance for SCCM; however I am not sure how to do this without uninstalling a reinstallation.  As a side note, SCOM was installed after SCCM.

I can do the reinstall, but would love to be able to save all the data collected to this point.  Sorry for all the questions, but I am a novice with these products.
JAN PAKULAICT Infranstructure ManagerCommented:
you could export the database in sql management studio

and then import it to different instance/server


http://blogs.technet.com/b/configurationmgr/archive/2013/04/02/how-to-move-the-configmgr-2012-site-database-to-a-new-sql-server.aspx
jchauncey60Author Commented:
Sorry for the delay, I have been working towards a solution.  I removed SCOM from the box and destroyed the associated DBs.  I uninstalled SCCM from the box and destroyed the DBs.  

I moved re-installed SCOM on a different box and so far it is working, although I have not installed Reporting role yet.

I did a fresh install of SCCM including the Reporting role and still have the same problem.  Reports are blank.

Any ideas?
JAN PAKULAICT Infranstructure ManagerCommented:
1 is port 1433 open on firewall?

2 disable the firewall (temporary) and test.

3 try running SQL Server Reporting Services service as Local System, (its probably set as domain admin)  (picture attached - to access type services.msc in start run)
100.png
jchauncey60Author Commented:
Thanks again...so I just don't get it.  

I decided for several reasons to blow away the entire SCCM 2012 r2 server. Loaded a new OS, new SQL, new SCCM 2012 r2.  No problems during the install and still no reports!

If I go to http://localhost:/reports I am told that I don't have privs to access the site.

Firewall is turned off (for troubleshooting).

I just don't get it...
JAN PAKULAICT Infranstructure ManagerCommented:
have you added this site http://servername

or if you are using https https://servername

to trusted sites in Internet explorer?

also use “Network Service” as the service identity for the Report Server web service.

Then in IIS go to the “Directory Security” tab in the properties window of both ReportServer and Report(Virtual Directories) and enable the Anonymous Access.

can you try accessing with fqdn of the server

like http://servername.domainname.com/reports

is it even asking you for credentials?

if so are you putting full domain credentials

like

domainname\username
jchauncey60Author Commented:
Thanks again for assisting me...not sure why M$ makes this so difficult other than to keep consultants employed.

Not being asked for UN/PW, but getting this message

The report server cannot decrypt the symmetric key that is used to access sensitive or encrypted data in a report server database. You must either restore a backup key or delete all encrypted content. (rsReportServerDisabled) Get Online Help Keyset does not exist (Exception from HRESULT: 0x80090016)
JAN PAKULAICT Infranstructure ManagerCommented:
Open Reporting Services Configuration Manager

Connect to your RS server

Select 'Encryption Keys' from the left pane

Press the 'Delete' button to get rid of your encrypted content



After doing this, you will need to re-set the connection strings and stored credentials on your reports.

http://connect.microsoft.com/SQLServer/feedback/details/322557/the-report-server-cannot-decrypt-the-symmetric-key
jchauncey60Author Commented:
Got rid of the encrypted content but don't see how to reset the connection strings and stored credentials...sorry can you give me a pointer

Getting this message now

User 'xxx\yyy' does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed.
JAN PAKULAICT Infranstructure ManagerCommented:
follow that


http://technet.microsoft.com/en-us/library/ms160330.aspx


and possibly that


http://sithayuvaraj.wordpress.com/2012/07/04/application-catalog-cannot-connect-to-server-error/


Try  running IE as administrator (right click run as administrator) (does it ask you to run UAC when trying to connect to reports?)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jchauncey60Author Commented:
Thanks for all your help, it finally assisted me getting to the reports.  I missed a step during configuration for the reporting service.  Once I fixed that and waiting a while I had reports...thanks again so very much!!!!!
jchauncey60Author Commented:
Very patient and helpful...hung in there with me!
JAN PAKULAICT Infranstructure ManagerCommented:
happy to help :)
vivaisCommented:
Hi Guys,
I'm trying to install SCCM 2012 R2 reporting on MS SQL 2012 SP2 with comullative update 2. The reporting server version is 11.0.5058

The error is:
(!) SRS not detected as running


System.Web.Services.Protocols.SoapException: An error occurred when invoking the authorization extension. ---> Microsoft.ReportingServices.Diagnostics.Utilities.AuthorizationExtensionException: An error occurred when invoking the authorization extension. ---> System.ServiceModel.FaultException`1[[System.ServiceModel.ExceptionDetail, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]: Value does not fall within the expected range.~   at Microsoft.ReportingServices.Library.ReportingService2005Impl.GetItemType(String Item, ItemType& Type)~   at Microsoft.ReportingServices.WebServer.ReportingService2005.GetItemType(String Item, ItemTypeEnum& Type)  $$<SMS_SRS_REPORTING_POINT><10-16-2014 20:49:43.955-240><thread=2348 (0x92C)>
(!) SRS not detected as running  $$<SMS_SRS_REPORTING_POINT><10-16-2014 20:49:43.955-240><thread=2348 (0x92C)>
Failures reported during periodic health check by the SRS Server SQL.PCMC.LOCAL.~  $$<SMS_SRS_REPORTING_POINT><10-16-2014 20:49:43.955-240><thread=2348 (0x92C)>
Registry change~  $$<SMS_SRS_REPORTING_POINT><10-16-2014 20:49:43.955-240><thread=2348 (0x92C)>
~Waiting for changes for 1 minutes  $$<SMS_SRS_REPORTING_POINT><10-16-2014 20:49:43.956-240><thread=2348 (0x92C)>

According to MS link the SCCM 2012 R2 support MS SQL 2012, am i right? pls help to solve issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Enterprise

From novice to tech pro — start learning today.