• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 576
  • Last Modified:


Hi I am trying to setup a L2 port-channel between two 6509-E's and when I get to the second switch I keep getting this error:
Command rejected: VLAN port provisioning is enabled. Please input vlan name.

It won't let me add any Vlans to the trunk.   This is in my lab so I'm trying to fiddle with it but I've been at it for a while and figured it's time to bounce some ideas off EE as well as reading up on Cisco's site.  

Appreciate any feedback!
1 Solution
Sounds like you have vlan locking enabled.  See description here:- http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/vlans.html#wp1060897

I haven't used the feature before, so I'd probably cheat and disable vlan locking (temporarily).  Otherwise you'll need to get used to it - apparently it forces you to configure vlan (trunk) access by name.
rotarypwrAuthor Commented:
Perfect that did the trick.  I do not need VLAN locking for this lab setup.  Thank you!  Also a good lesson learned that I figured I'd mention. Sometimes due to work pressure you get rushed and miss some obvious things.  I noticed someone else that was using the lab was using the same physical ports as part of another configuration so it certainly wasn't helping matters.  Cheers!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

We Need Your Input!

WatchGuard is currently running a beta program for our new macOS Host Sensor for our Threat Detection and Response service. We're looking for more macOS users to help provide insight and feedback to help us make the product even better. Please sign up for our beta program today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now