Solved

Cisco QoS for Voice VLAN

Posted on 2013-12-26
19
1,212 Views
Last Modified: 2014-01-19
Hi,

I have 2 Cisco switches, a L3 3560G and a L2 2960G and I'm attempting to enable QoS throughout both of the switches to support the tagging and application of QoS to every available port.

I'm not too sure if my configuration is correct however I have 2 VLANs on each access port,
switchport access vlan 50

Open in new window

is the data VLAN and
switchport voice vlan 100 

Open in new window

is the voice VLAN.

mls qos

Open in new window

has been applied to both switches.

Basically each port has the following configuration (except the trunk port on each switch):

interface GigabitEthernet0/10
 description to wall socket 10
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 100
 switchport priority extend cos 5
 mls qos trust cos
 spanning-tree portfast

Open in new window


I basically want it configured so that I can connect any type of IP phone (as Cisco phones may not be used) and manually configure the phone's voice VLAN to be VLAN 10 and the phone's data port to be VLAN 100. VLAN 10 should have a CoS priority of 5 and VLAN 100 should be default which I think is 0 (best effort)?

Each of the trunk ports that connect the switches together are configured similar to:

interface GigabitEthernet0/45
 description to 3560g
 switchport mode trunk
 ip dhcp snooping trust

Open in new window


Could someone please provide some additional guidance on this, just to make sure that I have this right?

VTP is configured and enabled, so the 2960G receives the VLANs from the 3560G switch.
0
Comment
Question by:bradbald
  • 10
  • 5
  • 4
19 Comments
 
LVL 11

Expert Comment

by:Miftaul
ID: 39741341
You are saying voice VLAN to be VLAN 10 and data VLAN to be 100 but your switchport configuration says Voice VLAN 100 and data VLAN 50. Please check
0
 

Author Comment

by:bradbald
ID: 39741356
Sorry, wasn't thinking too hard there...

data vlan is 50
voice vlan is 100
native vlan is 1 (default as we all know)
0
 

Author Comment

by:bradbald
ID: 39747706
Anyone?
0
 
LVL 11

Accepted Solution

by:
Miftaul earned 500 total points
ID: 39747764
your configuration seems just fine, as you are tagging the VLAN and QoS on the non-cisco phone, this should work perfect.

interface GigabitEthernet0/10
 description to wall socket 10
 switchport access vlan 50
 switchport mode access
 switchport voice vlan 100
 switchport priority extend cos 5
 mls qos trust cos
 spanning-tree portfast

Open in new window

0
 

Author Comment

by:bradbald
ID: 39747771
So is this all that is required to configure the actual switches? Do the trunk ports between the switches need to be configured also?

Will this configuration basically give vlan 100 higher priority over vlan 50 as long as devices can tag their voice traffic on vlan 100?
0
 
LVL 11

Expert Comment

by:Miftaul
ID: 39747805
Once you set QoS at the source, that will traverse through the switching fabric through the trunk. We don't need additional QoS configuration on the trunk.

We do however need to set the QoS on the Uplink and Downlink port.
0
 

Author Comment

by:bradbald
ID: 39747808
So basically apply mls qos trust cos to all ports?
0
 
LVL 11

Expert Comment

by:Miftaul
ID: 39747810
Yes, all access port with Voice VLANs.
0
 

Author Comment

by:bradbald
ID: 39747815
Thanks, however you specify having to set Qos on the uplink and downlink ports, these are the trunk port on each switch yes?
 
If so, does the mls qos trust cos need to applied to those uplink/downlink/trunk ports?
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 11

Expert Comment

by:Miftaul
ID: 39747823
Trunk ports are the switches connecting to each other within your network, and Uplink/downlink are the links connecting to outside say router.

You can configure QoS on trunk, if you do so, it will overwrite the QoS tags on untagged VLAN traffic as well. Thats why we can leave Trunk ports without any QoS configuration, because it will preserve the source VLAN QoS marking.
0
 
LVL 1

Expert Comment

by:gbotts
ID: 39784095
Please add this to your switches. Cisco switches do not label QoS properly.   I know this is probably a closed discussion but this is required if you truly want it to work properly..

Hope this helps...


!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
0
 

Author Comment

by:bradbald
ID: 39785036
What does all that mean basically?
Isn't that already done using mls qos or does the above set out the priorities and equivilents in terms of dscp markings and cos markings?
0
 
LVL 1

Expert Comment

by:gbotts
ID: 39786468
The switch doesn't mark properly. This is the exact settings required to ensure your QoS marking is correct.   It's a long explanation but someone has already done it for me.. :-)

Have a read and let me know if this answers it for you.  

Hope this helps..

https://supportforums.cisco.com/thread/2051718
0
 

Author Comment

by:bradbald
ID: 39786978
I notice that entering these commands removes the 'mls qos' entry. Is that normal?
0
 

Author Comment

by:bradbald
ID: 39786999
Does any further configuration need to be applied to each switch port?
0
 
LVL 1

Expert Comment

by:gbotts
ID: 39787292
Enable autoqos and you should be good.  The autoqos will do all the port configs and should also do the uplink configs...

It shouldn't have removed it. If you do a "sho run | i mls qos "  what does it show?  That command is usually at the bottom depending on the platform and IOS....
0
 

Author Comment

by:bradbald
ID: 39787760
But does this configuration still give the voice vlan cos 5 and the data/access vlan nothing?
0
 
LVL 1

Expert Comment

by:gbotts
ID: 39789075
Yes... The changes are only within the switches marking system.  It ensures the switch marks everything properly.
0
 

Author Comment

by:bradbald
ID: 39793155
OK thanks for that. Much appreciated.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The worst thing when starting a new job is when the previous Network Administrator left behind no documentation. How do you get into the devices? If you've been in this situation or just accidently mistyped your password, this article will hopefully…
Article by: user_n
How Sip Phone (User Agent) works and communicates with sip servers 1.  There is a sip server and a sip registrar.  The sip server and sip registrar can be one server or two different servers. The sip registrar is the server on which it is record…
This Micro Tutorial will give you a basic overview how to record your screen with Microsoft Expression Encoder. This program is still free and open for the public to download. This will be demonstrated using Microsoft Expression Encoder 4.
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).

896 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now