?
Solved

Cisco SG300 LACP config

Posted on 2013-12-27
11
Medium Priority
?
8,891 Views
Last Modified: 2014-01-06
We purchased a 2nd switch (sg300-28) to add redundancy. Both switches are the same model, and both set to L3 Mode.

Can someone please review the below config to verify if LACP is correctly configured between the two switches on ports 27 & 28 to allow all traffic to flow between the two switches.

FYI, the factory default VLAN was changed from 1 to 1000 to match the 1st switch.

config-file-header
i1lvsw02
v1.3.5.58 / R750_NIK_1_35_647_358
CLI v1.0
set system mode router

file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
default-vlan vlan 1000
exit
vlan database
vlan 1-2,101,320,400,646,649,1020,1030,1040
exit
voice vlan state disabled
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
bonjour interface range vlan 1
hostname i1lvsw02
line ssh
exec-timeout 30
exit
no passwords complexity enable
username cisco password encrypted da193767a7ba202949500df3547a3151dc0ee4a5 privi                                                                                        lege 15
username pavel password encrypted a5f6338dcec5cg56440a92f22c04098e5808fafc privi                                                                                        lege 15
ip ssh server
snmp-server server
snmp-server location "Las Vegas"
snmp-server contact "Pavel"
ip http timeout-policy 1800 http-only
clock timezone PST -8
clock summer-time web recurring usa
sntp broadcast client enable both
clock source sntp
clock source browser
sntp unicast client enable
sntp unicast client poll
sntp server 64.250.229.100 poll
sntp server 205.233.73.201 poll
ip telnet server
!
interface vlan 2
 name Transit
 ip address 10.0.15.250 255.255.255.248
!
interface vlan 101
 name DMZ
 ip address 10.0.0.1 255.255.255.0
!
interface vlan 320
 name Server
 ip address 10.0.32.2 255.255.255.0
!
interface vlan 400
 name Citrix
!
interface vlan 646
 name Batch
!
interface vlan 649
 name Desktop
 ip address 10.0.64.130 255.255.255.128
!
interface vlan 1000
 ip address 10.10.0.2 255.255.255.0
!
interface vlan 1020
 name Storage
 ip address 10.20.0.2 255.255.255.0
!
interface vlan 1030
 name Replication
 ip address 10.30.0.2 255.255.255.0
!
interface vlan 1040
 name HSRP
!
interface gigabitethernet1
 switchport mode access
!
interface gigabitethernet2
 switchport mode access
!
interface gigabitethernet3
 switchport mode access
!
interface gigabitethernet4
 switchport mode access
!
interface gigabitethernet5
 switchport mode access
!
interface gigabitethernet6
 switchport mode access
!
interface gigabitethernet7
 switchport mode access
!
interface gigabitethernet8
 switchport mode access
!
interface gigabitethernet9
 switchport mode access
!
interface gigabitethernet10
 switchport mode access
!
interface gigabitethernet11
 switchport mode access
!
interface gigabitethernet12
 switchport mode access
!
interface gigabitethernet13
 switchport mode access
!
interface gigabitethernet14
 switchport mode access
!
interface gigabitethernet15
 switchport mode access
!
interface gigabitethernet16
 switchport mode access
!
interface gigabitethernet17
 switchport mode access
!
interface gigabitethernet18
 switchport mode access
!
interface gigabitethernet19
 switchport mode access
!
interface gigabitethernet20
 switchport mode access
!
interface gigabitethernet21
 switchport mode access
!
interface gigabitethernet22
 switchport mode access
!
interface gigabitethernet23
 switchport mode access
!
interface gigabitethernet24
 switchport mode access
!
interface gigabitethernet25
 switchport mode access
!
interface gigabitethernet26
 switchport mode access
!
interface gigabitethernet27
 no negotiation
 channel-group 1 mode auto
 switchport mode access
!
interface gigabitethernet28
 no negotiation
 channel-group 1 mode auto
 switchport mode access
!
interface Port-channel1
 flowcontrol on
 description SwitchToSwitch
 switchport trunk allowed vlan add 2,101,320,400,646,649,1020,1030
 switchport trunk allowed vlan add 1040
!
exit
macro auto disabled
ip default-gateway 10.0.15.254

Open in new window

0
Comment
Question by:pzozulka
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
11 Comments
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39742486
Nearly there, but try this instead...

interface gigabitethernet27
 no negotiation
 channel-group 1 mode active
 switchport trunk allowed vlan add 2,101,320,400,646,649,1020,1030
 switchport trunk allowed vlan add 1040
 switchport mode trunk
!
interface gigabitethernet28
 no negotiation
 channel-group 1 mode active
 switchport trunk allowed vlan add 2,101,320,400,646,649,1020,1030
 switchport trunk allowed vlan add 1040
 switchport mode trunk
!
interface Port-channel1
 flowcontrol on
 description SwitchToSwitch
 switchport trunk allowed vlan add 2,101,320,400,646,649,1020,1030
 switchport trunk allowed vlan add 1040
 switchport mode trunk

Open in new window

0
 
LVL 8

Author Comment

by:pzozulka
ID: 39742685
From the Admin guide:

To add a port to the LAG, it cannot belong to any VLAN except the default VLAN.
0
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39742698
I think that means you must create the LAG before you add VLANs to it.  IIRC you can't configure the VLANs on the LAG interface until it is created.
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 
LVL 8

Author Comment

by:pzozulka
ID: 39742745
I get an error message when trying to add the interface to the channel-group. It says: port gi27 belongs to a VLAN.
0
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39742758
Ok it may just be that it doesn't like the existing configuration, as there are already VLANs added to the interfaces.

Default the interfaces first, then try again, like this...

default interface gigabitethernet27
default interface gigabitethernet28
interface gigabitethernet27
 no negotiation
 channel-group 1 mode active
 switchport trunk allowed vlan add 2,101,320,400,646,649,1020,1030
 switchport trunk allowed vlan add 1040
 switchport mode trunk
!
interface gigabitethernet28
 no negotiation
 channel-group 1 mode active
 switchport trunk allowed vlan add 2,101,320,400,646,649,1020,1030
 switchport trunk allowed vlan add 1040
 switchport mode trunk
!
interface Port-channel1
 flowcontrol on
 description SwitchToSwitch
 switchport trunk allowed vlan add 2,101,320,400,646,649,1020,1030
 switchport trunk allowed vlan add 1040
 switchport mode trunk

Open in new window

0
 
LVL 8

Author Comment

by:pzozulka
ID: 39742839
Having trouble with the default interface command.

Tried to do it from the main cli, as well as from "config t", and from the "<config>int gi27", but it says the command is not recognized.

This is a sg300-28 switch (small business) in L3 mode.
0
 
LVL 10

Expert Comment

by:Mohammed Rahman
ID: 39746301
how about interface GE27

I have checked the SG300 Series CLI guide and the interface command is

switch(config)# interface gi1

Guide Link For your reference. Cisco 300 Series CLI Guide

Is your previous question: Creating a trunk between two switches still unresolved?
0
 
LVL 8

Author Comment

by:pzozulka
ID: 39746378
craigbeck: I'm having difficulty with the "default" command. It says unrecognized.

Mohammad Rahman: I'm getting mixed feedback from various sources. Cisco Small Business Support is telling me that the recommendations provided by forums is incorrect because the switches are set to L3 mode, and thus require me to setup static routes on each switch for each VLAN.

Example:
Switch A - 10.10.0.1
ip route 10.10.0.0 255.255.255.255.0 10.10.0.2

Switch B - 10.10.0.2
ip route 10.10.0.0 255.255.255.255.0 10.10.0.1

According to them, since it's set to L3, LACP will not work between the two switches without also configuring static routes between each of the VLANs.

Is this true?
0
 
LVL 8

Author Comment

by:pzozulka
ID: 39746466
Also for Layer 3, what load-balancing mode should I configure. The default is by MAC address, but the other option is "By IP and MAC Address".
0
 
LVL 46

Assisted Solution

by:Craig Beck
Craig Beck earned 1000 total points
ID: 39746485
Cisco are wrong.  You can't run an EtherChannel if the individual ports are in L3 mode, but they're not so its fine.  You don't need a static route per VLAN either that's just nonsense.

You can use the default load-balancing method and it should be fine.
0
 
LVL 10

Accepted Solution

by:
Mohammed Rahman earned 1000 total points
ID: 39746882
This is what I read across few forums:

MAC Address—Perform load balancing by source and destination MAC addresses on all packets.
IP /  MAC Address—Perform load balancing by the source and destination IP addresses on IP packets, and by the source and destination MAC addresses on non-IP packets.

SG300 series doesn't support balance by port, It supports by IP and MAC.

The switch supports 2 load balance toggles

config t
port-channel load-balance src-dst-mac-ip

config t
port-channel load-balance src-dst-mac

You might find Setting LAG Article interesting. Ignore the VMWare part in it. It is for SG300-20 and I hope the same should apply to SG300-28

Select IP/MAC Address under "Load Balance Algorithm" and then start following steps from "creating first link aggregation group...."

Configuring Link Aggregation

Apologies for providing ONLY links and no direct answers. You have the equipment with you and probably you will be able to setup things by following instructions from those links. OR other EEs could :-)
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Arrow Electronics was searching for a KVM  (Keyboard/Video/Mouse) switch that could display on one single monitor the current status of all units being tested on the rack.
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question