Solved

Users cant login to OWA after being migrated form Ex2007 to Ex2013

Posted on 2013-12-27
5
4,494 Views
Last Modified: 2014-02-17
I just finished my Ex2007-Ex2013 coexistance and everything is working great except OWA.
Ex2013 CU2 is installed on Win 2012 which has all the required prerequisites.

It only seems to apply to NON Admin users.
So far only 2 users have been migrated from ex2007 and 1 new user created on ex2013.
All 3 cant login to OWA.

It seems to load fine for a moment, I can see the inbox  with this message:
Your Request cant be completed right now. Please try again later.
but then it kicks them out back to login screen.

Then when they try again, it says:
something went wrong
A problem occurred while you were trying to use your mailbox

I did have the same issue for Admin accounts but I manged to resolve that by
Go under the user in AD and on their Security Tab I went to Advanced and checked the box to ‘inherit’ the parent settings

This didnt help with other users as they already had the inherit selected.

Looking at the IIS logs I see these errors.
GET /owa/ &ActID=fc9efcef-5f48-448e-9c09-e1bce707fe01&ex=UE:Microsoft.Exchange.Data.Storage.TooManyObjectsOpenedException 444 Domain\User
There was an error setting up WacConfiguration. Wac will be disabled and we will fall back to stellent. The WacUrlHostName was invalid. Expected a valid Uri. Actual value was ''. Value read from 'OrganizationConfig'

Looking at the event logs I see a warning:

A process serving application pool 'MSExchangeSyncAppPool' suffered a fatal communication error with the Windows Process Activation Service. The process id was '3956'. The data field contains the error number.

I checked the AppPool and it is RUNNING.


I looked up the Toomany objects error and found some registry fix for Ex2010 but nothing on Ex2013. I applied it but it didnt resolve my issue. I set it to 40 but still got this message:
Mapi session /o=Company/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=34c38d3c155f45f4a10f4c5e091aa240-ittest3 with client type OWA exceeded the maximum of 40 objects of type Session.

Rather than just increasing it more, i need to find out why its using all those objects.

I believe this issue started after upgrading to CU2. My test user connected fine to OWA before the update.
0
Comment
Question by:baysysadmin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
5 Comments
 

Author Comment

by:baysysadmin
ID: 39742782
Turned out that HTTPS redirect wasnt working.
When manually specifying HTTPS and then logging in, it loads fine.

I tried 3 different methods of getting the HTTP redirect workig with no luck.

http://msexchangeguru.com/2013/10/30/http-redirect-owa-ecp/
http://www.jppinto.com/2009/04/automatically-redirect-http-requests-to-https-iis-7/
And also a default redirect file with this code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
<title>Your Page Title</title>
<meta http-equiv="REFRESH" content="0;url=https://mail.domain.com/owa"></HEAD>
<BODY>
</BODY>
</HTML>

None of them redirected http to https
0
 
LVL 15

Expert Comment

by:Rajkumar-MCITP
ID: 39743553
Please check this blog to find whether you are in the same situation..

http://terenceluk.blogspot.in/2013/10/exchange-server-2013-owa-throws-error.html
0
 

Author Comment

by:baysysadmin
ID: 39746326
Wow that is a lot of steps, none of which I did. Ill have to look at that in more detail.
I really hope I dont have to redo my exchange. I already moved 3 users, can I use the same process to move them back to 2007 database?
0
 

Accepted Solution

by:
baysysadmin earned 0 total points
ID: 39746355
I did a check on some of the errors he had.
I dont have any of the httpproxy log errors or IIS ISAPI missing modules.

I also dont have the
Your request can't be completed right now. Please try again later
Error when using HTTPS.
I do have that error when using HTTP which goes away when I switch to HTTPS, hence the reason why i was looking into a redirection in the first place.

I may just have to instruct my users to use HTTPS. I noticed once you browse it ONCE, then later the browser will automatically redirect you to HTTPS no matter what you type.

Unfortunately if the users logs in for the 1st time using HTTP and they get the error
A problem occurred while you were trying to use your mailbox.
Switching to HTTPS doesnt fix it until you clear your browser cache/history or restart your browser.
0
 

Author Closing Comment

by:baysysadmin
ID: 39864322
Ended up updated Exchange to CU3 and then setting up http to https redirection.
The issue went away completely.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question