Solved

Cannot open SQL Server Express 2008 management studio

Posted on 2013-12-28
3
719 Views
Last Modified: 2014-01-02
I have installed SQL Server Express 2008 on my Windows server 2008 and when I try to open the management studio the following error pops up:

Cannot connect to {Server name}

A network-related or instance-specific error occured while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open connection to SQL Server) (Microsoft SQL Server, Error: 2)
0
Comment
Question by:mike99c
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 23

Expert Comment

by:Patrick Bogers
ID: 39743436
Hi

Open SQL on the server itself and configure to accept remote connections like shown below:
allow remote connections
Next, i expect you to run into the next problem, configure TCP/IP to be enabled and select port 1433 for remote management by executing following steps:

1.Open SQL Server Configuration Manager. Click Start / Programs / Microsoft SQL Server 2008 express / Configuration Tools / SQL Server Configuration Manager.
2.Expand SQL Server Network Configuration / Protocols for [Instance Name]. If you see that TCP/IP protocol status is disabled, right click to Enabled it.

3.Open TCP/IP properties to set the correct listening port:
1.In Protocol / General, set Enabled = Yes.
2.In IP Addresses / IPAll, set TCP Port = 1433 and TCP Dynamic Port = an empty string (to disable the dynamic port).

Lastly, create a firewall rule to allow port 1433 en restart your MSQL Server services.

Now you would be ready to fire off SSMS.
0
 

Accepted Solution

by:
mike99c earned 0 total points
ID: 39743443
It's ok I found out what the issue was. In the login dialog where you have the server name, it should have been of the form:

{Server name}\SQLEXPRESS

I left out the \SQLEXPRESS part.
0
 

Author Closing Comment

by:mike99c
ID: 39750934
I have sincefound out what the issue was and the server name part in the login dialog was not correctly filled in.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Ever wondered why sometimes your SQL Server is slow or unresponsive with connections spiking up but by the time you go in, all is well? The following article will show you how to install and configure a SQL job that will send you email alerts includ…
A Stored Procedure in Microsoft SQL Server is a powerful feature that it can be used to execute the Data Manipulation Language (DML) or Data Definition Language (DDL). Depending on business requirements, a single Stored Procedure can return differe…
Familiarize people with the process of utilizing SQL Server functions from within Microsoft Access. Microsoft Access is a very powerful client/server development tool. One of the SQL Server objects that you can interact with from within Microsoft Ac…
Familiarize people with the process of retrieving data from SQL Server using an Access pass-thru query. Microsoft Access is a very powerful client/server development tool. One of the ways that you can retrieve data from a SQL Server is by using a pa…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question