Solved

Windows 7 Virtual Machine Failure on MacBook Pro - How to Recover?

Posted on 2013-12-28
47
3,730 Views
Last Modified: 2014-01-28
While conducting some remedial work on a previously closed question regarding the non-resolution of the Time Machine Backup problem, another situation arose involving the disappearance of the Windows 7 Virtual Machine from the Parallels 7 Desktop.app.
On 24 Dec 2013, in the Application Launcher window, the Windows 7 Application folder disappeared! In selecting the Parallels Desktop.app icon on the Mac OS Desktop, an error message was displayed:
“The Virtual Machine is not available
The virtual machine files have been moved or deleted.  If the files are on an external device, reconnect the device.  You can also remove the virtual machine from the list, or manually locate its files.
Cancel  Remove  Locate”.
 The Windows 7 icon disappeared from the Desktop.  It was replaced by a large “?” on the display.
Regrettably, I accidently hit the “Remove” option!

In an obvious panic-mode reaction, I conducted a reinstallation of my Windows 7 Home Premium, from the original x64 DVD.  Regrettably, I did not exercise sufficient good sense to use the System Restore option on the Installation process (although I do not recall it being displayed as an option!)!  I also do not recall seeing the usual warning that continuing with the reinstallation process would delete all data from the relevant storage device (V:\ on my MacBook Pro, OS 10.7.5).  Hence, all my applications and associated data were deleted from the Mac OS system!

There were 135 Windows updates (473.5 MB total) required for downloading and installation.  After more than 35 minutes of downloading, a “low memory warning” was displayed.  The installation process stopped after 127 completions.  The remaining 8 were downloaded and installed separately.

Following the reinstallation and updating of Windows 7, the Mac OS had to be rebooted, and the Parallels Tools reinstalled (took over 35 minutes).  There were also several further Windows Updates required.

Note that the last Mac OS backup (to the USB 3.0 My Passport 1 TB) external HD was completed early in the morning prior to the catastrophic loss of Windows 7 – Parallels Desktop.

I also note that, in investigating whether a recover/restore operation from Windows Backup application would resolve the problem, I could not get to select the USB External HD (My Passport Essentials-320 GB) as the backup device, despite it having been previously used successfully (last one on 16 Dec 2013) for the Windows Backup process.

Following advice provided by einosullivan as part of the closed question
"Sorry to hear your Parallels VM disappeared.  If you've backed it up to an external HD, you can simply copy it back into the Parallels folder on the HD of your Mac (you might want to rename it as there could be a new VM in that folder too).
The Parallels VM file has the extension .pvm
The Parallels VM folder is located in /Users/bruce/Documents/Parallels
You simply launch Parallels and then select the OPEN command from the File menu or the Parallels Virtual Machines window and browse to the .pvm file you copied back to the HD."
the renaming of the two Windows pvm files, the Parallels Desktop.app reverted to the display of a “?” in the window, plus an error message:
“The Virtual Machine is corrupted
The virtual machine cannot be used because its files are corrupted.
      Cancel            Remove”
I have taken no further action pending the Experts-Exchange response to this new question.
Appreciatively, Bruce
0
Comment
Question by:R_Bruce_Morris
  • 24
  • 21
  • 2
47 Comments
 
LVL 90

Expert Comment

by:John Hurst
ID: 39744176
I am not an expert in Parallels, but I do use VMware Workstation and have lots of machines, all of which I built myself, both Windows and Linux.

Based on your description "all my applications and associated data were deleted from the Mac OS system!", that machine is gone.

Then based on the later description "plus an error message: The Virtual Machine is corrupted", the backup is not of much use either.

So based on my own experience, you need to re-assemble your machine and get any data from any other source you might have.

I do not know about Parallels, but I do know I make complete copies of my machines about 3 times a year (overwriting prior copies) so as to assure myself of not too much loss.

.... Thinkpads_User
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39744719
If you didn't write any files to the system folder since that time , there might be a chance to use a recovery software and recover your PVM files.

I don't know which softwares have better results on recovering in Mac systems but I know these 2 softwares which are free:
TestDisk
Minitool
0
 

Author Comment

by:R_Bruce_Morris
ID: 39744741
Hi Thinkpads_User & kpax77: My description of "all applications …" ought to have clarified that only the Windows 7 applications had disappeared from my Parallels Virtual Machine.  Hence, my Mac OS machine is working well!
I executed the transfer of the Parallels.pvm file (renamed to Parallels-preloss.pvm) to the correct folder.  I then renamed the current Parallels.pvm file to Parallels-post-reinstallationofWindows7.pvm, followed by renaming of the transferred file to Parallels.pvm.  I assumed that the Parallels virtual machine would then use this recovered Parallels.pvm file for its normal operations.  Perhaps there was another step required, which I failed to execute, in the process.
I would still like to know whether I ought to be able to use Windows backup to recover/restore my Windows 7 (having been reinstalled) to its pre-failure mode.  I also need to resolve why I cannot seem to use my USB My Passport Essential external hard drive to both set up the Windows Backup process (given the reinstalled "virgin" Windows 7 Home Premium system), and to execute a system recovery/restore from the pre-crfash backup version on that external HD.
I will be most grateful for any further assistance/advice i this rather critical matter ( I desperately need to be able to use my Quicken XG 2007 application (for which I have over 10 years of data stored therein - I also have separate backups on a Lexar USB memory device), and my FrontPage 2003 application which I use to support two Websites.
Given einosullivan's assistance with my previously closed question regarding my Time Machine Backup issue [noting that while officially closed, it ought to be re-opened (but how?)], I look forward to his continuing involvement.
Appreciatively, Bruce
0
 
LVL 10

Accepted Solution

by:
Arman Khodabande earned 500 total points
ID: 39744761
So sorry , I misunderstood the situation!
This is what I understood from your explanation:
Your had a virtual Windows 7 installed on a PVM.
The Windows 7 worked fine but the applications inside the VM disappeared. (or the whole Windows 7 couldn't boot up? possibly pvm got corrupted?)
Then you have a backup of a working pvm on the external source with all applications installed and you wanna replace the old one (?)
Do you have a backup pvm or windows backup files on the external HDD?
And I have the same exact USB 3.0 My Passport WD Hard, what's the problem with that?
you can't connect it to the Parallels or the Mac osx itself?
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 39744764
Hence, my Mac OS machine is working well!

I assumed that and was only talking about the virtual machine.

I would still like to know whether I ought to be able to use Windows backup to recover/restore my Windows 7 (having been reinstalled) to its pre-failure mode

You said / suggested in your first post that you did an install without regard to trying to save your files, so I do not think you can recover / restore now. The overwriting install goes too far for that.

I also need to resolve why I cannot seem to use my USB My Passport Essential external hard drive

I do not know what this occurred but the message above says the backup is corrupted.

.... Thinkpads_User
0
 

Author Comment

by:R_Bruce_Morris
ID: 39744820
Hi again:  My problem(s) are obviously very complex - even to explain what has happened and what steps that I have already taken to attempt to resolve them.
For clarification, I do have a back up of each of my Mac OS (without Windows 7 Virtual machine, and Windows 7 - each is on a separate external USB 3.0 HD!
I have already stepped through the process of transferring, and renaming as appropriate, the Parallels.pvm file from my Mac OS backup to the Mc OS internal HD (as I attempted to describe in my initial post).
However, I need to resolve the issue of apparently not being successful at accessing my Windows 7 external USB HD (the usual process of ejecting the drive then reconnecting it does not appear to provide the option of ensuring the HD is allocated/assigned to the Parallels Windows 7 - vice the Mac OS.  The Windows 7 Backup drive was originally assigned to the Parallels Windows 7 domain, and the Windows Backups were successful (although the aggregate of .zip files only totalled some 2.9 GB, which hardly seems adequate to have captured all of my Windows 7 information.data).
When I was able to access Parallels Windows 7, I was unable to access the previously designated external USB HD to setup the Windows Backup process, hence to use the Windows Backup restore system recover/function.
BTW, in attempting to seek Parallels Desktop support via parallels.com for the latest error problem ID 15232, my valid Support code from the original Parallels Desktop installation was rejected.  Hence, that support source does not appear to be available to me!
Was there something wrong with my process to replace the previous Parallels.pvm file from my Mac OS backup external USB 3.0 HD (My Passport 1 TB) to my Mac OS internal HD?
Does the apparent failure have anything to do with the fact of my Windows 7 having been reinstalled, thereby creating some anomaly/incongruity with Parallels Desktop?
Now I have just discovered an additional anomaly in my MacBook Pro!  In attempting to reopen Parallels Desktop, a window was displayed showing two versions (see attached .png file), one showing the failed Windows 7 with the "?" mark displayed, the other with Windows 7 (1) displayed.
I really do not know how to proceed beyond this point!  Help please!!!!!!
Appreciatively, Bruce
0
 
LVL 10

Assisted Solution

by:Arman Khodabande
Arman Khodabande earned 500 total points
ID: 39745340
Ok, now better!
The solution I can come up with is that if you want to rescue your files (files only) from the external pvm, you can follow this procedure.

If you want to completely replace the newly installed Windows 7 with the backup one to be able to boot it follow the below steps:
Parallels Wizard > select Add Existing Virtual Machine > Continue > Navigate to .pvm (vm) on your external drive
You will be asked "Have you copied or moved "Your vm"?  Answer "Moved".

I hope that helps.
Note: According to parallels: Using two identical virtual machines may violate the Windows license agreement.

And for the USB troubleshooting:
You need to check properties in Windows.  Please open "My Computer": >control panel, >Administrative tools, >services. In the list of services is "removable memory" --- activate it and the computer now recognizes your removable storage devices.
if the problem still persists:

There's a way to get around this, you can map your hard drive as network folder for windows 7! For details read this Parallels doc.
0
 

Author Comment

by:R_Bruce_Morris
ID: 39747476
Hi kpax77:

As I described in my original post, I have already conducted the process of renaming the Parallels.pvm file from my Mac OS Backup of 24 Dec 2013 - taken prior to the catastrophic failure, transferring it to my Mac OS applicable folder.  I then renamed the existing Parallels .pvm file in order to subsequently rename the transferred file back to a "vanilla" Paralles.pvm.  Unfortunately, it appears that the process did not permit the Windows 7 VM to use the renamed "vanilla" Parallels.pvm file, but rather continued to use the renamed previous Parallels.pvm.  That is why I somehow have two versions of Windows 7 VM (one which operates correctly - but with only the "raw" new Windows 7 configuration i.e. without any of my Windows 7 applications and associated data.

Regrettably, I cannot locate the "Parallels Wizard" to try your solution.  Hence, I need clarification as to where to find the correct process to follow your suggested solution [Parallels Wizard > select Add Existing Virtual Machine > Continue > Navigate to .pvm (vm) on your external drive. You will be asked "Have you copied or moved "Your vm"?  Answer "Moved"]. to replace my newly installed Windows 7 with the previous Parallels.pvm which existed prior to the catastrophic disappearance of Windows 7 VM (on the basis that this would provide the same Windows 7 configuration as existed at the time of the failure and reinstallation of Windows 7).  I assume that this would recover all of my Windows 7 applications and associated data files.

I started (activated) the Virtual Disk Service (I could not find "removable memory on my list of Services).  However, I still could not locate any device to set up or Restore Files (advanced).  Attempting to identify the W:\ external USB HD from the Network Share selection (\\W:\OWNER-PC\Backup Set 2013-12-16 133405, entered manually into the "Browse" window, produced an error "The network location cannot be read-network path not found (0x80070035)".

I also experienced another problem when attempting to copy the relevant Windows 7 backup files from my external USB  HD - when it was accessible via Mac OS - to my Mac OS Desktop.  During the attempted copying process the notification was displayed that the filenames were too long to be accommodate on the Desktop.  After comparing the contents of the two sources of the backup files, indeed, there were files missing from the copied version on the Desktop.  I had though that perhaps I could identify the Desktop location as the source for the recovery/restore process, so as to recover my Windows 7 applications and associated data files.

I am still experiencing problems with my USB external HD disappearing from Finder (I also note that ejecting the subject device, then reconnecting it does not provide the option to associate/assign it to either Mac OS or Windows 7 VM.

BTW, I have already had the appropriate setting for sharing the removable disks between Mac OS and Windows 7 VM (as described in the referenced Parallels webpage.

Any other possible approaches to set up my Windows 7 virtual machine [Windows 7 (1) - Parallels Desktop] to be able to both setup Windows Backup and use the Restore Files (Advanced) function?

Appreciatively, Bruce
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39747613
Parallels Wizard is the same az "New Virtual Machine" , act as you want to add a new virtual machine (the backup one), to do so :

1. From Files menu choose  ¿ New.
File Menu > New
2. Select "Add Existing Virtual Machine" from the bottom.
Add Existing Virtual Machine
And then continue from there. or you can alternatively point the missing virtual machine (the one which has exclamation mark on it) to the backup pvm. Read this article.

Disappearing of your hard drive from the finder is not related to Parallels. Check your Hard drive wires and check the S.M.A.R.T on your hard drive to make sure it's healthy.

Regards.
0
 

Author Comment

by:R_Bruce_Morris
ID: 39748191
Hi kpx77:

Thanks for the speedy response. However, I am concerned about the fact of two Windows VMs (one working on the newly-created Parallels.pvm - which I have renamed to Parallels-postReinstallation.pvm, and the the other working on the copied and renamed to "vanilla" Parallels.pvm).

Before I attempt your proposed resolution, I need to clarify an alternate possibility to rectify the obviously failed steps that I have taken to produce the current status.
 
Should I be able to copy, from my Mac OS backup external drive, the Parallels.pvm file, to replace the new Parallels.pvm file (renamed as noted above)?  Should I be able to select only the earlier files to replace those generated by the reinstallation process for Windows 7?  Should I then be able to delete the "delinquent" unwanted Parallels.pvm file, and then rename the copied, updated file from the pre-Windows reinstallation configuration?

Or can I safely select the remove option for the corrupted version of the Windows VM before performing the copy/replace operation that I have described above?

With apologies for perhaps making this process overly-complicated.

Appreciatively, Bruce
0
 

Author Comment

by:R_Bruce_Morris
ID: 39748905
Hi again kpx77:

After reviewing the excellent article in your referenced hotlink, I tried the process described therein.  Regrettably, because of the current status of the two Windows 7 VMs, but with each of the Windows 7.pvm files being in the Parallels 7 folder, the process does not provide for the "locate" option after obtaining the window with the "?" Windows 7, and the error message "The virtual machine file is corrupted".

Hence, I still need to determine whether I can safely delete the unwanted .pvm file (having first backed it, plus the second Windows 7-postReinstallation.pvm up separately), then select the option to remove the "?" Windows 7 VM.  Hopefully, with the remaining desired Windows 7.pvm file (renamed previously to the "vanilla" form "Windows 7.pvm", the repeat of the process described in the referenced Parallels.com knowledge base, my problem ought to be resolved?

I still have the Windows 7.pvm file from my Mac OS backup on my second external USB 3.0 HD (My Passport 1 TB), as part of my backups (2013-12-24 and earlier).

What next?

Appreciatively, Bruce
0
 

Author Comment

by:R_Bruce_Morris
ID: 39749358
Hi again:

After much very frustrating stumbling around, trying to apply the solutions proposed, I finally accomplished an apparently successful restoration using the backed up Windows 7.pvm file!
 
However, as a result of the process, I now have three Windows 7 VMs running under Windows 7 - Parallels Desktop!  One is the version [Windows 7 (1)] with only the bare configuration following the reinstallation of Windows 7 Home Premium, while the second (Windows 7) is non-operable with many deficiencies.
/Users/bruce/Desktop/3Win7VMs-Win7(2) SuccessfulRestore 2013-12-31.png
(file attached).

During the process, there were many anomalous circumstances, including one part of the process which called for a re-installation of Windows 7, because, allegedly, no Operating System was installed in the virtual machine!  I did not perform the requested (second) reinstallation.  

However, I prefer not to attempt to describe the tortuous unsuccessful steps, and the associated error messages, before apparent at least success was achieved.

Now I need to know the precise procedure to eliminate the Windows 7, and Windows 7 (1) no longer wanted Parallels VMs.

I wish all involved a Very Happy, Healthy, and Safe 2014.

Appreciatively, Bruce
3Win7VMs-Win7-2--SuccessfulResto.png
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39749451
Thanks God you finally managed to do that!!
You posted here so rapidly that I couldn't answer each of the comments above and now happy to hear that you were successful !
So now you have everything back? and the only problem is that you want to remove those 2 extra VMs?
Removing the rest is so easy just follow these steps.

Mary Christmas
Regards
0
 

Author Comment

by:R_Bruce_Morris
ID: 39749767
Happy New Year kpx77:

Thanks again.  I have removed all references to the two no-longer-wanted Windows 7 VMs
As a follow question, can I safely rename the remaining (wanted) Windows 7 (2).pvm file and/or the Windows 7 (1) VM to the vanilla Windows 7.pvm and Windows 7 Virtual Machine so as to "purify" my Windows 7 - Parallels Desktop?  If so, what id the best process to accomplish that?
I will keep this question open until I fully resolve this latter matter.
Note that I still have issues, perhaps unrelated to the Windows 7 "disappearance and subsequent poor decision to effect a reinstallation of Windows 7 Home Premium, with all of the associated frustrations in completing the total process apparently successful.  These issues relate to the apparent anomalies with the access to my external USB devices, plus the related assignment/allocation of those devices to either Mac OS or Windows 7, or both.  I will cause a separate question to be posted to address these remaining issues.
What a more pleasant way to have at least a major part of my New Year's resolution fulfilled (to have a "cleanly" operating MacBook Pro)!
Appreciatively, Bruce
0
 
LVL 10

Assisted Solution

by:Arman Khodabande
Arman Khodabande earned 500 total points
ID: 39749786
You're welcome.
That's also easy. Right click on your Windows 7 VM in the list and select configure.
In the Virtual Machine Configuration Window, you can easily rename your VM.
VM config
If you needed to change other settings like the dedicated CPU and ram refer to the user manual here.
Good luck
0
 

Author Comment

by:R_Bruce_Morris
ID: 39751872
Hi kpx77:
Thanks, I have renamed to achieve a "vanilla" Windows 7 Virtual Machine!
Regrettably "good Luck" is not in my court!
Another series of problems have arisen with Windows 7 Virtual Machine, from what gremlins I know not!
I have been experiencing irregular failures of Windows 7 VM, notably failures with errors for pimou.sys (pluralinput mouse) and piked.sys (pluralinput keyboard), the latter of which I had experienced and eventually resolved. But, some attempts to startup Windows 7 VM from the DriverMax Pro 7.25 application (which I have not yet updated to the latest version 7.26 - I also use it on my wife's HP Win 7 desktop) somehow succeed, but then fail when I attempt to execute the application to perform seven driver updates, including one for each of the problem-creating pluralinput-based drivers.  The failure error is often an "un-named" one, as distinct from one of the driver errors.  There is also an anomalous process while starting Windows 7 VM.  The Windows 7 desktop never reaches its complete form, before disappearing.  This occurs either with an apparent successful loading of the DriverMax Pro application, or an eventual failure window appearing.
As part of the several restart efforts, the occasional one displays a "Startup Repair" option.  When selected, with "System Restore" the process runs its course, then apparently permits me to open the DriverMax Pro application.  Unfortunately, the application then fails sometime during the execution of installing the seven selected updates required.  The next time DriverMax Pro is successfully loaded, the same seven updates have yet to be installed!
I have suffered through many more cycles of Windows 7 VM states, ending in abend failures, while some "Startup Repair" process (initiated by holding the F* key while booting up Windows 7 VM), resulting in an apparently successful recovery.  However, any attempt to execute an application, particularly DriverMax Pro 7.26, which requires driver updates to seven items, including each of the two problematic pikbd.sys and pimou.sys drivers.
I now have an operational Windows 7 VM, but I will not attempt to open any applications tonight!  
So now I am more confused than ever!
Is there any hope for a satisfactory resolution, e.g. a diagnostic tool which can be applied (noting that it now seems that I cannot even boot up into Safe Mode?
Thanks, in advance, for your continuing support in this highly complex matter, at least for me.
Bruce
0
 
LVL 10

Assisted Solution

by:Arman Khodabande
Arman Khodabande earned 500 total points
ID: 39755807
Oh, I know where the problem is :D
Drivermax is a nice software but it's for real machines not virtual machines.
So the drivers corrupt your virtual machine drivers!
Virtual machines have special set of drivers which is released by parallels itself.
Those set of drivers and tools are called Parallels Tools.

1.

See Parallels Tools Overview here...

2.

The location of Parallels on your Mac

3.

How to install Parallels Tools
My suggestion is that you restore your windows 7 from the backup once again and then install parallels tools and never install Drivermax on VM.
This may also help.
Good luck
0
 

Author Comment

by:R_Bruce_Morris
ID: 39757885
Hi einosullivan:
Thanks for the amazing revelation and probable resolution!
Should I have been able to determine the incompatibility with more careful research of the relevant documents on Parallels Desktop help and/or the DriverMax website information?
In any case, although I am in the midst of travelling from Kingston, ON to Largo, FL, with a stopover here in Sparta, NJ, I obviously wish to resolve my problem as soon as possible.
However, I am reluctant to go through the entire restoration of Windows 7 form the Parallels.pvm file still stored on my Mac OS backup external USB HD, if only because I have continued to use my Windows 7 applications anytime I could, thereby updating a considerable  amount of data, most of which I cannot afford to lose (because I have not been performing regular backups of my Mac OS)!
Hence, perhaps at my peril, I have tried to resolve the problem by first uninstalling the DriverMax Pro 7.26 (using my RevoUninstaller program), given that Windows 7 VM appeared to be working satisfactorily without a crash.  I then reinstalled Parallels Tools.  I then restarted Windows 7 VM, apparently successfully, with some updates required to USB devices.  I was able to open most of my Windows 7 applications, although I did not conduct any operations on them, with some exceptions.
The applications just opened and closed were: Quicken XG 2007, Turbo Tax Canada 2012, FrontPage 2003, Bridge Baron 19, FileZilla Client 3.7.3, Firefox 18.0.1, Dragon NaturallySpeaking 12.5 (though not yet installed, so I did not do so), Adobe Reader 11.0.04, and Family Tree Maker 2012.  This application unfortunately caused a DRIVER_IRQL_NOT_LESS_OR_EQUAL crash, with a tcpip.sys error, during an automatic re-sync process - with an online version of my .ftm file; this process automatic with each start of the program.
I went through several cycles of the restart of Windows 7 VM, with several crashes, before I was able to use an "operational" version.  I tested some more applications (McAffee Security Scan Plus which ran a clean scan successfully, FTM 2012 again, to conduct the recommended Compress file process - because somehow my last use of the program had resulted in an improper shutdown of the application).  I also tried my Roxio Creator 2012 program, and its integral PhotoSuite 13.5 application, which I depend on  frequently.  Both programs opened successfully, although I did not test any use of the program.  I then tried my Web Easy Pro ENU application (which I do not yet use).  I had to perform an update (24.19 MB - which took forever to download at an average of 4 KB/Sec).  The update appeared to succeed.
I then tried my Zinio Reader 4 program.  One of my magazines - PC Mag - required downloading, during which another DRIVER_IRQL - … tcpip.sys error occurred.
I have attached a screen shot of the "Windows checking for solution" process.
This is where I am currently.
Do I now have to acquiesce to your recommended solution and perform the recovery via the Parallels.pvm replacement from my Mac OS backup USB HD?
BTW, I cannot seem to locate my "active" Parallels.pvm file.  I understand that it ought to be in my Parallels folder, but the contents are empty!  Also, a search of my MacBook Pro for "Parallels.pvm" only reports files with a .doc extension.  Can you explain what is going on in this particular matter.
With apologies for creating more confusion, but that is my current status!
Appreciatively, Bruce
Win7-unexpectedShutdow-Minidump-.png
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39761746
Haha, seems the problem is never gonna resolve :)

First of all, virtual machines on the mac specifically Parallels and specifically windows 7 are very very unstable and you SHOULD do a regular backup! And remember not to do your important things in there or have a backup.

Second, I think the original drivers in windows 7 are corrupted,
Try the following:
1. Start menu > Type : System restore and open it.
Then Restore your Windows 7 to the time before Drivermax.
2. Start menu > Run > Sfc /scannow
This will replace any bad files with the windows 7 original version.


And regarding the disappeared VM I don't have anything to say :)
I should say I don't know
0
 

Author Comment

by:R_Bruce_Morris
ID: 39763982
Hi kpax77: I ran the sec /scannow program with the result that no integrity violations were detected by Windows Resource Protection during the verification phase (see attached file).
Windows 7 appears to be operating correctly. since I was able to open Quicken XG 2007 and enter transactions.
I am still mystified why the Windows7.pvm file cannot be located!
Bruce
sfc--scannow-results-2014-01-07-.png
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39764723
To find the PVM file, do the following:

1. Right click  on the "Windows 7" in the VM list
2. Select "Show in Finder"

You should see your pvm now!

Right click on VM
Good luck
0
 

Author Comment

by:R_Bruce_Morris
ID: 39774149
Hi kapx77: I apologize for the delay, but I have been in transit from Kingston, ON to Largo, FL since last Saturday.
I was unable to achieve your recommended resolution to locating Windows 7.pvm.  However, I did notice that the subject file was on my Mac OS desktop!  I moved that file from the desktop to its correct Parallels folder.  I was then able to open Parallels Desktop.app, and open my Quicken XG 2007 application, and enter some transactions, after which I was able to backup the application on my Lexar USB memory stick.
Regrettably, all is still not well, because the Parallels Desktop.app program caused Windows 7 VM to crash, with a DRIVER_IRQL_NOT_LESS_OR_EQUAL tcpip.sys driver error!  The WIN7-PARALL external USB My Passport Essentials HD short-cut was displayed on the Mac OS desktop, but the © Windows 7 icon was not displayed.
After the Windows 7 VM crash, the Parallels Desktop.app was re-opened, apparently successfully, since I was again able to open my Quicken XG 2007 application.
This cycle of opening the Windows 7 VM, opening an Windows 7 application, and crash of Windows 7 was repeated several times, with the same tcpip.sys driver error.
I tried my PhotoSuite 13 application, part of Roxio 2012, apparently successfully.
All of my devices appeared to be displayed on the Finder display (see attached file, a snapshot of the Bruce's MAchine devices).
I am operating my MacBook Pro on BrightHouse Roadrunner network here in Largo, FL, with a Belkin N150 Wi-Fi router.  This is the same configuration with which I operated successfully last year here in the same unit in Largo, FL.
I still do not know what else to do to further resolve this issue!
Any further suggestions?
Appreciatively, Bruce
Finder-Mac-OS-Devices-2014-01-11.png
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39775385
Welcome back :)
Start your VM and go to this directory in the win7 VM:
C:\windows\minidump

take the latest 3 ones (based on the file dates) and zip them up and upload em here ...

P.S> Perhaps the original problem is solved! I don't know how many problems are awaiting us. For eternity :)
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:R_Bruce_Morris
ID: 39777833
Hi kpax77:

As requested, I attempted to attach the last three mini dump files (regrettably, I have not yet registered my WinZip product, so I could not zip the files):

011114-12906-01.dmp, 011114-34093-01.dmp, 011114-11796-01.dmp, each 274K

However, on my attempt to upload the selected first file, the "uploading" window continued for over 15 minutes,before I had to stop the operation.  Will the webpage system not accept "vanilla" .dmp files (even at only 274 K in size)?

BTW, Windows 7 VM appears to be working correctly, except for my last mentioned failure on the tcpip.sys driver crash).

Appreciatively, Bruce
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39778103
I don't see anything attached here, only the names.
And also ZIP has been integrated to windows since windows ME as far as remember!
You can download Winrar , that's a very cool tool to compress and view your files.

How to zip files in windows;

Right click in a empty area of folder or desktop
New submenu
Compressed Zip folder

After that drag your files on the zip folder to compress them
0
 

Author Comment

by:R_Bruce_Morris
ID: 39778193
Hi kpax77:
Any explanation for why the "vanilla" .dmp file (267K) cannot be uploaded?
If I right-click on one of the .dmp files, I get an option to "Quick compress", with a sub-menu option to "create Zip-folder".  However, when save is selected, an error message is displayed that states "Unable to compress the file named, Access is denied".
If there is no adequate approach to obtain access to the .dmp file to compress it?
Bruce
0
 
LVL 10

Assisted Solution

by:Arman Khodabande
Arman Khodabande earned 500 total points
ID: 39778351
If you are an administrator you shouldn't get Access denied!
Just copy and paste those three files to a folder on your desktop and Make a new empty zip file on your desktop. Then drag that folder to your zip file and upload it. Simple.
Don't use any Quick compress option. And remove any Compression products you installed.
If you wanna buy a compression software , Winrar is the best.
If you want a free and nice one 7zip is the best.
0
 

Author Comment

by:R_Bruce_Morris
ID: 39779052
I am an Administrator, but I get Access Denied even for 7-zip!
The folder with unzipped dip files is attached (for some reason, the upload worked this time!).
Bruce
010514-11796-01.dmp
011113-12437-01.dmp
011113-12437-01.dmp
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39780469
The problem seems to be from one of the network drivers that Drivermax installed on your system! It could be anything!
I told you to restore from backup! :)
Now it's hard to find out which driver is causing the panic!
Try rolling back your lan wired card to default driver...
0
 

Author Comment

by:R_Bruce_Morris
ID: 39782916
In respect of restoring from backup, my challenge was losing all of the changes in my total system from the last Windows 7 backup of 16 Dec 2012!
I acknowledge that I have created a "monster" scenario with the ill-effects from the use of DriverMax Pro.
I have suffered yet another Windows 7 VM crash, following downloading and installing the latest four important Windows 7 updates today.
With respect to my LAN wired modem and associated Wi-Fi router, I am operating from a new  NetGear CDG24G cable modem from BrightHouse Networks, and my own Belkin N150 router here in Largo, FL.  Hence, I doubt that either of these device configurations could be the root cause, or even contributing to the ongoing issue of Windows 7 VM crashes from the tcpip.sys driver failure.
Was there anything from the dip files that I provided that would point to a problem area?
Is there any effective troubleshooting tool that could contribute to finding a resolution?
Thanks again, Bruce
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39783494
All of them pointed to a corrupt or inappropriate network driver.
And I should say that the problem doesn't relate to your physical modems or routers.
Your virtual machine has a virtual Lan interface which needs original drivers to work.
And now you have replaced it's original drivers with the drivers of a real device! That's why it crashes. Red this and roll back all your Network adapters in the device manager.
Click here...
0
 

Author Comment

by:R_Bruce_Morris
ID: 39784200
Thanks.  But, before I embark on this recommended process, why does Reinstalling Windows Tools not resolve the driver issue?
I tried to do so, but the Windows 7 VM crashes continued, although I was able to open and operate my Quicken XG 2007 successfully, including backing it up to my Lexar USB device.
Appreciatively, Bruce
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39784491
I don't really know what's going on there
The only solution I can come up with is that you remove Parallels tools and then roll back your network drivers to their defaults (or uninstall them if the roll back is not applicable) and then reinstall the latest Parallels tools...

Good luck
0
 

Author Comment

by:R_Bruce_Morris
ID: 39790649
Hi kpax77:
When you say "latest Parallel Tools",  what is the source of the relevant files?
By my "network drivers", do you mean those for my Netgear cable modem and Belkin router?
I cam across the following from a search in the Parallels Forum:
"From: http://forum.parallels.com/showthread.php?112030-Parallels-Tools-Shared-Profile-in-Windows-7-Constantly-forces-logout/page2
May 9, 2013, 02:31 AM #26 ClaytonS  

  Reinstall Parallels Tools
Solution is Simple
- Disable Profile Sharing
- Reinstall Parallels Tools
- Enable Profile Sharing

  Originally Posted by cdfergus  
I know that this was over 6 months ago - but why hasn't this been patched with newer releases? I have 8.0.18483 (Rev.860857 Mar 30,2013) and have this problem as well.
I see that there was a .reg file that would fix the problem; however, the person who hosted it has since pulled it.
Any suggestions?
Mahalo"
I applied this suggested remedy.  To date I have not had a recurrence of the crash caused by tcpip.sys.  However, on startup of Windows 7 VM, the "Recovered from an unexpected shutdown" window still appears with the options to boot up in Normal, or Safe Mode.
Also, the Windows 7 desktop no longer comprises the duplicate icons of Screen Shots that had appeared following some previous attempts to rectify the "amends".
Bruce
0
 
LVL 10

Assisted Solution

by:Arman Khodabande
Arman Khodabande earned 500 total points
ID: 39791235
You said:
By my "network drivers", do you mean those for my Netgear cable modem and Belkin router?

I said:
And I should say that the problem doesn't relate to your physical modems or routers.
Your virtual machine has a virtual Lan interface which needs original drivers to work.

As far as I know your problem is totally different from the link you gave me!
You don't have a log off problem, your problem is BSOD due to bad drivers.  And I gave you the solution in my previous comments.
I don't know anything about that REG fix, you could post your problem there or ask the author to upload it again. sorry
0
 

Author Comment

by:R_Bruce_Morris
ID: 39792347
Hi kpax77:
Thanks for the clarifications.
In a previous post, you said:
"The only solution I can come up with is that you remove Parallels tools and then roll back your network drivers to their defaults (or uninstall them if the roll back is not applicable) and then reinstall the latest Parallels tools…"
I do not fully understand your proposed solution.  
Firstly, are the network drivers not part of Parallels Tools (hence, if I uninstall my current Parallels Tools, they ought to be included)?  If they are not, where do I find them to uninstall them?  Where do I find the Parallels Tools to perform the uninstall (unless activating the Reinstall Parallels Tools automatically uninstalls the current version)?
Secondly, where do I locate the latest Parallels Tools to install to replace the uninstalled ones (i.e. what is the source of the latest Parallels Tools)?
Appreciatively, Bruce
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39792563
"Firstly, are the network drivers not part of Parallels Tools"
Yes they are, but you need to remove them because apparently they are mixed with the Drivermax drivers. you need to remove all network drivers and reinstall a fresh Parallels tool.

" If they are not, where do I find them to uninstall them?  Where do I find the Parallels Tools to perform the uninstall "
My Computer > On the top bar > Uninstall or change a program > find Parallels tools and uninstall.

"Secondly, where do I locate the latest Parallels Tools to install to replace the uninstalled ones"
Click here for updating Parallels tools or here to reinstall tools.
0
 

Author Comment

by:R_Bruce_Morris
ID: 39795433
Hi kpax77:
I finally contacted Parallels, Inc via telephone (without having to pay a service charge because my support code has expired).  I clarified that my product (Parallels Desktop 7 Switch to Mac) is, apparently, the same as Windows 7 - Parallels Desktop, the title most often used in the literature regarding problems with the product.
The Parallels representative did not understand what the implications were of my re-installation of vanilla Windows 7 Home Premium - because it had been somehow corrupted beyond restoration, and my recovery of my backed-up Windows 7.pvm file.
They are sending me instructions, via email, to use to accomplish an uninstall of Windows 7 - Parallels Desktop (the Windows 7 Virtual Machine), plus the re-installation.  However, I understand that such instructions (possibly the same two references which you provided via hotlines) will not address the removal of all Windows drivers i.e. those DriverMax drivers which have caused the corruption/damage to my configuration e.g. registry entries.
I will report back once I have received and reviewed the set of instructions from Parallels, Inc.
I also need to confirm whether upgrading from Windows 7 - Parallels Desktop to Windows 9 - Parallels Desktop and Mac Maverick (OX 10.9) would be a possible resolution to my rather severe problems.
Appreciatively, Bruce
0
 

Author Comment

by:R_Bruce_Morris
ID: 39798839
Hi again kpax77:

I believe that I finally have the appropriate process for uninstalling and re-installing the Windows 7 VM (Windows 7.pvm file).

I need one last clarification regarding the removal/uninstallation/deletion of the offending Windows drivers, caused by the inappropriate use of DriverMax Pro.

Is it simply a case of deleting the offending drivers from the Windows 7 VM - as located using the Control Panel/Hardware and Devices contents:
"There were four (4) Parallels devices reported as NOT working:
Parallels Audio Controller
Parallels Memory Controller
Parallels Mouse Synchronization Device
Parallels Tool Device  
In selecting the Parallels Audio Controller device properties, the driver files were all Microsoft provided:
C:\Windows\system32\drivers\drmk.sys
C:\Windows\system32\drivers\ksthunk.sys
C:\Windows\system32\drivers\portcls.sys
C:\Windows\system32\DRIVERS\prl_sound.sys
C:\Windows\system32\SysFxUl.dll
C:\Windows\system32\WMALFXGFXDSP.dll
For the Parallels Tool Device, the Driver file was:
C:\Windows\system32\DRIVERS\prl_tg.sys"
 
from the Windows folder in which they are stored?  Or is there a more complex process for "uninstalling" each of them, such that the Registry items are removed appropriately (presumably, incorrect/corrupted registry entries are at least part of the problem)?

  I have the RevoUninstaller program in my Windows 7 set of applications (it appears to do a more complete job of cleaning up non-relevant files and registry entries following the "native" uninstall process of the program being uninstalled).  Is it possible to use this program, although I seem to need to delete non-needed Windows 7 driver files - plus any associated Registry entries?

Hopefully, I am finally close to resolving this long-outstanding frustrating problem!

BTW, do you have any advice regarding the process of upgrading my MacBook Pro to Windows 9 - Parallels Desktop and Mac OS Maverick (10.9.1) - should that ultimately be required to fully resolve my current recurring Windows 7 VM failures?

Appreciatively, Bruce
0
 
LVL 10

Assisted Solution

by:Arman Khodabande
Arman Khodabande earned 500 total points
ID: 39800060
And I don't understand why you want to uninstall or remove your windows 7 pvm file!!
That's not needed.
Just repair your drivers as I say and the problem gets solved.
regarding the problematic tools drivers, you can right click on each device and choose "Uninstall" . Don't use any programs like revo , they may make the situation worse.
Uninstall the drivers with the yellow sign and then Install Parallels tools again.
That should patch you up for now.

If that costs money to upgrade , I think that's not necessary because this version works fine if you do procedures right. If upgrading to version 9 is free, do it.
0
 

Author Comment

by:R_Bruce_Morris
ID: 39801458
Hi kpax77:
I finally "muddled" my way through the process in Control Panel/Hardware/Devices and Printers/OWNER-PC (Windows 7 VM) properties to uninstall all four of the non-working Parallels device drivers.  I then installed Parallels Tools from the Virtual Machine menu.
On re-starting Windows 7 VM, as required following the Parallels Tools installation, all four previously malfunctioning Windows 7 drivers were indicated as being successfully installed.  Indeed, two extra Windows 7 drivers were installed (as shown in the Control Panel/Hardware/Printers and Devices/OWNER-PCproperties displays);  these were Parallels Paravirtualization driver and Parallels Display Adapter (WDDM).
I must note that on restarting Windows 7 VM, the Windows Error Recovery window was initially displayed, with Normal mode being selected.  However, on repeating a restart, the WER window is no longer displayed.
But, I did note that, during the re-boot process, "Windows 7 Build 7601. This copy of Windows is not genuine." was displayed in the lower right corner, just before the desktop icons began to appear.
It would now appear that my Windows 7 virtual machine is functioning as it should (unless the apparent fact of an non-genuine copy of Windows 7 ought to be of serious concern to me!).
I will wait a few days before closing this agonizingly log and complex post.
I will also delay any action to upgrade either my Windows 7 Parallels Desktop or my Mac OS until I determine if any serious problems remain with my current "repaired" configuration.
Appreciatively, Bruce
0
 
LVL 10

Expert Comment

by:Arman Khodabande
ID: 39802431
Great!

"Windows 7 Build 7601. This copy of Windows is not genuine."
This message indicates that your copy of windows is not properly activated.
In this case this method may help.

If that didn't help you may be required to repair your windows.
0
 

Author Comment

by:R_Bruce_Morris
ID: 39807785
Hi kpax77:
I am pleased to report that your recommended method for correcting the "not genuine copy" of Windows 7 finally worked (although not on my first attempt).
In my system, the C:\Windows\System32>SLMGR –REARM command resulted in the C:\Windows\System32> line being repeated with the pop-up window “Windows Script Host – Command completed successfully. Please restart your system for the changes to take effect.”  The Windows 7 VM was restarted, with the result of an apparently “clean” Windows 7!
Note that the startup process is exceedingly slow, with the desktop icons display going through three iterations, before the process is complete.  The system also goes into “Click to Resume” mode almost immediately after startup appears to be complete!  The Garmin updater application now appears to be the only one to be displayed briefly during the startup process, i.e. the RoboForm application no longer appears during the process.
I should now be able to close this excruciatingly long and complex post.  Hopefully, I will benefit from the many painful lessons learned, e.g. do not take the drastic step of attempting a re-install of Windows 7 before checking with a reliable source (such as Experts-Exchange); do not install/use any Windows 7 application (such as DriverMax Pro) on the Windows 7 Virtual Machine without checking first with a reliable source; always clarify advice/counsel provided in respect of proposed resolutions. before attempting to implement them; and, last but not least, ensure that relevant/applicable sources are researched before seeking advice/counsel on a real/perceived problem.
Thanks again for your patience/perseverance in assisting me to finally resolve this very severe issue with my MacBook Pro / Windows 7 - Parallels Desktop (Windows 7 virtual machine) system.
Appreciatively, Bruce
0
 
LVL 10

Assisted Solution

by:Arman Khodabande
Arman Khodabande earned 500 total points
ID: 39808581
Glad to here that your problem is now solved.
You're welcome.

As a last advice, To improve your startup speed, try disabling the unnecessary programs from loading during startup process.
You can either disable them from starting from their respective settings or using the "msconfig" tool to disable them. I can't explain more about the second one because that is not relevant to this topic. You can search the net for the application of msconfig.
Here's a small tip to get you started, click here. (after going there select your os as windows 7)

Good luck
Looking forward to finalizing this topic soon
0
 

Author Comment

by:R_Bruce_Morris
ID: 39810663
Hi kpax77:
I finally accomplished a reduction in Win7 VM startup items to six (6), with eleven (11) of the total of seventeen (17) unchecked.
I discovered a SmartGuard execution, trying to delete the previous "snapshot", preparatory to executing a new "snapshot". Through an Internet search, I discovered that "SmartGuard" is, allegedly, a virus.  I have no idea how the virus was able to be installed on my system!  
However, before doing so, I experienced a glitch in that I could not get the Windows 7 Parallels.app to display the Windows 7 VM desktop (so as to execute the msconfig operation).  I terminated operations by performing a Mac OS shutdown (while the Sophos program was still operating). I executed a Sophos Virus Removal Tool  program (complementary to my MalwareBytes Pro application, which I left in the Startup list), as recommended by the website which had identified the "SmartGuard" as a virus. It is possible that both the anti-virus programs could have been executing concurrently (which I am quite certain ought not to have been allowed to happen).
After a restart of the Mac OS system, the relevant Windows 7 VM did re-appear, such that I was able to complete the msconfig operation, as recommended.  However, I do note that the startup process was not improved by very much!
Neither Anti-virus program was able to detect the "SmartGuard" virus; hence, I suspect that the Internet website may not have been accurate in identifying it as a virus?
Another potential remaining glitch in my Windows 7 VM configuration is that, from the Windows 7 Application folder on the Mac OS task bar, selecting my Bridge Baron 19 application resulted in an error "There is no default application specified to open the document Bridge Baron 19". The same error was displayed when attempting to start the Quicken XG 2007 application, or indeed any of my Windows 7 applications, from this folder.  Does this folder only contain documents  (previously, I had used this folder to start several applications on several different occasions)?
Hopefully, the closing of this topic post will not continue much longer (but I cannot surmise what has changed with the contents of the Windows 7 Application folder on the Mac OS task bar)!
Appreciatively, Bruce
0
 
LVL 10

Assisted Solution

by:Arman Khodabande
Arman Khodabande earned 500 total points
ID: 39815896
You shouldn't have installed 2 Antimalware softwares on one windows!!
That reduces the system performance heavily or may even cause some conflicts and crashes...
Keep only Malwarebytes and start a free trial for pro version and update it . then scan the VM.
I can not understand your explanation about those documents ... Were they shortcuts?
And also that is completely non-relevant to this topic, we've been talking off topic for a long time please close this topic and ask your other problems on newer topics.
0
 

Author Closing Comment

by:R_Bruce_Morris
ID: 39816633
Regrettably, my "muddling" through so many suggestions to resolve the problems has caused many exchanges with the Experts.
I am quite certain that the failure to fully resolve the issues with my Mac OS / Windows 7 virtual machine rests primarily with my many excursions into areas  not recommended by the Experts.
I will review my latest status (and review my 39 pages of notes which I have maintained during this very lengthy process), and consider resubmitting a new post with an appropriate title.
Many thanks for the extreme patience and perseverance demonstrated by the experts!
Appreciatively, Bruce
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now