Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cannot connect Surface Pro 2 (Windows 8) to SBS2011 Exchange server using Outllook 2013

Posted on 2013-12-28
27
Medium Priority
?
2,753 Views
1 Endorsement
Last Modified: 2013-12-29
When trying to connect a Surface Pro 2 (Windows 8) to our SBS2011 Exchange Server I get error:

     "The connection to Microsoft Exchange is unavailable. Outlook must be online or
      connected to complete this action."

I can connect using the built in Mail client in Windows 8. I can connect form several windows 7 / Android / iPAd, etc accounts.  Only get issues with Surface/Outlook 2013

Also if I go to https://remote.XXXXXXX.com it is a blank page from the Windows 8 PC, but works great from 7/vista/xp

What am i missing???
1
Comment
Question by:Alisanne
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 17
  • 8
  • 2
27 Comments
 
LVL 59

Expert Comment

by:Cliff Galiher
ID: 39744406
The built in win8 mail cloent, android, and iOS, all use exchange activesync. A protocol heavily optimized for mobile devices. Outlook 2007, 2010, and 2013, on the other hand, use Outlook Anywhere, which is a different protocol. So yes, it is entirely possible for one to work and have the other fail.

Start by testing your server for Outlook Anywhere problems. Www.testexchangeconnectivity.com has tests for just that sort of thing. Knowing what the error is a necessary first step towards fixing it.
0
 

Author Comment

by:Alisanne
ID: 39744421
Outlook 10 connects fine. But I will run thru the testing site.
0
 
LVL 59

Expert Comment

by:Cliff Galiher
ID: 39744426
Outlook 2010 on a local LAN still defaults to MAPI. 2013 now uses OA whether remote OR local. That was a significant change in 2013 and is documented in the release notes.  OA *must* work for 2013 to work where it could be broken and 2010 and EAS clients would work okay... never indicating that OA was broken.
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 22

Assisted Solution

by:Olaf De Ceuster
Olaf De Ceuster earned 2000 total points
ID: 39744427
From surface log onto the RWW and download the certificate. (In Public downloads) and install. (If using IE 10-11 , use in compatibility mode)
Once installed try opening outlook and connect using RPC over https. (Let us know if you need a hand with that)
Can you logon using OWA?
Hope that helps.
Olaf
0
 

Author Comment

by:Alisanne
ID: 39744903
OWA Works from the system.  RWW Does not but I will set to compatibility mode and try again. Thank you.
0
 

Author Comment

by:Alisanne
ID: 39744998
Auto discover Failed, But Manually setting server worked. Which (to me) explains why I can connect remotely with 2010 and not 2013, because 2010 lets me define the server/domain/etc. and 2013 does not.

Auto-discover errors:


      Testing RPC/HTTP connectivity.
       The RPC/HTTP test failed.
       
      Additional Details
       
Elapsed Time: 946 ms.
       
      Test Steps
       
      The Microsoft Connectivity Analyzer is attempting to test Autodiscover for auditor@xxxxxxx.com.
       Testing Autodiscover failed.
       
      Additional Details
       
Elapsed Time: 945 ms.
       
      Test Steps
       
      Attempting each method of contacting the Autodiscover service.
       The Autodiscover service couldn't be contacted successfully by any method.
       
      Additional Details
       
      Test Steps
0
 

Author Comment

by:Alisanne
ID: 39745001
How do I setup a DNS entry for auto-discover?
0
 

Author Comment

by:Alisanne
ID: 39745020
Tried:

1) Set compatibility mode for remote.xxxxxxx.com
2) Login to RWW (Successfully)
3) Download sbs Certficate
4) Install 3rd Party Certificate (Go Daddy)
5) Attempt to login thru outlook, Error:

Cannot Start Microsoft Outlook. Cannot open the Outlook window. The set of folders cannot be opened. The file C;|Users\xxxxx_000\AppData\Local\Microsoft\Outlook\XXXXXXX.ost is not an Outlook file (.ost).

I press OK, then get:

The connection to Microsoft Exchange is Unavailable. Outlook must be online or connected to complete this action.

At this point I think I need a DNS entry for auto-discover. Any advice would be appreciated.
0
 

Author Comment

by:Alisanne
ID: 39745022
Also, I verified that Autodiscover is enabled in SBS2011.
0
 

Author Comment

by:Alisanne
ID: 39745033
I have found this article: http://www.thirdtier.net/2009/02/setting-up-an-external-autodiscover-record-for-sbs-2008/

Highlight:
The details on how to set this record up are all in KB940881, but I’ll briefly summarize it here:

1. Get rid of any CNAME or A records for “autodiscover”, and any wildcard “*” records in the public DNS zone. This is a critical step, so don’t just drift past it.
2. Build the SRV record to look like this:

Service: _autodiscover
Protocol: _tcp
Port Number: 443
Host: remote.smallbizco.net

Will this solve my problem?
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 39745034
You are doing this inside the sbs domain?
Or from a remote location?
If you are doing this remotely you need to try again with an active VPN. (Need to allow VPN connections on the SBS box)
Also need to manually add the dns suffix for your sbs domain and add your sbs server IP as primary DNS.
Run a manual setup only (use a new profile).
Also make sure the SBS has the latest rollup installed. (Or at least rollup 3)
Let me know.
Olaf
I does work so don't give up.
0
 

Author Comment

by:Alisanne
ID: 39745058
From a remote location. The goal was not to need a VPN. I thought (I could be totally wrong) that Outlook Anywhere did not require a VPN.
0
 

Author Comment

by:Alisanne
ID: 39745076
Added DNS record:

Service: _autodiscover
Protocol: _tcp
Port Number: 443
Host: remote.xxxxxxx.com

And Remote connectivity analyzer test worked for Outlook Anywhere (RPC over HTTP). Now to create new profile and try again.
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 39745083
It only needs VPN for the initial setup I have found.
You can turn  it off after that.
Olaf
0
 

Author Comment

by:Alisanne
ID: 39745101
Created a new (Test) account on Surface to start from scratch.

1) Add xxxxxxx.com to trusted sites
2) Set to compatibility mode for remote.xxxxxxx.com
3) Installed the SBS certificate
4) Installed 3rd Party (Go Daddy) certificate
5) Ran Outlook (Manual Setup)
6) Checked Connect to Microsoft Exchange using HTTP (Under Outlook anywhere)
7) Set proxy server to https://remote.xxxxxxx.com

Got a new message - "You must restart Outlook" Then got a Windows Security pop-up asking for credentials.

8) set to xx\user to change domain.
9) After restarting Outlook, it asks me for my credentials.
10) Restarted system and tried to load using the newly created test user account

Get: "The connection to Microsoft exchange is unavailable"

IT seems like Im making progress...  ...but very frustrating.
0
 

Author Comment

by:Alisanne
ID: 39745106
When I try to to open Mail (From control Pannel) to delete/create new profile, I get:

Windows host process (Rundll32) has stopped working.
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 39745114
Run a repair on outlook.
Delete all Exchange profiles before doing so.  You'll have to create a generic pop account as default profile in order to delete the exchange account.
Rin Ipconfig /flushdns before running the  VPN and starting again. Add your RPC details manually and do NOT use offline settings (cashed) for now.
Olaf
0
 

Author Comment

by:Alisanne
ID: 39745115
@ Olafdc - I have not accessed thru VPN before. How do I set that up to test?
0
 
LVL 22

Accepted Solution

by:
Olaf De Ceuster earned 2000 total points
ID: 39745123
In SBS 2011 console Network>connectivity>Configure a VPN on right hand side.
Make sure VPN is ON on left hand side and remeber the user you gave access to. (Preferred  an admin account)

On workstation:
Under networking: Se up a new connection> VPN > use remote.xxx.xx and use credentials in format xx\user of an account with VPN access (You can check that under users in SBS console)

RPC settings details.
0
 
LVL 22

Assisted Solution

by:Olaf De Ceuster
Olaf De Ceuster earned 2000 total points
ID: 39745125
rpc
0
 

Author Comment

by:Alisanne
ID: 39745131
Added a pop account, still cant open the mail icon to delete the other profiles. How can i get the exchange profiles deleted? After closing/opening Outlook it goes back to trying to load the exchange account.  

I am still not sure how to start/run the VPN.  Thank you for your patience.

About to reset the surface again...
0
 

Author Comment

by:Alisanne
ID: 39745146
Is there any difference between office 2013 preloaded on the surface and what I would download from the Microsoft site?

If I reset the surface and start all over again what would the basic steps be to get connected.

How do I start the VPN before connecting to Outlook
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 39745150
Good idea: Reset surface and start again. (they act like toys, not computers fromtime to time)
Server: SBS console>Network> Connectivity>Configure a VPN>Allow users to connect to the server by using a VPN>Finish wizard.
+ Forward port 1723 to your server IP from your firewall.
SBS console>Users and Groups>choose your account>Edit user account>Remote Access> Tick the box next to: User can access VPN> OK

On workstation:
Controlpanel>All control panel Items>Network and Sharing Center>Set Up a new connection or network>Connect to a workplace>Next>Create a new one.next> choose your existing internet connection (VPN)>Use "remote.xxx.xx" for Internet address> Create
Click on connection to connect.
Hope that helps,
Olaf
0
 

Author Comment

by:Alisanne
ID: 39745172
Thank you for posting I will try that and update
0
 

Author Comment

by:Alisanne
ID: 39745241
Setup VPN/Outlook as above, got connected just fine. Does the VPN have to be connected from now on?

Thank you!
0
 

Author Closing Comment

by:Alisanne
ID: 39745245
I referred back to your prior comment about only needing VPN for initial setup.  Thank you for working through this with me. You were very clear in your instructions.
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 39745306
Glad you got it going.
Olaf
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
You need to know the location of the Office templates folder, so that when you create new templates, they are saved to that location, and thus are available for selection when creating new documents.  The steps to find the Templates folder path are …
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question