Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Cannot open user default database. Login failed. After upgraded to window 8.1

Posted on 2013-12-29
8
Medium Priority
?
374 Views
Last Modified: 2014-02-06
Hi,
My local database connection was all okay until i upgraded to window 8.1. I'm using web developer 2008 express and SQL Server 2008 R2.

The error as attached. Been trying to seach for solution, but to no avail. Please help :(
0
Comment
Question by:tangteng78
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 39744885
No attachment.
0
 

Author Comment

by:tangteng78
ID: 39744897
Sorry Dave. Did you missed out anything? As i can't see any comment.
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 39744898
Dave wanted to tell you that WE are missing the attachment containing the error message here.
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 

Author Comment

by:tangteng78
ID: 39744899
Ohh...sorry guys. There you go.
login-failed.jpg
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 39744914
From which OS did you upgrade? You might have to reapply the security settings of your local MSSQL server.
0
 

Author Comment

by:tangteng78
ID: 39744923
From window 8.0 to 8.1

How do i reapply the security setting of the MSSQL server?
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 39744946
If only I knew ... 8.0 to 8.1 should not have that effect, but maybe it is because the Microsoft Online accounts are more tightly integrated now.
If noone comes up with a better idea, you can do a repair install of MSSQL. That way you will fix authentication issues, but there might be a more direct way.
0
 
LVL 70

Accepted Solution

by:
Scott Pletcher earned 2000 total points
ID: 39746879
Make sure the default db for that login is set and that it actually exists.

--NOTE: this code only works if this is a Windows User login, NOT a Windows Group login.
ALTER LOGIN [Ethan\EngTeng] WITH DEFAULT_DATABASE = master
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows gives you an overview on SQL Server 2016 row level security. You will also get to know the usages of row-level-security and how it works
The article shows the basic steps of integrating an HTML theme template into an ASP.NET MVC project
Familiarize people with the process of utilizing SQL Server functions from within Microsoft Access. Microsoft Access is a very powerful client/server development tool. One of the SQL Server objects that you can interact with from within Microsoft Ac…
Using examples as well as descriptions, and references to Books Online, show the documentation available for date manipulation functions and by using a select few of these functions, show how date based data can be manipulated with these functions.

597 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question