?
Solved

Terminal server user - restrict to specific session

Posted on 2013-12-29
9
Medium Priority
?
1,341 Views
Last Modified: 2014-02-16
Hello

We have a particular client running server 2008 R2 on a single server installation with remote desktop services (terminal server) configured

We have an issue (due to poor software support) where if the remote user gets a session ID greater than 2, that the remote printing does not work for the application

Windows printing works fine, its just this particular application that has a problem

Is there a way to specify a session ID for a remote user to always have the same session ID?

For instance we would want 'remoteuser' to ALWAYS have session ID 2, regardless of when other users login to this server remotely

The only other users who connect to this server are ourselves; and it does not affect us as to what session ID we get
0
Comment
Question by:HeronTech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
9 Comments
 
LVL 38

Expert Comment

by:Mahesh
ID: 39745624
By default, a terminal server allows you to reconnect to a disconnected session from any computer.
Only option to get same session ID for user is to configure \ restrict users to a single session on terminal server and the user must leaves the session in a disconnected state, so that user will automatically reconnect to that session only next time when connected.

Check below article to enable single session restriction through Terminal server itself or through GPO
http://technet.microsoft.com/en-us/library/cc754762.aspx

Only you need to increase timeout for disconnected sessions, otherwise if session get disconnected, it will create new session with new session ID

I hope this is the setting you are looking for. Correct me if wrong please

Mahesh
0
 
LVL 1

Author Comment

by:HeronTech
ID: 39745647
I was hoping for a more permanent fix than to leave the one user perpetually connected; and getting the same ID whenever they logon

I had a Microsoft case open and they basically said that its by design, and whoever logs in first gets the lower ids.

It was more if anyone else had come across this and an appropriate solution
0
 
LVL 38

Expert Comment

by:Mahesh
ID: 39745669
Thanks for confirmation

Really I don't see any option other than above as it is some kind of dynamic behavior and can't be controlled

May be its not the session id which restricting application from printing, root cause might be different and can be addressed by software vendor hopefully

Mahesh
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
LVL 3

Expert Comment

by:Detlef001
ID: 39745815
I don't there can be a different session id for the same , since at every log in the time interval changes. Moreover for "Restrict Terminal Services users to a single session"? Because if you set the group policy, the tsconfig should grey out the setting for the same policy. Since you could also use the tsconfig to set the policy, I am wondering whether the GP really got applied.
0
 
LVL 1

Author Comment

by:HeronTech
ID: 39798972
Also with a restrict to a single session option, and holding a perpetual session open, this would need to be then logged back in first each time the server reboots, which would also be an issue.
It does appear that noone has to deal with session IDs at this level, will hope for a vendor fix but not expecting it.
0
 
LVL 1

Author Comment

by:HeronTech
ID: 39849736
I've requested that this question be closed as follows:

Accepted answer: 0 points for HeronTech's comment #a39798972

for the following reason:

Waiting on the vendor to ultimately fix this issue
0
 
LVL 1

Accepted Solution

by:
HeronTech earned 0 total points
ID: 39851949
There isnt a solution available from the experts - but the comments here may prove useful for anyone else having similar problems. ultimately we are still waiting on the vendor to fix how their application deals with remote desktop redirected printing - as this is the only vendor that seems to have this particular issue with redirected session ids greater than 2
0
 
LVL 1

Author Closing Comment

by:HeronTech
ID: 39862496
Waiting on vendors to ultimately fix this issue
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question