Link to home
Start Free TrialLog in
Avatar of Skiff-SS-N-23
Skiff-SS-N-23Flag for Kyrgyzstan

asked on

SCCM 2012 R2 installation fails when checking SQL Service broker port 4022 (Requested registry access is not allowed)

Hi Experts,
Faced with a problem during prerequisite check of SCCM 2012 R2 installation.
what i have:
Remote SQL server - MS SQL 2012 CU11 on Windows Server 2012 R2
SCCM R2 server - SCCM R2 on Windows Server 2012 R2

on Database Information page i enter SQL server FQDN and database name; instance is default.
Service Broker Port is by default 4022.
when i press Next error dialog appears:"Requested registry access is not allowed".

Firewall on both SCCM and on SQL server is OFF from beginning.
I tried with firewall on and rules for incoming session for all SQL ports but no way.
Port 1433 is open and OK but 4022 is not accessible and I think error above is because of this. SQL Dynamic ports is disabled also.

Request your solutions ASAP.

thanks
Avatar of Raja Jegan R
Raja Jegan R
Flag of India image

Can you try running the installer by using Run as Administrator once which can help resolve few of the permissions issue.

>> but 4022 is not accessible and I think error above is because of this. SQL Dynamic ports is disabled also

Also check which application is using or blocking the port 4022 and stop those service if required and try installing it once again.
ASKER CERTIFIED SOLUTION
Avatar of Skiff-SS-N-23
Skiff-SS-N-23
Flag of Kyrgyzstan image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Skiff-SS-N-23

ASKER

answer provided was not the solution, I got this answer from MS Communities.
Could you please tell us how you resolved this? None of the solutions I've tried so far, have worked.

Thank you